Base cannot find java on my new laptop

classic Classic list List threaded Threaded
5 messages Options
Anne Wilson Anne Wilson
Reply | Threaded
Open this post in threaded view
|

Base cannot find java on my new laptop

I keep a database of magazine articles, with the file saved on my server
which is accessed by a drive mapping (Y:).  I installed java runtime and
checked the version.  However when I try to run Base I see the page that
lists tables, forms, reports etc., but can't open any of those links.
Every time it tells me that it is unable to connect, since it can't find
java.  (See attachment)

Please can someone point me towards finding what is causing this?  Thanks.

Anne

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Anne Wilson Anne Wilson
Reply | Threaded
Open this post in threaded view
|

Re: Base cannot find java on my new laptop

On 01/06/2020 10:42, Pulkit Krishna wrote:
> On Mon, Jun 1, 2020 at 3:04 PM Anne Wilson <[hidden email]
> <mailto:[hidden email]>> wrote:
>
> I keep a database of magazine articles, with the file saved on my
> server which is accessed by a drive mapping (Y:).
>
> It may be the source of error that the database isn't stored locally.
>
I know things can change, but I used a local Libre Office installation
with this database accessed from the mapped drive, (Y:), exactly as I
have set it up.  Since the new laptop was necessitated by a hard drive
trashing, I can't look back to try to find any other possible culprits.

>
> I installed java runtime and checked the version.  However when I try
> to run Base I see the page that lists tables, forms, reports etc.
>
> Actually they are listed on different pages.
>
> , but can't open any of those links.
>
> Links? What links?

Sure - my bad description.  Along with the attachment reporting lack of
Java, I attached an overview of what I can currently see.  It looks fine
- just as I'd expect, but when I try to open the Display view, most used
as it contains description and images, I get the no-java report.
>
>
> The mailing list removes any attachment. Can you send the attachment
> to me directly?
>
My bad - I should have remembered that.
>
> Please can someone point me towards finding what is causing this?
> Thanks.
>
> Also, I would be help you much more efficiently if you provide other
> technical details such as your operating system, architecture,
> LibreOffice version, which java you use? (oracle or openjava) Java
> version etc.
>
OK - Windows 10 v.1909 64-bit.  Java is Oracle 8, v.251 - I think on the
old laptop I had openjava.  It is installed at C:\Program Files
(x86)\Java\jre1.8.0_251\.  Is this in fact a 32-bit version?  I know LO
says I must have a 64-bit version.

Anything else that would help?

Thanks

Anne

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Anne Wilson Anne Wilson
Reply | Threaded
Open this post in threaded view
|

Re: Base cannot find java on my new laptop

On 01/06/2020 16:03, Pulkit Krishna wrote:
> Oh yes. Now I get your problem. You have installed 32 bit Java. You
> should install a 64 bit java.
> Pulkit Krishna
>
Ah, I suspected it might be so.  I assume I should remove the version
I've got and start again?  I'll make sure it's removed, then look for
the correct  version in the morning.

Thanks for all the help, folks.

Anne

>
> On Mon, Jun 1, 2020 at 8:21 PM Anne Wilson <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     On 01/06/2020 10:42, Pulkit Krishna wrote:
>     > On Mon, Jun 1, 2020 at 3:04 PM Anne Wilson <[hidden email]
>     <mailto:[hidden email]>
>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>     >
>     > I keep a database of magazine articles, with the file saved on my
>     > server which is accessed by a drive mapping (Y:).
>     >
>     > It may be the source of error that the database isn't stored locally.
>     >
>     I know things can change, but I used a local Libre Office installation
>     with this database accessed from the mapped drive, (Y:), exactly as I
>     have set it up.  Since the new laptop was necessitated by a hard drive
>     trashing, I can't look back to try to find any other possible culprits.
>
>     >
>     > I installed java runtime and checked the version.  However when I try
>     > to run Base I see the page that lists tables, forms, reports etc.
>     >
>     > Actually they are listed on different pages.
>     >
>     > , but can't open any of those links.
>     >
>     > Links? What links?
>
>     Sure - my bad description.  Along with the attachment reporting lack of
>     Java, I attached an overview of what I can currently see.  It looks fine
>     - just as I'd expect, but when I try to open the Display view, most used
>     as it contains description and images, I get the no-java report.
>     >
>     >
>     > The mailing list removes any attachment. Can you send the attachment
>     > to me directly?
>     >
>     My bad - I should have remembered that.
>     >
>     > Please can someone point me towards finding what is causing this?
>     > Thanks.
>     >
>     > Also, I would be help you much more efficiently if you provide other
>     > technical details such as your operating system, architecture,
>     > LibreOffice version, which java you use? (oracle or openjava) Java
>     > version etc.
>     >
>     OK - Windows 10 v.1909 64-bit.  Java is Oracle 8, v.251 - I think on the
>     old laptop I had openjava.  It is installed at C:\Program Files
>     (x86)\Java\jre1.8.0_251\.  Is this in fact a 32-bit version?  I know LO
>     says I must have a 64-bit version.
>
>     Anything else that would help?
>
>     Thanks
>
>     Anne
>


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Anne Wilson Anne Wilson
Reply | Threaded
Open this post in threaded view
|

Re: Base cannot find java on my new laptop

On 01/06/2020 16:13, Anne Wilson wrote:

That was indeed the problem.  I can now access and update my database.
Thanks again to both of you.

Regards

Anne

> On 01/06/2020 16:03, Pulkit Krishna wrote:
>> Oh yes. Now I get your problem. You have installed 32 bit Java. You
>> should install a 64 bit java.
>> Pulkit Krishna
>>
> Ah, I suspected it might be so.  I assume I should remove the version
> I've got and start again?  I'll make sure it's removed, then look for
> the correct  version in the morning.
>
> Thanks for all the help, folks.
>
> Anne
>
>>
>> On Mon, Jun 1, 2020 at 8:21 PM Anne Wilson <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>>     On 01/06/2020 10:42, Pulkit Krishna wrote:
>>     > On Mon, Jun 1, 2020 at 3:04 PM Anne Wilson <[hidden email]
>>     <mailto:[hidden email]>
>>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>>     >
>>     > I keep a database of magazine articles, with the file saved on my
>>     > server which is accessed by a drive mapping (Y:).
>>     >
>>     > It may be the source of error that the database isn't stored locally.
>>     >
>>     I know things can change, but I used a local Libre Office installation
>>     with this database accessed from the mapped drive, (Y:), exactly as I
>>     have set it up.  Since the new laptop was necessitated by a hard drive
>>     trashing, I can't look back to try to find any other possible culprits.
>>
>>     >
>>     > I installed java runtime and checked the version.  However when I try
>>     > to run Base I see the page that lists tables, forms, reports etc.
>>     >
>>     > Actually they are listed on different pages.
>>     >
>>     > , but can't open any of those links.
>>     >
>>     > Links? What links?
>>
>>     Sure - my bad description.  Along with the attachment reporting lack of
>>     Java, I attached an overview of what I can currently see.  It looks fine
>>     - just as I'd expect, but when I try to open the Display view, most used
>>     as it contains description and images, I get the no-java report.
>>     >
>>     >
>>     > The mailing list removes any attachment. Can you send the attachment
>>     > to me directly?
>>     >
>>     My bad - I should have remembered that.
>>     >
>>     > Please can someone point me towards finding what is causing this?
>>     > Thanks.
>>     >
>>     > Also, I would be help you much more efficiently if you provide other
>>     > technical details such as your operating system, architecture,
>>     > LibreOffice version, which java you use? (oracle or openjava) Java
>>     > version etc.
>>     >
>>     OK - Windows 10 v.1909 64-bit.  Java is Oracle 8, v.251 - I think on the
>>     old laptop I had openjava.  It is installed at C:\Program Files
>>     (x86)\Java\jre1.8.0_251\.  Is this in fact a 32-bit version?  I know LO
>>     says I must have a 64-bit version.
>>
>>     Anything else that would help?
>>
>>     Thanks
>>
>>     Anne
>>
>


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
PulkitKrishna00 PulkitKrishna00
Reply | Threaded
Open this post in threaded view
|

Re: Base cannot find java on my new laptop

Glad it worked.
Pulkit Krishna


On Tue, Jun 2, 2020 at 5:44 PM Anne Wilson <[hidden email]> wrote:

> On 01/06/2020 16:13, Anne Wilson wrote:
>
> That was indeed the problem.  I can now access and update my database.
> Thanks again to both of you.
>
> Regards
>
> Anne
>
> > On 01/06/2020 16:03, Pulkit Krishna wrote:
> >> Oh yes. Now I get your problem. You have installed 32 bit Java. You
> >> should install a 64 bit java.
> >> Pulkit Krishna
> >>
> > Ah, I suspected it might be so.  I assume I should remove the version
> > I've got and start again?  I'll make sure it's removed, then look for
> > the correct  version in the morning.
> >
> > Thanks for all the help, folks.
> >
> > Anne
> >
> >>
> >> On Mon, Jun 1, 2020 at 8:21 PM Anne Wilson <[hidden email]
> >> <mailto:[hidden email]>> wrote:
> >>
> >>     On 01/06/2020 10:42, Pulkit Krishna wrote:
> >>     > On Mon, Jun 1, 2020 at 3:04 PM Anne Wilson <[hidden email]
> >>     <mailto:[hidden email]>
> >>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
> >>     >
> >>     > I keep a database of magazine articles, with the file saved on my
> >>     > server which is accessed by a drive mapping (Y:).
> >>     >
> >>     > It may be the source of error that the database isn't stored
> locally.
> >>     >
> >>     I know things can change, but I used a local Libre Office
> installation
> >>     with this database accessed from the mapped drive, (Y:), exactly as
> I
> >>     have set it up.  Since the new laptop was necessitated by a hard
> drive
> >>     trashing, I can't look back to try to find any other possible
> culprits.
> >>
> >>     >
> >>     > I installed java runtime and checked the version.  However when I
> try
> >>     > to run Base I see the page that lists tables, forms, reports etc.
> >>     >
> >>     > Actually they are listed on different pages.
> >>     >
> >>     > , but can't open any of those links.
> >>     >
> >>     > Links? What links?
> >>
> >>     Sure - my bad description.  Along with the attachment reporting
> lack of
> >>     Java, I attached an overview of what I can currently see.  It looks
> fine
> >>     - just as I'd expect, but when I try to open the Display view, most
> used
> >>     as it contains description and images, I get the no-java report.
> >>     >
> >>     >
> >>     > The mailing list removes any attachment. Can you send the
> attachment
> >>     > to me directly?
> >>     >
> >>     My bad - I should have remembered that.
> >>     >
> >>     > Please can someone point me towards finding what is causing this?
> >>     > Thanks.
> >>     >
> >>     > Also, I would be help you much more efficiently if you provide
> other
> >>     > technical details such as your operating system, architecture,
> >>     > LibreOffice version, which java you use? (oracle or openjava) Java
> >>     > version etc.
> >>     >
> >>     OK - Windows 10 v.1909 64-bit.  Java is Oracle 8, v.251 - I think
> on the
> >>     old laptop I had openjava.  It is installed at C:\Program Files
> >>     (x86)\Java\jre1.8.0_251\.  Is this in fact a 32-bit version?  I
> know LO
> >>     says I must have a 64-bit version.
> >>
> >>     Anything else that would help?
> >>
> >>     Thanks
> >>
> >>     Anne
> >>
> >
>
>

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy