Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

classic Classic list List threaded Threaded
13 messages Options
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo zusammen,

bitte um Übersetzung der Meldung. Das fehlerhafte Verhalten wurde nach
Prüfung mit LO 6.3.0.1 bestätigt und ist dort ebenfalls vorhanden -
nicht aber bei LO 4.2.8.2 und 5.1.6.2

Ein Check erfordert nur wenige Handgriffe:

- Writer-Dokument anlegen
- Tabelle einfügen (2-3 Spalten und einige Zeilen genügen)
- Tabelle -> Autoformat: irgendeine Tabelle mit eingefärbten Zeilen
- abspeichern im html-Format
- im Browser aufrufen

Hier sind sämtliche Umrandungen sind weg.

Für mich ist die Angelegenheit dringlich, denn ich arbeite fast täglich
mit dieser Funktion.

Viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Heiko Tietze-5 Heiko Tietze-5
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

https://bugs.documentfoundation.org/show_bug.cgi?id=126762

Der style wird 2x in der HTML Datei definiert, was wpohl nicht akzeptiert wird. Bis der Fehler behoben ist, lässt sich das in einem Texteditor manuell korrigieren.

Beste Grüße,
Heiko

On 07.08.19 20:58, Rainer wrote:

> Hallo zusammen,
>
> bitte um Übersetzung der Meldung. Das fehlerhafte Verhalten wurde nach
> Prüfung mit LO 6.3.0.1 bestätigt und ist dort ebenfalls vorhanden -
> nicht aber bei LO 4.2.8.2 und 5.1.6.2
>
> Ein Check erfordert nur wenige Handgriffe:
>
> - Writer-Dokument anlegen
> - Tabelle einfügen (2-3 Spalten und einige Zeilen genügen)
> - Tabelle -> Autoformat: irgendeine Tabelle mit eingefärbten Zeilen
> - abspeichern im html-Format
> - im Browser aufrufen
>
> Hier sind sämtliche Umrandungen sind weg.
>
> Für mich ist die Angelegenheit dringlich, denn ich arbeite fast täglich
> mit dieser Funktion.
>
> Viele Grüße
>
> Rainer
>

--
Dr. Heiko Tietze, UX-Designer and UX-Mentor
Tel: +49 30 5557992-63 | Mail: [hidden email]
The Document Foundation, Kurfürstendamm 188, 10707 Berlin, DE
Gemeinnützige rechtsfähige Stiftung des bürgerlichen Rechts
Legal details: https://www.documentfoundation.org/imprint


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Heiko,

ich schätze, das ist nicht ganz zutreffend - es sei denn, Du meinst das
gleiche, was ich nun beobachtet habe (immerhin aber hat mich Dein
Kommentar auf diese Spur gebracht):

Beim Vergleich zwischen einer korrekten Umsetzung (LO 4) mit einer
fehlerhaften (LO 6) habe ich jetzt festgestellt, dass die von LO 6 mit
zusätzlichem Quelltext durchsetzt ist. Eckpunkt des Versuchs:
Writer-Dokument mit einer Tabelle, die 3 Spalten und 10 Zeilen hat,
Autoformat: "Braun".

Nach dem Abspeichern als html-Dokument findet sich insgesamt 30x der
Ausdruck style="background: xxx" - also genau so oft, wie es bei meinem
Beispiel Zellen gibt: 3x style="background: #663300", 9x
style="background: #996633" und 18x style="background: #ffcc99".
Nachdem alle gelöscht sind, stellt sich die Seite auch im Browser
korrekt dar.

Der Quelltext lässt sich mit einem Texteditor zwar händisch
entsprechend bearbeiten, ist aber ziemlich aufwändig.

Viele Grüße

Rainer

 Am Thu, 8 Aug 2019 09:20:30 +0200
schrieb Heiko Tietze <[hidden email]>:

> https://bugs.documentfoundation.org/show_bug.cgi?id=126762
>
> Der style wird 2x in der HTML Datei definiert, was wpohl nicht
> akzeptiert wird. Bis der Fehler behoben ist, lässt sich das in einem
> Texteditor manuell korrigieren.
>
> Beste Grüße,
> Heiko
>
> On 07.08.19 20:58, Rainer wrote:
> > Hallo zusammen,
> >
> > bitte um Übersetzung der Meldung. Das fehlerhafte Verhalten wurde
> > nach Prüfung mit LO 6.3.0.1 bestätigt und ist dort ebenfalls
> > vorhanden - nicht aber bei LO 4.2.8.2 und 5.1.6.2
> >
> > Ein Check erfordert nur wenige Handgriffe:
> >
> > - Writer-Dokument anlegen
> > - Tabelle einfügen (2-3 Spalten und einige Zeilen genügen)
> > - Tabelle -> Autoformat: irgendeine Tabelle mit eingefärbten Zeilen
> > - abspeichern im html-Format
> > - im Browser aufrufen
> >
> > Hier sind sämtliche Umrandungen sind weg.
> >
> > Für mich ist die Angelegenheit dringlich, denn ich arbeite fast
> > täglich mit dieser Funktion.
> >
> > Viele Grüße
> >
> > Rainer
> >  
>

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Heiko Tietze-5 Heiko Tietze-5
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

On 08.08.19 11:51, Rainer wrote:
> ich schätze, das ist nicht ganz zutreffend - es sei denn, Du meinst das
> gleiche, was ich nun beobachtet habe (immerhin aber hat mich Dein
> Kommentar auf diese Spur gebracht):
> ...
> Der Quelltext lässt sich mit einem Texteditor zwar händisch
> entsprechend bearbeiten, ist aber ziemlich aufwändig.

Genau. Immerhin hast du jetzt einen Workaround ;-)


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Am Thu, 8 Aug 2019 12:31:02 +0200
schrieb Heiko Tietze <[hidden email]>:

> On 08.08.19 11:51, Rainer wrote:
> > ich schätze, das ist nicht ganz zutreffend - es sei denn, Du meinst
> > das gleiche, was ich nun beobachtet habe (immerhin aber hat mich
> > Dein Kommentar auf diese Spur gebracht):
> > ...
> > Der Quelltext lässt sich mit einem Texteditor zwar händisch
> > entsprechend bearbeiten, ist aber ziemlich aufwändig.  
>
> Genau. Immerhin hast du jetzt einen Workaround ;-)
>
Vermutlich wird das Thema irrelevant (ob nur für mich oder auch für
andere, kann ich nicht einschätzen), denn der LO-Generator produziert
noch mehr Fehler - festzustellen mit zwei einfachen Vergleichstests und
anschließender Validierung hier: https://validator.w3.org/:

- Abspeichern (nicht: Exportieren!) einer leeren, unbearbeiteten
  Writer-Seite als html. Die mit LO4.x generierte ist fehlerfrei, bei
  der mit LO 6.x generierten werden 7 Fehler und 6 Warnungen ausgegeben;

- Abspeichern einer Writer-Seite, auf der eine Tabelle mit 3 Spalten
  und 10 Zeilen eingefügt ist, als html: 8 Fehler und 37 Warnungen.

Wenn Formatierungen und Inhalte dazukommen, steigen die beiden Quoten
deutlich an.

Offenbar arbeitet der Generator schon lange nicht mehr sauber: Das
Ergebnis eines weiteren Vergleichstests mit LO 5.x ist mit dem von LO
6.x identisch.

Ernüchternde Erkenntnisse - mit der Folge, dass ich nun wohl auf meine
jahrelange Praxis, mit LO html-Seiten zu generieren, verzichten und
mich grundsätzlich umorientieren muss. Wenn solche Fehler über solche
Zeiträume nicht behoben wurden, kann ich mir nicht vorstellen, dass es
noch dazu kommt.

Viele Grüße

Rainer



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Reiner,

ich habe einmal beim Bugtracker nachgesehen:
https://bugs.documentfoundation.org/buglist.cgi?component=Writer%20Web&order=Importance&product=LibreOffice&query_format=advanced&resolution=---

Den HTML-Export vom Writer aus nutzen sehr wenig Leute. Ich sehe so
etwas auch z.B. im LibreOffice-Forum (https://www.libreoffice-forum.de)
oder im OpenOffice-Forum (http://de.openoffice.info/).

Ich nutze stattdessen den Export über XHTML. Und das funktioniert für
meinen Bedarf ganz ordentlich:
http://robert.familiegrosskopf.de/lo_hb_xhtml/Base_01_Einfuehrung.xhtml

Auch da gibt es aber Fehler, die schon länger mitgezogen werden. So muss
ich bei jedem Export des Handbuches die Datei im Texteditor aufrufen und
über "Suchen und Ersetzen" die folgenden Ersetzungen vornehmen:
:0, → :0.
:1, → :1.
Aus irgendeinem Grunde werden dort Dezimalkommas statt Dezimalpunkten
gesetzt. Habe ich auch gemeldet
https://bugs.documentfoundation.org/show_bug.cgi?id=95662
aber leider bisher keinen Erfolg, dass das für jemand interessant genug
ist, so ein Problemchen in die Hand zu nehmen.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Robert,

Am Sat, 10 Aug 2019 08:59:16 +0200
schrieb Robert Großkopf <[hidden email]>:
>
> Den HTML-Export vom Writer aus nutzen sehr wenig Leute.

Das ist der Kern dessen, warum ich annehme, dass mit eine Besserung
nach so langer Zeit wohl nicht mehr zu rechnen ist.
>
> Ich nutze stattdessen den Export über XHTML.

Ist eine von mehreren Optionen, wenn ich mich in dieser Frage von
meiner Jahrelangen Praxis ab- und anderen Instrumenten zuwenden muss.
Immerhin wäre auch XHTML etwas ganz anderes, als HTML. Vgl.

https://wiki.selfhtml.org/wiki/XHTML und
https://wiki.selfhtml.org/wiki/HTML/Unterschiede_von_HTML_zu_XHTML

> Auch da gibt es aber Fehler, die schon länger mitgezogen werden. [..]
> Aus irgendeinem Grunde werden dort Dezimalkommas statt Dezimalpunkten
> gesetzt. Habe ich auch gemeldet
> https://bugs.documentfoundation.org/show_bug.cgi?id=95662
> aber leider bisher keinen Erfolg, dass das für jemand interessant
> genug ist, so ein Problemchen in die Hand zu nehmen.

Exakt (s. meine Anmerkung oben).

BTW: Eine andere Option wäre für mich, auf USB-Stick ein portables LO4.x
zu nutzen, denn es geht ja nur um diese eine Funktion, mit der ich auch
weiterhin gern sauber arbeiten würde. Bzw. müsste ich ausprobieren, ab
welcher Version es exakt losging mit den Fehlern (also vor 5.1.6.2).
Sind die alten LO-Portables noch zu bekommen?

Danke jedenfalls für die Rückmeldung und viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo rainer,
>
> Exakt (s. meine Anmerkung oben).
>
> BTW: Eine andere Option wäre für mich, auf USB-Stick ein portables LO4.x
> zu nutzen, denn es geht ja nur um diese eine Funktion, mit der ich auch
> weiterhin gern sauber arbeiten würde. Bzw. müsste ich ausprobieren, ab
> welcher Version es exakt losging mit den Fehlern (also vor 5.1.6.2).
> Sind die alten LO-Portables noch zu bekommen?

Ich habe hier mehrere LO-Versionen parallel installiert. Bei der Version
LO 5.1.5.2 habe ich die Umrandung, bei der Version LO 5.2.7.2 nicht
mehr. Und da Du das unter Linux hast brauchst Du doch gar nicht ein
LO-Portable zu nutzen.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Robert,

Am Sat, 10 Aug 2019 09:46:39 +0200
schrieb Robert Großkopf <[hidden email]>:

> >
> > Eine andere Option wäre für mich, auf USB-Stick ein portables LO4.x
> > zu nutzen, denn es geht ja nur um diese eine Funktion, mit der ich
> > auch weiterhin gern sauber arbeiten würde. Bzw. müsste ich
> > ausprobieren, ab welcher Version es exakt losging mit den Fehlern
> > (also vor 5.1.6.2). Sind die alten LO-Portables noch zu bekommen?  
>
> Ich habe hier mehrere LO-Versionen parallel installiert. Bei der
> Version LO 5.1.5.2 habe ich die Umrandung, bei der Version LO 5.2.7.2
> nicht mehr.

Wie gesagt: Das Thema hat sich nach den jüngsten Validierungen
ausgeweitet. Es geht nun ja nicht mehr nur um die Umrandungen, sondern
auch darum, dass LO je Menge weiterer Fehler und kritischen Code
generiert. Den einfachen Vergleichstest müsste ich also mit 5.1.5.2
auch machen. Allerdings wundert mich, dass Du damit schon keine
Umrandungen mehr hast, denn hier habe ich sie auch noch mit 5.1.6.2

> Und da Du das unter Linux hast brauchst Du doch gar nicht  ein
> LO-Portable zu nutzen.
>
Abgesehen davon, dass ältere Versionen nicht über die Paketverwaltung
angeboten werden und ich zu einem ppa greifen müsste, installiere ich
ungern mehrere Versionen der gleichen Anwendungen nebeneinander. Meine
Erfahrungen mit so etwas sind nicht gut (bei anderen schon passiert,
dass sie sich ins Gehege kamen).

Viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo rainer,

>>
>> Ich habe hier mehrere LO-Versionen parallel installiert. Bei der
>> Version LO 5.1.5.2 habe ich die Umrandung, bei der Version LO 5.2.7.2
>> nicht mehr.
>
> Wie gesagt: Das Thema hat sich nach den jüngsten Validierungen
> ausgeweitet. Es geht nun ja nicht mehr nur um die Umrandungen, sondern
> auch darum, dass LO je Menge weiterer Fehler und kritischen Code
> generiert. Den einfachen Vergleichstest müsste ich also mit 5.1.5.2
> auch machen. Allerdings wundert mich, dass Du damit schon keine
> Umrandungen mehr hast, denn hier habe ich sie auch noch mit 5.1.6.2

Doch, mit 5.1.5.2 habe ich sie noch. Siehe Text.
>
>> Und da Du das unter Linux hast brauchst Du doch gar nicht  ein
>> LO-Portable zu nutzen.
>>
> Abgesehen davon, dass ältere Versionen nicht über die Paketverwaltung
> angeboten werden und ich zu einem ppa greifen müsste, installiere ich
> ungern mehrere Versionen der gleichen Anwendungen nebeneinander. Meine
> Erfahrungen mit so etwas sind nicht gut (bei anderen schon passiert,
> dass sie sich ins Gehege kamen).

Die kommen sich nichts ins Gehege, wenn Du sie als Nutzerinstallation in
einem separaten Verzeichnis Deines Heimatverzeichnisses installierst.
Steht in dem ersten Einstiegshandbuch zur Installation gut beschrieben.
Habe ich auch daraus übernommen.

Gruß

Robert

--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Robert,

Am Sat, 10 Aug 2019 10:14:47 +0200
schrieb Robert Großkopf <[hidden email]>:

> >>
> > Allerdings wundert mich, dass Du damit schon keine Umrandungen mehr
> > hast, denn hier habe ich sie auch noch mit 5.1.6.2  
>
> Doch, mit 5.1.5.2 habe ich sie noch. Siehe Text.
> >  
Oh, habe ich im Eifer des Gefechts verwechselt. Sorry.

> >> Und da Du das unter Linux hast brauchst Du doch gar nicht  ein
> >> LO-Portable zu nutzen.

> > Meine Erfahrungen mit so etwas sind nicht gut (bei anderen schon
> > passiert, dass sie sich ins Gehege kamen).  
>
> Die kommen sich nichts ins Gehege, wenn Du sie als Nutzerinstallation
> in einem separaten Verzeichnis Deines Heimatverzeichnisses
> installierst. Steht in dem ersten Einstiegshandbuch zur Installation
> gut beschrieben. Habe ich auch daraus übernommen.
>
Das kenne ich bisher gar nicht ;-) Werde mich aber mit dieser
Möglichkeit etwas eingehender beschäftigen.

Könntest Du evtl. mal mit 5.1.5.2 testen, was bei der Validierung auf
https://validator.w3.org/ herauskommt - also 1x als unbearbeitete
Writer-Seite im html-Format und 1x mit eingefügter Tabelle (3 Spalten,
10 Zeilen)? Ich muss ja irgendwie die Version finden, die dabei als
letzte zwischen 4.2.8.2 und 5.1.6.2 einen fehlerfreien Code generiert).

Viele Grüße

Rainer


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Rainer,
>
> Könntest Du evtl. mal mit 5.1.5.2 testen, was bei der Validierung auf
> https://validator.w3.org/ herauskommt - also 1x als unbearbeitete
> Writer-Seite im html-Format und 1x mit eingefügter Tabelle (3 Spalten,
> 10 Zeilen)? Ich muss ja irgendwie die Version finden, die dabei als
> letzte zwischen 4.2.8.2 und 5.1.6.2 einen fehlerfreien Code generiert).

Das habe ich bei der Tabelle einmal laufen lassen. Dieser Test kreidet
bereits Elemente an, die für mich völlig korrekt sind. Allein im
<head>-Bereich alles mögliche, was mit /> endet.

Vielleicht passt einfach der darüber stehende Doctype nicht.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: Bug in LO 6.0.7.3 (Linux) beim Abspeichern von html-Writer-Tabellen nach Bearbeitung mit "Autoformat"

Hallo Robert,

Am Sat, 10 Aug 2019 16:30:19 +0200
schrieb Robert Großkopf <[hidden email]>:

> >
> > Könntest Du evtl. mal mit 5.1.5.2 testen, was bei der Validierung
> > auf https://validator.w3.org/ herauskommt - also 1x als
> > unbearbeitete Writer-Seite im html-Format und 1x mit eingefügter
> > Tabelle (3 Spalten, 10 Zeilen)?
>
> Das habe ich bei der Tabelle einmal laufen lassen. Dieser Test kreidet
> bereits Elemente an, die für mich völlig korrekt sind. Allein im
> <head>-Bereich alles mögliche, was mit /> endet.
>
Ja, und das ist eben nicht korrekt. Ich habe beide Seiten (also 1x ohne
Bearbeitung und einmal mit Tabelle) mit denen verglichen, die von mit
LO 4.2.8.2 generiert wurden. Ergebnis: An allen Stellen, wo in den, bei
der Validierung durchgefallenen Quelltexten ein "/>" zu finden ist,
steht in den fehlerfreien ein ">". Der Validator sagt zu diesem Fehler:

For the current document, the validator interprets strings like <FOO />
according to legacy rules that break the expectations of most authors
and thus cause confusing warnings and error messages from the
validator. This interpretation is triggered by HTML 4 documents or
other SGML-based HTML documents. To avoid the messages, simply remove
the "/" character in such contexts.

Tatsächlich: Werden alle "/>" durch ">" ersetzt, ist die Validierung
erfolgreich.

Bei bearbeiteten Tabellen mit Inhalten und durchgeführtem "Autoformat"
kommen - wie in einem früheren Posting beschrieben - 3 Varianten des
Ausdrucks hinzu, der mit "style="background:" beginnt - insgesamt eine
recht große Zahl. Außerdem muss der LO-eigene Datums-Tag)
"sdnum="1031;0;@" entfernt werden (je nach gewähltem Autoformat soll
alternativ die Anpassung oder Entfernung von "sdval" notwendig sein).
Über "sdnum" sagt der Validator:

You have used the attribute named above in your document, but the
document type you are using does not support that attribute for this
element.

Der LO-Generator baut also bereits in ein einfaches Writer-Dokument mit
eingefügter Tabelle (3 Spalten, 10 Zeilen) sowie durchgeführtem
"Autoformat" (Standardvorlage "Braun") folgende, zu entfernende Fehler
ein (was er in Version 4.2.8.2 nicht tut):

30x style="background: #......"
37x "/>"
12x sdnum="1031;0;@"

Fazit: Bei der Erstellung von html-Seiten (mittels "Speichern unter"!)
handelt es sich beim derzeitigen Stand der Dinge nicht nur um einen
Bug, sondern um drei.

Wäre schön, wenn das jemand übersetzen und melden könnte.

Viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/discuss/
Datenschutzerklärung: https://www.documentfoundation.org/privacy