Calc: Zwei Listen vergleichen

classic Classic list List threaded Threaded
4 messages Options
Micha Kühn Micha Kühn
Reply | Threaded
Open this post in threaded view
|

Calc: Zwei Listen vergleichen

Hallo,

ich habe folgendes Problem:

In Spalte A habe ich einen Haufen von kryptischen Zahlencodes.
In Spalte B habe ich eine andere Liste, ähnlicher, kryptischer
Zahlencodes. Es gibt einige Codes, die in Spalte B stehen, auch schon in
Spalte A.

Jetzt muss ich eine Lösung finden, die Codes, die auch in Spalte A
stehen, zu löschen. Ich will also nur die Codes in B übrig behalten, die
nicht schon in A stehen.

Wie geht das am elegantesten?

Danke,
Micha

P.S. Es geht um die Verwaltung von Zugangscodes für eBooks einer Schule.

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Alois Klotz Alois Klotz
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Zwei Listen vergleichen

Hallo,
ich hab da ein Beispiel erstellt:

https://www.dropbox.com/s/r99w18i08np7469/Listen_vergleichen.ods?dl=0

In der Spalte C zähle ich, wie oft der Eintrag in Spalte B in der Spalte
A vorkommt.
Dann filtere ich alle Werte in Spalte B heraus, die größer als Null sind
(hab ich per bedingter Formatierung schon rot eingefärbt)
Diese Werte kann man dann einfach löschen.
MfG Alois

Micha Kuehn schrieb am 23.03.2020 um 18:03:

> Hallo,
>
> ich habe folgendes Problem:
>
> In Spalte A habe ich einen Haufen von kryptischen Zahlencodes.
> In Spalte B habe ich eine andere Liste, ähnlicher, kryptischer
> Zahlencodes. Es gibt einige Codes, die in Spalte B stehen, auch schon in
> Spalte A.
>
> Jetzt muss ich eine Lösung finden, die Codes, die auch in Spalte A
> stehen, zu löschen. Ich will also nur die Codes in B übrig behalten, die
> nicht schon in A stehen.
>
> Wie geht das am elegantesten?
>
> Danke,
> Micha
>
> P.S. Es geht um die Verwaltung von Zugangscodes für eBooks einer Schule.
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy

Wolfgang Jäth Wolfgang Jäth
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Zwei Listen vergleichen

In reply to this post by Micha Kühn
Am 23.03.2020 um 18:03 schrieb Micha Kuehn:

> Hallo,
>
> ich habe folgendes Problem:
>
> In Spalte A habe ich einen Haufen von kryptischen Zahlencodes.
> In Spalte B habe ich eine andere Liste, ähnlicher, kryptischer
> Zahlencodes. Es gibt einige Codes, die in Spalte B stehen, auch schon in
> Spalte A.
>
> Jetzt muss ich eine Lösung finden, die Codes, die auch in Spalte A
> stehen, zu löschen. Ich will also nur die Codes in B übrig behalten, die
> nicht schon in A stehen.
>
> Wie geht das am elegantesten?

Da gibt es mehrere Möglichkeiten:

| =ISTFEHLER(VERGLEICH(B2;$A$2:$A$1000;0))=0
| =ISTFEHLER(SVERWEIS(B2;$A$2:$A$1000;1;0))=0
| =ZÄHLENWENN($A$2:$A$1000;B2)>0

Ich verwende meistens ersteres, als bedingte Formatierung, die den
Hintergrund der betreffenden Zelle rot färbt; aber das ist Geschmackssache.

Wolfgang
--
Donald Trump ist ein großer Visionär, der seiner Zeit weit voraus ist:
Er verbreitet schon jetzt den Slogan "make America great again", obwohl
dieser erst in der Ära /nach/ ihm seine volle Bedeutung entfalten wird.


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Jürgen Kirsten Jürgen Kirsten
Reply | Threaded
Open this post in threaded view
|

Re: Calc: Zwei Listen vergleichen

Hallo Micha,

eine weitere Möglichkeit, wenn du keine Formeln verwenden möchtest.
Spezialfilter:
Kopiere deine Werte von Spalte B einfach unter die der Spalte A
Achte darauf das deine Liste in Spalte A eine Überschrift hat
Kopiere dir die Überschrift in die Zelle C1
Schreibe in Zelle C2 ".*" also Punkt und Stern ohne Anführungszeichen
Markiere deine Daten in Spalte A komplett mit Überschrift
Im Menü, Daten, Weitere Filter, Spezialfilter
Filterkriterien: C1:C2 (einfach mit der Maus auswählen)
Optionen:
Reguläre Ausdrücke: AN
Keine Duplikate: AN
Kopiere Ergebnisse nach: AN
Ziel der Ergebnisse auswählen: Z.B. D1

Die Liste wird nach D1 gefiltert. Duplikate werden eliminiert.

lg

Jürgen


Am 23.03.2020 um 18:39 schrieb Wolfgang Jäth:

> Am 23.03.2020 um 18:03 schrieb Micha Kuehn:
>> Hallo,
>>
>> ich habe folgendes Problem:
>>
>> In Spalte A habe ich einen Haufen von kryptischen Zahlencodes.
>> In Spalte B habe ich eine andere Liste, ähnlicher, kryptischer
>> Zahlencodes. Es gibt einige Codes, die in Spalte B stehen, auch schon in
>> Spalte A.
>>
>> Jetzt muss ich eine Lösung finden, die Codes, die auch in Spalte A
>> stehen, zu löschen. Ich will also nur die Codes in B übrig behalten, die
>> nicht schon in A stehen.
>>
>> Wie geht das am elegantesten?
> Da gibt es mehrere Möglichkeiten:
>
> | =ISTFEHLER(VERGLEICH(B2;$A$2:$A$1000;0))=0
> | =ISTFEHLER(SVERWEIS(B2;$A$2:$A$1000;1;0))=0
> | =ZÄHLENWENN($A$2:$A$1000;B2)>0
>
> Ich verwende meistens ersteres, als bedingte Formatierung, die den
> Hintergrund der betreffenden Zelle rot färbt; aber das ist Geschmackssache.
>
> Wolfgang


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy