Calc formule

classic Classic list List threaded Threaded
13 messages Options
demande_aide_fr demande_aide_fr
Reply | Threaded
Open this post in threaded view
|

Calc formule

Bonjour

Voici une nouvelle question envoyée à l'aide du formulaire de demande d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
Si vous répondez, merci de penser à utiliser la fonction "répondre à tous" de votre logiciel de courrier électronique de façon que le demandeur reçoive une copie de votre réponse.


Email: - [hidden email]
Sujet: - Calc formule
Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
Comment figer la colonne I ?
Cordialement
 


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
linux-2 linux-2
Reply | Threaded
Open this post in threaded view
|

Re: Calc formule

en ajoutant $ devant le I

=NB.SI($I2:AD2;1)

A bientot
Jean Luc
Le 30/10/2014 10:41, [hidden email] a écrit :

> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous" de votre logiciel de courrier électronique de façon que le demandeur reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>  
>
>


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

In reply to this post by demande_aide_fr
Bonjour,

Il faut construire la référence:
=NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)

Bonne journée,

Michel


> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]]
> Envoyé : jeudi 30 octobre 2014 10:41
> À : [hidden email]
> Objet : [fr-users] Calc formule
>
> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>
>
>
> --
> Envoyez un mail à [hidden email] pour savoir comment
> vous désinscrire
> Les archives de la liste sont disponibles à
> http://listarchives.libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

Dans ce cas, il faut utiliser :

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)

 

Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
corruption du fichier content.xml à la position 2,34892 (row,col) et je
manque de temps pour regarder de plus près.

(Nota : le fichier xml est « monoligne » ce qui complique le repérage de
l’erreur pour qui n’est pas un pro de cette opération. Il y avait une option
qui permettait d’enregistrer en « multiligne », mais je ne la retrouve pas –
je suis en version 4.2.6.2, si quelqu’un sait où est cette option)

 

Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
de votre logiciel de courrier électronique de façon que la liste reçoive
aussi une copie de votre réponse.

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : jeudi 30 octobre 2014 12:12
À : Michel Rudelle
Objet : Re: [fr-users] Calc formule

 

Merci pour votre réponse.

J'ai appliqué votre correction, c'est OK pour la ligne 2

par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
ne changent pas automatiquement.

Mon besoin est de faire une une stat de nombre de match joué et par équipe
(1, 2, 3 ou 4) pour un joueur précis.

J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.

Cordialement

 

voir PJ

 

Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

Il faut construire la référence:
=NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)

Bonne journée,

Michel


> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]]
> Envoyé : jeudi 30 octobre 2014 10:41
> À : [hidden email]
> Objet : [fr-users] Calc formule
>
> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>
>
>
> --
> Envoyez un mail à [hidden email]
<mailto:users%[hidden email]>  pour savoir comment
> vous désinscrire
> Les archives de la liste sont disponibles à
> http://listarchives.libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés

 


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

Bonjour,

 

Il faut mettre la formule suivante en E2 :

 =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)

et la recopier sur tous les calculs (E2 :H5)

 

une seule formule, qui lit le critère sur la première ligne, commence le
comptage colonne I (9° colonne), et le termine colonne AD

 

Je renvoie le fichier modifié séparément

 

PS : un conseil, enregistrer au format ODS

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : vendredi 31 octobre 2014 07:30
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

en PJ un extraction de mon tableau.

 

Cordialement

 

Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a écrit
:

Dans ce cas, il faut utiliser :

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)

 

Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
corruption du fichier content.xml à la position 2,34892 (row,col) et je
manque de temps pour regarder de plus près.

(Nota : le fichier xml est « monoligne » ce qui complique le repérage de
l’erreur pour qui n’est pas un pro de cette opération. Il y avait une option
qui permettait d’enregistrer en « multiligne », mais je ne la retrouve pas –
je suis en version 4.2.6.2, si quelqu’un sait où est cette option)

 

Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
de votre logiciel de courrier électronique de façon que la liste reçoive
aussi une copie de votre réponse.

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : jeudi 30 octobre 2014 12:12
À : Michel Rudelle
Objet : Re: [fr-users] Calc formule

 

Merci pour votre réponse.

J'ai appliqué votre correction, c'est OK pour la ligne 2

par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
ne changent pas automatiquement.

Mon besoin est de faire une une stat de nombre de match joué et par équipe
(1, 2, 3 ou 4) pour un joueur précis.

J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.

Cordialement

 

voir PJ

 

Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

Il faut construire la référence:
=NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)

Bonne journée,

Michel


> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]]
> Envoyé : jeudi 30 octobre 2014 10:41
> À : [hidden email]
> Objet : [fr-users] Calc formule
>
> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>
>
>
> --
> Envoyez un mail à [hidden email]
<mailto:users%[hidden email]>  pour savoir comment
> vous désinscrire
> Les archives de la liste sont disponibles à
> http://listarchives.libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés

 

 


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

pierre-yves samyn pierre-yves samyn
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

In reply to this post by Michel Rudelle
Bonjour

Michel Rudelle wrote
(Nota : le fichier xml est « monoligne » ce qui complique le repérage de
l’erreur pour qui n’est pas un pro de cette opération. Il y avait une option
qui permettait d’enregistrer en « multiligne », mais je ne la retrouve pas –
je suis en version 4.2.6.2, si quelqu’un sait où est cette option)
Laurent a documenté cela dans le wiki :
https://wiki.documentfoundation.org/FR/General/CreerFichierODF#Conseils

Cordialement
Pierre-Yves
Carpentier Alain Carpentier Alain
Reply | Threaded
Open this post in threaded view
|

Re: Calc formule

In reply to this post by Michel Rudelle
C'est OK,

la formule ne s'invente pas... après plusieurs années de dur labeur
j'aurais peut-être trouvé.


*Torcy vous remercie.*

*Bonne soirée*

*Alain Carpentier*

Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a écrit
:

>  Bonjour,
>
>
>
> Il faut mettre la formule suivante en E2 :
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)
>
> et la recopier sur tous les calculs (E2 :H5)
>
>
>
> une seule formule, qui lit le critère sur la première ligne, commence le
> comptage colonne I (9° colonne), et le termine colonne AD
>
>
>
> Je renvoie le fichier modifié séparément
>
>
>
> PS : un conseil, enregistrer au format ODS
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* vendredi 31 octobre 2014 07:30
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> en PJ un extraction de mon tableau.
>
>
>
> Cordialement
>
>
>
> Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a
> écrit :
>
> Dans ce cas, il faut utiliser :
>
> =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)
>
>
>
> Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
> corruption du fichier content.xml à la position 2,34892 (row,col) et je
> manque de temps pour regarder de plus près.
>
> (Nota : le fichier xml est « monoligne » ce qui complique le repérage de
> l’erreur pour qui n’est pas un pro de cette opération. Il y avait une
> option qui permettait d’enregistrer en « multiligne », mais je ne la
> retrouve pas – je suis en version 4.2.6.2, si quelqu’un sait où est cette
> option)
>
>
>
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que la liste reçoive
> aussi une copie de votre réponse.
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* jeudi 30 octobre 2014 12:12
> *À :* Michel Rudelle
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Merci pour votre réponse.
>
> J'ai appliqué votre correction, c'est OK pour la ligne 2
>
> par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
> ne changent pas automatiquement.
>
> Mon besoin est de faire une une stat de nombre de match joué et par équipe
> (1, 2, 3 ou 4) pour un joueur précis.
>
> J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.
>
> Cordialement
>
>
>
> voir PJ
>
>
>
> Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
> Il faut construire la référence:
> =NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)
>
> Bonne journée,
>
> Michel
>
>
> > -----Message d'origine-----
> > De : [hidden email]
> > [mailto:[hidden email]]
> > Envoyé : jeudi 30 octobre 2014 10:41
> > À : [hidden email]
> > Objet : [fr-users] Calc formule
> >
> > Bonjour
> >
> > Voici une nouvelle question envoyée à l'aide du formulaire de demande
> > d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> > Si vous répondez, merci de penser à utiliser la fonction "répondre à
> tous"
> > de votre logiciel de courrier électronique de façon que le demandeur
> > reçoive une copie de votre réponse.
> >
> >
> > Email: - [hidden email]
> > Sujet: - Calc formule
> > Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> > une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> > Comment figer la colonne I ?
> > Cordialement
> >
> >
> >
> > --
> > Envoyez un mail à [hidden email] pour savoir
> comment
> > vous désinscrire
> > Les archives de la liste sont disponibles à
> > http://listarchives.libreoffice.org/fr/users/
> > Tous les messages envoyés sur cette liste seront archivés publiquement et
> > ne pourront pas être supprimés
>
>
>
>
>

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

In reply to this post by pierre-yves samyn
Bonsoir,

> -----Message d'origine-----
> De : pierre-yves samyn [mailto:[hidden email]]
> Envoyé : vendredi 31 octobre 2014 17:40
> À : [hidden email]
> Objet : [fr-users] RE: Calc formule
>
> Bonjour
>
>
> Michel Rudelle wrote
> > (Nota : le fichier xml est « monoligne » ce qui complique le repérage de
> > l’erreur pour qui n’est pas un pro de cette opération. Il y avait une
> > option
> > qui permettait d’enregistrer en « multiligne », mais je ne la retrouve
> pas
> > –
> > je suis en version 4.2.6.2, si quelqu’un sait où est cette option)
>
> Laurent a documenté cela dans le wiki :
> https://wiki.documentfoundation.org/FR/General/CreerFichierODF#Conseils

Merci Pierre-Yves, je me doutais que ça pouvait être là.
Rassuré de voir que chez moi c'était toujours à True, ça suit bien les
versions.

Une remarque en passant, je n'ai plus rencontré de pb de fichier corrompu
depuis environ 2 ans. C'est moi ou LibO ? (je n'en avais pas rencontré
beaucoup non plus avant)

Michel


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

Carpentier Alain Carpentier Alain
Reply | Threaded
Open this post in threaded view
|

Re: Calc formule

In reply to this post by Michel Rudelle
Bonjour;
la formule fonctionne très bien, je l'ai testé sur plusieurs tableaux.

   - Dans la formule ci-dessous à quoi correspond le "9" ?

=NB.SI(INDIRECT(ADRESSE(LIGNE();*9*)):$R5;F$1)

*Cordialement*

Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a écrit
:

>  Bonjour,
>
>
>
> Il faut mettre la formule suivante en E2 :
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)
>
> et la recopier sur tous les calculs (E2 :H5)
>
>
>
> une seule formule, qui lit le critère sur la première ligne, commence le
> comptage colonne I (9° colonne), et le termine colonne AD
>
>
>
> Je renvoie le fichier modifié séparément
>
>
>
> PS : un conseil, enregistrer au format ODS
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* vendredi 31 octobre 2014 07:30
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> en PJ un extraction de mon tableau.
>
>
>
> Cordialement
>
>
>
> Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a
> écrit :
>
> Dans ce cas, il faut utiliser :
>
> =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)
>
>
>
> Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
> corruption du fichier content.xml à la position 2,34892 (row,col) et je
> manque de temps pour regarder de plus près.
>
> (Nota : le fichier xml est « monoligne » ce qui complique le repérage de
> l’erreur pour qui n’est pas un pro de cette opération. Il y avait une
> option qui permettait d’enregistrer en « multiligne », mais je ne la
> retrouve pas – je suis en version 4.2.6.2, si quelqu’un sait où est cette
> option)
>
>
>
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que la liste reçoive
> aussi une copie de votre réponse.
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* jeudi 30 octobre 2014 12:12
> *À :* Michel Rudelle
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Merci pour votre réponse.
>
> J'ai appliqué votre correction, c'est OK pour la ligne 2
>
> par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
> ne changent pas automatiquement.
>
> Mon besoin est de faire une une stat de nombre de match joué et par équipe
> (1, 2, 3 ou 4) pour un joueur précis.
>
> J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.
>
> Cordialement
>
>
>
> voir PJ
>
>
>
> Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
> Il faut construire la référence:
> =NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)
>
> Bonne journée,
>
> Michel
>
>
> > -----Message d'origine-----
> > De : [hidden email]
> > [mailto:[hidden email]]
> > Envoyé : jeudi 30 octobre 2014 10:41
> > À : [hidden email]
> > Objet : [fr-users] Calc formule
> >
> > Bonjour
> >
> > Voici une nouvelle question envoyée à l'aide du formulaire de demande
> > d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> > Si vous répondez, merci de penser à utiliser la fonction "répondre à
> tous"
> > de votre logiciel de courrier électronique de façon que le demandeur
> > reçoive une copie de votre réponse.
> >
> >
> > Email: - [hidden email]
> > Sujet: - Calc formule
> > Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> > une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> > Comment figer la colonne I ?
> > Cordialement
> >
> >
> >
> > --
> > Envoyez un mail à [hidden email] pour savoir
> comment
> > vous désinscrire
> > Les archives de la liste sont disponibles à
> > http://listarchives.libreoffice.org/fr/users/
> > Tous les messages envoyés sur cette liste seront archivés publiquement et
> > ne pourront pas être supprimés
>
>
>
>
>

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

Bonjour,

 

Le 9 correspond à la colonne I

 

ADRESSE renvoie une adresse sous forme de texte et a pour arguments :

 - le n° de ligne

 - le n° de colonne

 - et des paramètres facultatifs (omis ici)

 

Le n° de colonne est ainsi figé à 9 dans la formule, et donne toujours la
colonne I  même si on insère des colonnes avant.

La fonction ADRESSE est très utile pour générer des adresses adaptées à son
besoin.

 

L’assistant fonction (fx) que l’on trouve dans la barre de formule est très
pratique pour découvrir ces fonctions

 

Cordialement,

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : lundi 24 novembre 2014 11:52
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

Bonjour;

la formule fonctionne très bien, je l'ai testé sur plusieurs tableaux.

* Dans la formule ci-dessous à quoi correspond le "9" ?

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$R5;F$1)

 

Cordialement

 

Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

 

Il faut mettre la formule suivante en E2 :

 =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)

et la recopier sur tous les calculs (E2 :H5)

 

une seule formule, qui lit le critère sur la première ligne, commence le
comptage colonne I (9° colonne), et le termine colonne AD

 

Je renvoie le fichier modifié séparément

 

PS : un conseil, enregistrer au format ODS

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : vendredi 31 octobre 2014 07:30
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

en PJ un extraction de mon tableau.

 

Cordialement

 

Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a écrit
:

Dans ce cas, il faut utiliser :

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)

 

Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
corruption du fichier content.xml à la position 2,34892 (row,col) et je
manque de temps pour regarder de plus près.

(Nota : le fichier xml est « monoligne » ce qui complique le repérage de
l’erreur pour qui n’est pas un pro de cette opération. Il y avait une option
qui permettait d’enregistrer en « multiligne », mais je ne la retrouve pas –
je suis en version 4.2.6.2, si quelqu’un sait où est cette option)

 

Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
de votre logiciel de courrier électronique de façon que la liste reçoive
aussi une copie de votre réponse.

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : jeudi 30 octobre 2014 12:12
À : Michel Rudelle
Objet : Re: [fr-users] Calc formule

 

Merci pour votre réponse.

J'ai appliqué votre correction, c'est OK pour la ligne 2

par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
ne changent pas automatiquement.

Mon besoin est de faire une une stat de nombre de match joué et par équipe
(1, 2, 3 ou 4) pour un joueur précis.

J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.

Cordialement

 

voir PJ

 

Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

Il faut construire la référence:
=NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)

Bonne journée,

Michel


> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]]
> Envoyé : jeudi 30 octobre 2014 10:41
> À : [hidden email]
> Objet : [fr-users] Calc formule
>
> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>
>
>
> --
> Envoyez un mail à [hidden email]
<mailto:users%[hidden email]>  pour savoir comment
> vous désinscrire
> Les archives de la liste sont disponibles à
> http://listarchives.libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés

 

 

 


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

Carpentier Alain Carpentier Alain
Reply | Threaded
Open this post in threaded view
|

Re: Calc formule

Bonjour Mr Rudelle,

Pour la formule ci-dessous, y a t il un nombre maximum pour les colonnes
que Calc peut calculer ?

=NB.SI <http://nb.si/>(INDIRECT(ADRESSE(LIGNE();*9*)):$R5;F$1)

Cordialement

Le 24 novembre 2014 12:46, Michel Rudelle <[hidden email]> a
écrit :

>  Bonjour,
>
>
>
> Le 9 correspond à la colonne I
>
>
>
> ADRESSE renvoie une adresse sous forme de texte et a pour arguments :
>
>  - le n° de ligne
>
>  - le n° de colonne
>
>  - et des paramètres facultatifs (omis ici)
>
>
>
> Le n° de colonne est ainsi figé à 9 dans la formule, et donne toujours la
> colonne I  même si on insère des colonnes avant.
>
> La fonction ADRESSE est très utile pour générer des adresses adaptées à
> son besoin.
>
>
>
> L’assistant fonction (fx) que l’on trouve dans la barre de formule est
> très pratique pour découvrir ces fonctions
>
>
>
> Cordialement,
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* lundi 24 novembre 2014 11:52
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Bonjour;
>
> la formule fonctionne très bien, je l'ai testé sur plusieurs tableaux.
>
>    - Dans la formule ci-dessous à quoi correspond le "9" ?
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();*9*)):$R5;F$1)
>
>
>
> *Cordialement*
>
>
>
> Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
>
>
> Il faut mettre la formule suivante en E2 :
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)
>
> et la recopier sur tous les calculs (E2 :H5)
>
>
>
> une seule formule, qui lit le critère sur la première ligne, commence le
> comptage colonne I (9° colonne), et le termine colonne AD
>
>
>
> Je renvoie le fichier modifié séparément
>
>
>
> PS : un conseil, enregistrer au format ODS
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* vendredi 31 octobre 2014 07:30
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> en PJ un extraction de mon tableau.
>
>
>
> Cordialement
>
>
>
> Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a
> écrit :
>
> Dans ce cas, il faut utiliser :
>
> =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)
>
>
>
> Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
> corruption du fichier content.xml à la position 2,34892 (row,col) et je
> manque de temps pour regarder de plus près.
>
> (Nota : le fichier xml est « monoligne » ce qui complique le repérage de
> l’erreur pour qui n’est pas un pro de cette opération. Il y avait une
> option qui permettait d’enregistrer en « multiligne », mais je ne la
> retrouve pas – je suis en version 4.2.6.2, si quelqu’un sait où est cette
> option)
>
>
>
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que la liste reçoive
> aussi une copie de votre réponse.
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* jeudi 30 octobre 2014 12:12
> *À :* Michel Rudelle
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Merci pour votre réponse.
>
> J'ai appliqué votre correction, c'est OK pour la ligne 2
>
> par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
> ne changent pas automatiquement.
>
> Mon besoin est de faire une une stat de nombre de match joué et par équipe
> (1, 2, 3 ou 4) pour un joueur précis.
>
> J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.
>
> Cordialement
>
>
>
> voir PJ
>
>
>
> Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
> Il faut construire la référence:
> =NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)
>
> Bonne journée,
>
> Michel
>
>
> > -----Message d'origine-----
> > De : [hidden email]
> > [mailto:[hidden email]]
> > Envoyé : jeudi 30 octobre 2014 10:41
> > À : [hidden email]
> > Objet : [fr-users] Calc formule
> >
> > Bonjour
> >
> > Voici une nouvelle question envoyée à l'aide du formulaire de demande
> > d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> > Si vous répondez, merci de penser à utiliser la fonction "répondre à
> tous"
> > de votre logiciel de courrier électronique de façon que le demandeur
> > reçoive une copie de votre réponse.
> >
> >
> > Email: - [hidden email]
> > Sujet: - Calc formule
> > Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> > une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> > Comment figer la colonne I ?
> > Cordialement
> >
> >
> >
> > --
> > Envoyez un mail à [hidden email] pour savoir
> comment
> > vous désinscrire
> > Les archives de la liste sont disponibles à
> > http://listarchives.libreoffice.org/fr/users/
> > Tous les messages envoyés sur cette liste seront archivés publiquement et
> > ne pourront pas être supprimés
>
>
>
>
>
>
>

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Michel Rudelle Michel Rudelle
Reply | Threaded
Open this post in threaded view
|

RE: Calc formule

Bonjour,

 

Je ne vois à priori comme seule limite le nombre maximal de colonnes
possibles d’un classeur Calc, 1024 si je ne m’abuse

 

Cordialement,

 

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : vendredi 5 décembre 2014 11:25
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

Bonjour Mr Rudelle,

 

Pour la formule ci-dessous, y a t il un nombre maximum pour les colonnes que
Calc peut calculer ?

 

=NB.SI <http://nb.si/> (INDIRECT(ADRESSE(LIGNE();9)):$R5;F$1)

 

Cordialement

 

Le 24 novembre 2014 12:46, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

 

Le 9 correspond à la colonne I

 

ADRESSE renvoie une adresse sous forme de texte et a pour arguments :

 - le n° de ligne

 - le n° de colonne

 - et des paramètres facultatifs (omis ici)

 

Le n° de colonne est ainsi figé à 9 dans la formule, et donne toujours la
colonne I  même si on insère des colonnes avant.

La fonction ADRESSE est très utile pour générer des adresses adaptées à son
besoin.

 

L’assistant fonction (fx) que l’on trouve dans la barre de formule est très
pratique pour découvrir ces fonctions

 

Cordialement,

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : lundi 24 novembre 2014 11:52
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

Bonjour;

la formule fonctionne très bien, je l'ai testé sur plusieurs tableaux.

* Dans la formule ci-dessous à quoi correspond le "9" ?

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$R5;F$1)

 

Cordialement

 

Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

 

Il faut mettre la formule suivante en E2 :

 =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)

et la recopier sur tous les calculs (E2 :H5)

 

une seule formule, qui lit le critère sur la première ligne, commence le
comptage colonne I (9° colonne), et le termine colonne AD

 

Je renvoie le fichier modifié séparément

 

PS : un conseil, enregistrer au format ODS

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : vendredi 31 octobre 2014 07:30
À : Michel Rudelle
Cc : [hidden email]
Objet : Re: [fr-users] Calc formule

 

en PJ un extraction de mon tableau.

 

Cordialement

 

Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a écrit
:

Dans ce cas, il faut utiliser :

=NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)

 

Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
corruption du fichier content.xml à la position 2,34892 (row,col) et je
manque de temps pour regarder de plus près.

(Nota : le fichier xml est « monoligne » ce qui complique le repérage de
l’erreur pour qui n’est pas un pro de cette opération. Il y avait une option
qui permettait d’enregistrer en « multiligne », mais je ne la retrouve pas –
je suis en version 4.2.6.2, si quelqu’un sait où est cette option)

 

Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
de votre logiciel de courrier électronique de façon que la liste reçoive
aussi une copie de votre réponse.

Michel

  _____  

De : Carpentier Alain [mailto:[hidden email]]
Envoyé : jeudi 30 octobre 2014 12:12
À : Michel Rudelle
Objet : Re: [fr-users] Calc formule

 

Merci pour votre réponse.

J'ai appliqué votre correction, c'est OK pour la ligne 2

par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
ne changent pas automatiquement.

Mon besoin est de faire une une stat de nombre de match joué et par équipe
(1, 2, 3 ou 4) pour un joueur précis.

J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.

Cordialement

 

voir PJ

 

Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a écrit
:

Bonjour,

Il faut construire la référence:
=NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)

Bonne journée,

Michel


> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]]
> Envoyé : jeudi 30 octobre 2014 10:41
> À : [hidden email]
> Objet : [fr-users] Calc formule
>
> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email: - [hidden email]
> Sujet: - Calc formule
> Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> Comment figer la colonne I ?
> Cordialement
>
>
>
> --
> Envoyez un mail à [hidden email]
<mailto:users%[hidden email]>  pour savoir comment
> vous désinscrire
> Les archives de la liste sont disponibles à
> http://listarchives.libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés

 

 

 

 


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés

Carpentier Alain Carpentier Alain
Reply | Threaded
Open this post in threaded view
|

Re: Calc formule

OK, je devrais avoir de la marge, j'estime le nombre de colonne entre 140
et 160.

Merci.

Le 5 décembre 2014 15:56, Michel Rudelle <[hidden email]> a écrit
:

>  Bonjour,
>
>
>
> Je ne vois à priori comme seule limite le nombre maximal de colonnes
> possibles d’un classeur Calc, 1024 si je ne m’abuse
>
>
>
> Cordialement,
>
>
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* vendredi 5 décembre 2014 11:25
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Bonjour Mr Rudelle,
>
>
>
> Pour la formule ci-dessous, y a t il un nombre maximum pour les colonnes
> que Calc peut calculer ?
>
>
>
> =NB.SI <http://nb.si/>(INDIRECT(ADRESSE(LIGNE();*9*)):$R5;F$1)
>
>
>
> Cordialement
>
>
>
> Le 24 novembre 2014 12:46, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
>
>
> Le 9 correspond à la colonne I
>
>
>
> ADRESSE renvoie une adresse sous forme de texte et a pour arguments :
>
>  - le n° de ligne
>
>  - le n° de colonne
>
>  - et des paramètres facultatifs (omis ici)
>
>
>
> Le n° de colonne est ainsi figé à 9 dans la formule, et donne toujours la
> colonne I  même si on insère des colonnes avant.
>
> La fonction ADRESSE est très utile pour générer des adresses adaptées à
> son besoin.
>
>
>
> L’assistant fonction (fx) que l’on trouve dans la barre de formule est
> très pratique pour découvrir ces fonctions
>
>
>
> Cordialement,
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* lundi 24 novembre 2014 11:52
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Bonjour;
>
> la formule fonctionne très bien, je l'ai testé sur plusieurs tableaux.
>
>    - Dans la formule ci-dessous à quoi correspond le "9" ?
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();*9*)):$R5;F$1)
>
>
>
> *Cordialement*
>
>
>
> Le 31 octobre 2014 10:17, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
>
>
> Il faut mettre la formule suivante en E2 :
>
>  =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):$AD2;E$1)
>
> et la recopier sur tous les calculs (E2 :H5)
>
>
>
> une seule formule, qui lit le critère sur la première ligne, commence le
> comptage colonne I (9° colonne), et le termine colonne AD
>
>
>
> Je renvoie le fichier modifié séparément
>
>
>
> PS : un conseil, enregistrer au format ODS
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* vendredi 31 octobre 2014 07:30
> *À :* Michel Rudelle
> *Cc :* [hidden email]
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> en PJ un extraction de mon tableau.
>
>
>
> Cordialement
>
>
>
> Le 30 octobre 2014 13:34, Michel Rudelle <[hidden email]> a
> écrit :
>
> Dans ce cas, il faut utiliser :
>
> =NB.SI(INDIRECT(ADRESSE(LIGNE();9)):AD3;1)
>
>
>
> Je n’ai pas pu visualiser le doc joint car j’ai un message m’indiquant une
> corruption du fichier content.xml à la position 2,34892 (row,col) et je
> manque de temps pour regarder de plus près.
>
> (Nota : le fichier xml est « monoligne » ce qui complique le repérage de
> l’erreur pour qui n’est pas un pro de cette opération. Il y avait une
> option qui permettait d’enregistrer en « multiligne », mais je ne la
> retrouve pas – je suis en version 4.2.6.2, si quelqu’un sait où est cette
> option)
>
>
>
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que la liste reçoive
> aussi une copie de votre réponse.
>
> Michel
>   ------------------------------
>
> *De :* Carpentier Alain [mailto:[hidden email]]
> *Envoyé :* jeudi 30 octobre 2014 12:12
> *À :* Michel Rudelle
> *Objet :* Re: [fr-users] Calc formule
>
>
>
> Merci pour votre réponse.
>
> J'ai appliqué votre correction, c'est OK pour la ligne 2
>
> par contre quand je recopie dans les cellules en dessous les valeurs (2;9)
> ne changent pas automatiquement.
>
> Mon besoin est de faire une une stat de nombre de match joué et par équipe
> (1, 2, 3 ou 4) pour un joueur précis.
>
> J'ai 85 joueurs qui jouent dans la catégorie des 17 ans.
>
> Cordialement
>
>
>
> voir PJ
>
>
>
> Le 30 octobre 2014 11:27, Michel Rudelle <[hidden email]> a
> écrit :
>
> Bonjour,
>
> Il faut construire la référence:
> =NB.SI(INDIRECT(ADRESSE(2;9)):AE2;1)
>
> Bonne journée,
>
> Michel
>
>
> > -----Message d'origine-----
> > De : [hidden email]
> > [mailto:[hidden email]]
> > Envoyé : jeudi 30 octobre 2014 10:41
> > À : [hidden email]
> > Objet : [fr-users] Calc formule
> >
> > Bonjour
> >
> > Voici une nouvelle question envoyée à l'aide du formulaire de demande
> > d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> > Si vous répondez, merci de penser à utiliser la fonction "répondre à
> tous"
> > de votre logiciel de courrier électronique de façon que le demandeur
> > reçoive une copie de votre réponse.
> >
> >
> > Email: - [hidden email]
> > Sujet: - Calc formule
> > Question: - ma 1ère colonne à tester doit toujours être I, quand j'insère
> > une colonne la formule =NB.SI(I2:AD2;1) devient =NB.SI(J2:AE2;1).
> > Comment figer la colonne I ?
> > Cordialement
> >
> >
> >
> > --
> > Envoyez un mail à [hidden email] pour savoir
> comment
> > vous désinscrire
> > Les archives de la liste sont disponibles à
> > http://listarchives.libreoffice.org/fr/users/
> > Tous les messages envoyés sur cette liste seront archivés publiquement et
> > ne pourront pas être supprimés
>
>
>
>
>
>
>
>
>

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés