Fail to build LO on Windows, Cannot link against library/libraries advapi32.lib

classic Classic list List threaded Threaded
3 messages Options
julien2412 julien2412
Reply | Threaded
Open this post in threaded view
|

Fail to build LO on Windows, Cannot link against library/libraries advapi32.lib

Hello,

First thank you Michael for your fix about this problem: http://nabble.documentfoundation.org/Fail-to-build-LO-on-Windows-missing-separator-in-sal-tp4015192.html

Now I've got this:
/home/annie/libreoffice/master/shell/Library_losessioninstall.mk:19: *** Cannot link against library/libraries advapi32.lib. Libraries must be registered in Repository.mk.  Stop.

Here are more info:
logs.txt

Here's my autogen.lastrun:
autogen.lastrun

master sources updated today and I use GNU Make 3.82
Built for i686-pc-cygwin

Any idea?

Julien
Michael Stahl-2 Michael Stahl-2
Reply | Threaded
Open this post in threaded view
|

Re: Fail to build LO on Windows, Cannot link against library/libraries advapi32.lib

On 09/11/12 20:47, julien2412 wrote:
> Hello,
>
> First thank you Michael for your fix about this problem:
> http://nabble.documentfoundation.org/Fail-to-build-LO-on-Windows-missing-separator-in-sal-tp4015192.html
>
> Now I've got this:
> /home/annie/libreoffice/master/shell/Library_losessioninstall.mk:19: ***
> Cannot link against library/libraries advapi32.lib. Libraries must be
> registered in Repository.mk.  Stop.

have fixed that problem already.  and just fixed the next problem from
that makefile.  i hope my msvc build will finally finish now...


_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
julien2412 julien2412
Reply | Threaded
Open this post in threaded view
|

Re: Fail to build LO on Windows, MSVCR80.dll: cannot open shared object file

Thank you again Michael :-)

Now, I've got "MSVCR80.dll: cannot open shared object file: No such file or directory"
I don't understand since I made the external/msvcp80 thing  (see http://wiki.documentfoundation.org/Development/Windows_Build_Dependencies#Pre-built_Mozilla_libraries)
+ I installed "vcredist_x86.exe"

Julien