Fehler in Bildexport von Calc?

classic Classic list List threaded Threaded
3 messages Options
ernst.huegli@bluewin.ch ernst.huegli@bluewin.ch
Reply | Threaded
Open this post in threaded view
|

Fehler in Bildexport von Calc?

Hallo Listige

Könnte jemand das Problem nachvollziehen und mir entweder bestätigen,
dass es ein Fehler von LO Calc ist, oder mir zeigen, wo ich einen Fehler
mache?

Mein Problem:

Für einen Schulungstext über Calc möchte ich ein Bild der Lösung in den
Text einfügen. Es handelt sich bei der Übung um einen Jahreskalender.
Also markiere ich die erste Jahreshälfte, die gerade eine A4-Seite
Orientierung Landscape füllen sollte. Dann Exportieren ..., Auswahl
angeklickt, als Grafik-Typ entweder JPEG oder png (der Fehler zeigt sich
in beiden Typen), dann Speichern. In den Optionen wähle ich als
Auflösung eine moderate Auflösung für den Druck, also z.B. 180
Pixel/Zoll, als Breite27 cm, Höhe automatisch, dann wird gespeichert.
Wenn ich dann das Bild z.B. in Draw einfüge (um es noch mit Nummern oder
Pfeilen zu ergänzen), dann sind im mittleren Bereich (Zeilen 16 bis 27,
teilweise aber bis zum unteren Tabellenende) die horizontalen
Umrandungslinien weg (im Original waren sie da ...), teilweise aber auch
vertikale Linien. Ich sehe kein Muster, was weggelassen wird, und was
sichtbar ist. Das ändert sich auch nicht, wenn ich die Auflösung etwas
ändere, z.B. 160 oder 200 Pixel/Zoll. Es nützt auch nichts, wenn ich die
von LO vorgeschlagene "Bildschirmauflösung" von 96 Pixel/Zoll wähle.

Seltsam: Wenn ich die Option Auswahl nicht anklicke, dann wird der
gewünschte Ausschnitt zwar klein oben links in einem Bild der Grösse 27
x ca. 16 cm positioniert, aber die Linien sind alle da. Bloss, damit es
brauchbar ist, muss ich jetzt ziemlich stark vergrössern, was z.T. die
Schärfe negativ beeinflusst. Und noch etwas: wenn ich für das Format png
auf die Auflösung 256 Pixel/Zoll gehe, dann wird nur noch die Farbe der
ersten Zelle oben links exportiert - ich habe dann ein leicht rotes
Rechteck, das ist alles ...

Das Ganze sieht mir nach einem Bug aus - oder mache ich was falsch?

Mein System:
LO 6.1.6.3 für x64-Systeme

Betriebssystem Windows 10 Pro Version 1809 (dh. mit allen Aktualisierungen)

Danke schon mal zum voraus und liebe Grüsse aus der bewölkten Schweiz

Ernst


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Gerhard Weydt Gerhard Weydt
Reply | Threaded
Open this post in threaded view
|

Re: Fehler in Bildexport von Calc?

Hallo Ernst,

ich kann dass  nicht nachvollziehen, in einer einigermaßen ähnlichen
Umgebung (Win10, LibO 6.2). Es ist aber auch schwierig, genau zu wissen,
wie deine Datei aussieht. Ich habe einfach in die Standard-Zellen eines
leeren Dokuments Text eingegeben, den nach unten ausgefüllt,
Druckvorschau ausgelöst , um die gestrichelten Linien für die
Seitenaufteilung zu sehen, damit ich weiß, dass ich genügend für eine
DinA4-Seite habe, und dann die Standard-Umrandung ausgelöst.
Wenn ich das dann exportiere und in Draw einfüge, sehe ich alle
Trennlinien (Übrigens, wieso arbeitest du mit Zoll? Bei einem deutschen
System sollte normalerweise cm eingestellt sein: Extras -> Optionen ->
LibreOfficeCalc -> Allgemein).
Da kann natürlich viel reinspielen. Hast du das mal mit einem anderen
Calc-Dokument, vorhanden oder auch testweise erstellt, nachgeprüft. Das
ist ja die erste Frage, ob das am Dokument liegt oder an LibO. Das wäre
als erstes zu klären, bevor jemend anders versucht, da etwas rauszukriegen.
Dann kann es evtl. am Format der Umrandung liegen, das müsste man
wissen, nicht von vornherein auszuschließen ist auch die Zellgröße u. ä.
Wahrscheinlich gibt es noch mehr Möglichkeiten, die mir jetzt nicht
einfallen.
Nach Klärung der Frage, ob das Problem auch bei anderen Dateien
auftritt, müsstest du die Datei (oder auch die Original- und die
Testdatei) auf einen Cloud-Speicher hochladen und den Link in der Liste
mitteilen, damit jemand das anhand dieser Dateien prüfen kann; die Liste
akzeptiert ja keine Anhänge.

Gruß

Gerhard

Am 14.06.2019 um 14:25 schrieb Ernst Hügli:

> Hallo Listige
>
> Könnte jemand das Problem nachvollziehen und mir entweder bestätigen,
> dass es ein Fehler von LO Calc ist, oder mir zeigen, wo ich einen
> Fehler mache?
>
> Mein Problem:
>
> Für einen Schulungstext über Calc möchte ich ein Bild der Lösung in
> den Text einfügen. Es handelt sich bei der Übung um einen
> Jahreskalender. Also markiere ich die erste Jahreshälfte, die gerade
> eine A4-Seite Orientierung Landscape füllen sollte. Dann Exportieren
> ..., Auswahl angeklickt, als Grafik-Typ entweder JPEG oder png (der
> Fehler zeigt sich in beiden Typen), dann Speichern. In den Optionen
> wähle ich als Auflösung eine moderate Auflösung für den Druck, also
> z.B. 180 Pixel/Zoll, als Breite27 cm, Höhe automatisch, dann wird
> gespeichert. Wenn ich dann das Bild z.B. in Draw einfüge (um es noch
> mit Nummern oder Pfeilen zu ergänzen), dann sind im mittleren Bereich
> (Zeilen 16 bis 27, teilweise aber bis zum unteren Tabellenende) die
> horizontalen Umrandungslinien weg (im Original waren sie da ...),
> teilweise aber auch vertikale Linien. Ich sehe kein Muster, was
> weggelassen wird, und was sichtbar ist. Das ändert sich auch nicht,
> wenn ich die Auflösung etwas ändere, z.B. 160 oder 200 Pixel/Zoll. Es
> nützt auch nichts, wenn ich die von LO vorgeschlagene
> "Bildschirmauflösung" von 96 Pixel/Zoll wähle.
>
> Seltsam: Wenn ich die Option Auswahl nicht anklicke, dann wird der
> gewünschte Ausschnitt zwar klein oben links in einem Bild der Grösse
> 27 x ca. 16 cm positioniert, aber die Linien sind alle da. Bloss,
> damit es brauchbar ist, muss ich jetzt ziemlich stark vergrössern, was
> z.T. die Schärfe negativ beeinflusst. Und noch etwas: wenn ich für das
> Format png auf die Auflösung 256 Pixel/Zoll gehe, dann wird nur noch
> die Farbe der ersten Zelle oben links exportiert - ich habe dann ein
> leicht rotes Rechteck, das ist alles ...
>
> Das Ganze sieht mir nach einem Bug aus - oder mache ich was falsch?
>
> Mein System:
> LO 6.1.6.3 für x64-Systeme
>
> Betriebssystem Windows 10 Pro Version 1809 (dh. mit allen
> Aktualisierungen)
>
> Danke schon mal zum voraus und liebe Grüsse aus der bewölkten Schweiz
>
> Ernst
>
>


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Christine Dellacher & Günther Breitfuß Christine Dellacher & Günther Breitfuß
Reply | Threaded
Open this post in threaded view
|

Re: Fehler in Bildexport von Calc?

In reply to this post by ernst.huegli@bluewin.ch
Hallo Ernst,

Export ohne Auswahl exportiert die Tabelle, wie sie in der Druckvorschau
eingestellt ist, z.B. mit Kopf-/Fußzeilen. Export mit Auswahl exportiert
nur den markierten Bereich (=Auswahl). Das Problem mit den
Umrandungslinien habe ich nicht. Sie werden am Monitor nicht immer
korrekt angezeit, aber wenn man hineinzoomt, sind sie bei mir richtig.

Win10, LO 6.2.4

LG Günther

Am 14.06.2019 um 14:25 schrieb Ernst Hügli:

> Hallo Listige
>
> Könnte jemand das Problem nachvollziehen und mir entweder bestätigen,
> dass es ein Fehler von LO Calc ist, oder mir zeigen, wo ich einen
> Fehler mache?
>
> Mein Problem:
>
> Für einen Schulungstext über Calc möchte ich ein Bild der Lösung in
> den Text einfügen. Es handelt sich bei der Übung um einen
> Jahreskalender. Also markiere ich die erste Jahreshälfte, die gerade
> eine A4-Seite Orientierung Landscape füllen sollte. Dann Exportieren
> ..., Auswahl angeklickt, als Grafik-Typ entweder JPEG oder png (der
> Fehler zeigt sich in beiden Typen), dann Speichern. In den Optionen
> wähle ich als Auflösung eine moderate Auflösung für den Druck, also
> z.B. 180 Pixel/Zoll, als Breite27 cm, Höhe automatisch, dann wird
> gespeichert. Wenn ich dann das Bild z.B. in Draw einfüge (um es noch
> mit Nummern oder Pfeilen zu ergänzen), dann sind im mittleren Bereich
> (Zeilen 16 bis 27, teilweise aber bis zum unteren Tabellenende) die
> horizontalen Umrandungslinien weg (im Original waren sie da ...),
> teilweise aber auch vertikale Linien. Ich sehe kein Muster, was
> weggelassen wird, und was sichtbar ist. Das ändert sich auch nicht,
> wenn ich die Auflösung etwas ändere, z.B. 160 oder 200 Pixel/Zoll. Es
> nützt auch nichts, wenn ich die von LO vorgeschlagene
> "Bildschirmauflösung" von 96 Pixel/Zoll wähle.
>
> Seltsam: Wenn ich die Option Auswahl nicht anklicke, dann wird der
> gewünschte Ausschnitt zwar klein oben links in einem Bild der Grösse
> 27 x ca. 16 cm positioniert, aber die Linien sind alle da. Bloss,
> damit es brauchbar ist, muss ich jetzt ziemlich stark vergrössern, was
> z.T. die Schärfe negativ beeinflusst. Und noch etwas: wenn ich für das
> Format png auf die Auflösung 256 Pixel/Zoll gehe, dann wird nur noch
> die Farbe der ersten Zelle oben links exportiert - ich habe dann ein
> leicht rotes Rechteck, das ist alles ...
>
> Das Ganze sieht mir nach einem Bug aus - oder mache ich was falsch?
>
> Mein System:
> LO 6.1.6.3 für x64-Systeme
>
> Betriebssystem Windows 10 Pro Version 1809 (dh. mit allen
> Aktualisierungen)
>
> Danke schon mal zum voraus und liebe Grüsse aus der bewölkten Schweiz
>
> Ernst
>
>
--
privat
 

Christine Dellacher & Günther Breitfuß

[hidden email] <mailto:[hidden email]>
Christine Dellacher +43 650 72 65 714
Günther Breitfuß +43 650 22 44 567

       

Ahornweg 8
4800 Attnang-Puchheim

         


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy