FlatPak on Ubuntu 14.04??

classic Classic list List threaded Threaded
9 messages Options
CVAlkan CVAlkan
Reply | Threaded
Open this post in threaded view
|

FlatPak on Ubuntu 14.04??

This is probably more of a flatpak question than a libreoffice question, but ...

Will the LibreOffice in FlatPak format eventually be available for Ubuntu versions earlier than 14.04. I've been following the progress of the next LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all the app support I need to upgrade yet.

Has anyone attempted to "fudge this into working (e.g. upgrading Gnome stuff, etc.)? I've only used one of these "packaged" app systems so far (MuseScore.AppImage) but it appears to work really well ...

Thanks for any comments or info ...
Paul D. Mirowsky Paul D. Mirowsky
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

If you are talking about package management.

Flatpak is a Red Hat Product.

See https://fedoramagazine.org/introducing-flatpak/

Ubuntu is using Snap

See "Universal “snap” packages launch on multiple Linux distros" at
https://insights.ubuntu.com/2016/06/14/universal-snap-packages-launch-on-multiple-linux-distros/

For more in LibreOffice and Snap see "LibreOffice 5.2.0 beta2 as a snap
package"
https://skyfromme.wordpress.com/2016/06/14/libreoffice-5-2-0-beta2-as-a-snap-package/

Hope it helps
Paul

On 6/22/2016 8:48 AM, CVAlkan wrote:

> This is probably more of a flatpak question than a libreoffice question, but
> ...
>
> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
> versions earlier than 14.04. I've been following the progress of the next
> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all
> the app support I need to upgrade yet.
>
> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
> stuff, etc.)? I've only used one of these "packaged" app systems so far
> (MuseScore.AppImage) but it appears to work really well ...
>
> Thanks for any comments or info ...
>
>
>
> --
> View this message in context: http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
> Sent from the Users mailing list archive at Nabble.com.
>


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Daniel Espinosa Daniel Espinosa
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

Flatpak PPA is available for 16.04 as for

https://launchpad.net/~alexlarsson/+archive/ubuntu/flatpak

It is well supported in Debian, at least for my box using Debian 8 and my
upgrade to Testing.

May the question is if this PPA will provide support for 14.04. May ask
Alex.
El jun. 22, 2016 10:41 AM, "Paul D. Mirowsky" <[hidden email]>
escribió:

> If you are talking about package management.
>
> Flatpak is a Red Hat Product.
>
> See https://fedoramagazine.org/introducing-flatpak/
>
> Ubuntu is using Snap
>
> See "Universal “snap” packages launch on multiple Linux distros" at
> https://insights.ubuntu.com/2016/06/14/universal-snap-packages-launch-on-multiple-linux-distros/
>
> For more in LibreOffice and Snap see "LibreOffice 5.2.0 beta2 as a snap
> package"
> https://skyfromme.wordpress.com/2016/06/14/libreoffice-5-2-0-beta2-as-a-snap-package/
>
> Hope it helps
> Paul
>
> On 6/22/2016 8:48 AM, CVAlkan wrote:
>
>> This is probably more of a flatpak question than a libreoffice question,
>> but
>> ...
>>
>> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
>> versions earlier than 14.04. I've been following the progress of the next
>> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all
>> the app support I need to upgrade yet.
>>
>> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
>> stuff, etc.)? I've only used one of these "packaged" app systems so far
>> (MuseScore.AppImage) but it appears to work really well ...
>>
>> Thanks for any comments or info ...
>>
>>
>>
>> --
>> View this message in context:
>> http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
>> Sent from the Users mailing list archive at Nabble.com.
>>
>>
>
> --
> To unsubscribe e-mail to: [hidden email]
> Problems?
> http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be
> deleted
>
>

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Jim Byrnes Jim Byrnes
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

In reply to this post by Paul D. Mirowsky
On 06/22/2016 10:40 AM, Paul D. Mirowsky wrote:
> If you are talking about package management.
>
> Flatpak is a Red Hat Product.
>
> See https://fedoramagazine.org/introducing-flatpak/

It is, but it seems to be going cross platform just like Snap.

http://arstechnica.com/information-technology/2016/06/here-comes-flatpak-a-competitor-to-ubuntus-cross-platform-linux-apps/

> Ubuntu is using Snap
>
> See "Universal “snap” packages launch on multiple Linux distros" at
> https://insights.ubuntu.com/2016/06/14/universal-snap-packages-launch-on-multiple-linux-distros/
>
>
> For more in LibreOffice and Snap see "LibreOffice 5.2.0 beta2 as a snap
> package"
> https://skyfromme.wordpress.com/2016/06/14/libreoffice-5-2-0-beta2-as-a-snap-package/
>
>
> Hope it helps
> Paul
>
> On 6/22/2016 8:48 AM, CVAlkan wrote:
>> This is probably more of a flatpak question than a libreoffice
>> question, but
>> ...
>>
>> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
>> versions earlier than 14.04. I've been following the progress of the next
>> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have
>> all
>> the app support I need to upgrade yet.
>>
>> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
>> stuff, etc.)? I've only used one of these "packaged" app systems so far
>> (MuseScore.AppImage) but it appears to work really well ...
>>
>> Thanks for any comments or info ...
>>
>>
>>
>> --
>> View this message in context:
>> http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
>>
>> Sent from the Users mailing list archive at Nabble.com.
>>
>
>



--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

CVAlkan CVAlkan
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

Wow - thanks for all the comments, but ...

Flatpak IS available for Ubuntu, but only for 16.04.

Ubuntu Snap is also available for 16.04 (actually for 15.04 as well, but that uses a different, obsolete form)

Neither claims to support 14.04, but I thought I would see if anyone had found a way to do so without making drastic changes to the kernel or anything.

Apparently, however, the answer is No.
Bastián Díaz-2 Bastián Díaz-2
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

In reply to this post by CVAlkan
 

See:
https://lists.freedesktop.org/archives/xdg-app/2016-June/000230.html

You could ask that Flatpak support in this mailing list. Cheers.

El 22-06-2016 08:48, CVAlkan escribió:

> This is probably more of a flatpak question than a libreoffice question, but
> ...
>
> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
> versions earlier than 14.04. I've been following the progress of the next
> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all
> the app support I need to upgrade yet.
>
> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
> stuff, etc.)? I've only used one of these "packaged" app systems so far
> (MuseScore.AppImage) but it appears to work really well ...
>
> Thanks for any comments or info ...
>
> --
> View this message in context: http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html [1]
> Sent from the Users mailing list archive at Nabble.com.

 

Links:
------
[1]
http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Bastián Díaz-2 Bastián Díaz-2
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

In reply to this post by Paul D. Mirowsky
 

Flatpak is not a product of Red Hat... http://flatpak.org/faq.html

El 22-06-2016 11:40, Paul D. Mirowsky escribió:

> If you are talking about package management.
>
> Flatpak is a Red Hat Product.
>
> See https://fedoramagazine.org/introducing-flatpak/ [2]
>
> Ubuntu is using Snap
>
> See "Universal "snap" packages launch on multiple Linux distros" at https://insights.ubuntu.com/2016/06/14/universal-snap-packages-launch-on-multiple-linux-distros/ [3]
>
> For more in LibreOffice and Snap see "LibreOffice 5.2.0 beta2 as a snap package" https://skyfromme.wordpress.com/2016/06/14/libreoffice-5-2-0-beta2-as-a-snap-package/ [4]
>
> Hope it helps
> Paul
>
> On 6/22/2016 8:48 AM, CVAlkan wrote:
>
>> This is probably more of a flatpak question than a libreoffice question, but ... Will the LibreOffice in FlatPak format eventually be available for Ubuntu versions earlier than 14.04. I've been following the progress of the next LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all the app support I need to upgrade yet. Has anyone attempted to "fudge this into working (e.g. upgrading Gnome stuff, etc.)? I've only used one of these "packaged" app systems so far (MuseScore.AppImage) but it appears to work really well ... Thanks for any comments or info ... -- View this message in context: http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html [1] Sent from the Users mailing list archive at Nabble.com.

 

Links:
------
[1]
http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
[2] https://fedoramagazine.org/introducing-flatpak/
[3]
https://insights.ubuntu.com/2016/06/14/universal-snap-packages-launch-on-multiple-linux-distros/
[4]
https://skyfromme.wordpress.com/2016/06/14/libreoffice-5-2-0-beta2-as-a-snap-package/
--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Paul D. Mirowsky Paul D. Mirowsky
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

In reply to this post by Bastián Díaz-2
My apologies, you are correct.


On 6/22/2016 6:06 PM, Bastián Díaz wrote:

>  
>
> See:
> https://lists.freedesktop.org/archives/xdg-app/2016-June/000230.html
>
> You could ask that Flatpak support in this mailing list. Cheers.
>
> El 22-06-2016 08:48, CVAlkan escribió:
>
>> This is probably more of a flatpak question than a libreoffice question, but
>> ...
>>
>> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
>> versions earlier than 14.04. I've been following the progress of the next
>> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have all
>> the app support I need to upgrade yet.
>>
>> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
>> stuff, etc.)? I've only used one of these "packaged" app systems so far
>> (MuseScore.AppImage) but it appears to work really well ...
>>
>> Thanks for any comments or info ...
>>
>> --
>> View this message in context: http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html [1]
>> Sent from the Users mailing list archive at Nabble.com.
>  
>
> Links:
> ------
> [1]
> http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
TomD TomD
Reply | Threaded
Open this post in threaded view
|

Re: FlatPak on Ubuntu 14.04??

Hi :)
I thought it was only bug-fixes and simple upgrades that were back-ported
to LTS releases?

I thought there had been a bit of argument within the Ubuntu community
about that sort of thing and how it is difficult to maintain all the
dependancies.  A very old version of an Ubuntu LTS becomes a bit like a
Redhat with just really old versions of old programs.

You could always try installing things directly using the Windows method of
trying to stumble onto the right website and hope that it's download hasn't
been compromised and then install that.  I can't see that as an attractive
route though.

I used to have a multi-boot machine for myself and tried to use the latest
LTS fairly shortly after release.  Then it'd be several weeks or even a
couple of months before i'd upgrade a couple of other machines.  Then a
decent chunk of the remaining ones another few months, or even years after
that.  I'd always have a few with really ancient LTSes on just because
those machines wouldn't get used so much.  One time i tried to leap-frog by
starting the upgrade cycle with those machines ahead of the rest but people
still didn't use them much so i didn't get as much feedback about the
newest LTS that way.

It's not such a problem having people on different versions of Ubuntu as it
is with Windows.  Different versions of programs or even different programs
doing the same job is MUCH less of an issue than when using Microsquish
stuff.

Regards from
Tom :)



On 23 June 2016 at 15:52, Paul D. Mirowsky <[hidden email]> wrote:

> My apologies, you are correct.
>
>
>
> On 6/22/2016 6:06 PM, Bastián Díaz wrote:
>
>>
>> See:
>> https://lists.freedesktop.org/archives/xdg-app/2016-June/000230.html
>>
>> You could ask that Flatpak support in this mailing list. Cheers.
>>
>> El 22-06-2016 08:48, CVAlkan escribió:
>>
>> This is probably more of a flatpak question than a libreoffice question,
>>> but
>>> ...
>>>
>>> Will the LibreOffice in FlatPak format eventually be available for Ubuntu
>>> versions earlier than 14.04. I've been following the progress of the next
>>> LTS version (Ubuntu 16.04), but it doesn't seem stable enough nor have
>>> all
>>> the app support I need to upgrade yet.
>>>
>>> Has anyone attempted to "fudge this into working (e.g. upgrading Gnome
>>> stuff, etc.)? I've only used one of these "packaged" app systems so far
>>> (MuseScore.AppImage) but it appears to work really well ...
>>>
>>> Thanks for any comments or info ...
>>>
>>> --
>>> View this message in context:
>>> http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
>>> [1]
>>> Sent from the Users mailing list archive at Nabble.com.
>>>
>>
>> Links:
>> ------
>> [1]
>>
>> http://nabble.documentfoundation.org/FlatPak-on-Ubuntu-14-04-tp4186884.html
>>
>
>
> --
> To unsubscribe e-mail to: [hidden email]
> Problems?
> http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be
> deleted
>

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted