Grammalecte & Python

classic Classic list List threaded Threaded
12 messages Options
Eric Hoffmann-2 Eric Hoffmann-2
Reply | Threaded
Open this post in threaded view
|

Grammalecte & Python

Bonjour,Je n'arrive pas à faire fonctionner Grammalecte sur LO 4.2.3 /
    Ubuntu 12.04 LTS.Dans les options, tout me semble correct : dans 'Linguisitique'
    Grammalecte est bien cochée.L'extension s'installe sans message d'erreur (v 0.4.0.1)J'ai l'impression que le problème vient de Python.Dans Synaptic, le paquet python-uno est installé (v 4.2.3)Quand je demande l'installation de python3-uno, j'obtiens le message
    'refus d'installer pour dépendance non résolue'.Savez-vous comment faire ?Merci.Bon WE et bonne fête des mères !--Éric HOFFMANN


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Eric Hoffmann-2 Eric Hoffmann-2
Reply | Threaded
Open this post in threaded view
|

Grammalecte & Python

Je constate que mon message précédent est mal mis en forme et donc
difficile à lire. Je le re-poste au format texte :

Bonjour,

Je n'arrive pas à faire fonctionner Grammalecte sur LO 4.2.3 /Ubuntu 12.04 LTS.
Dans les options, tout me semble correct : dans 'Linguisitique'Grammalecte est bien cochée.

L'extension s'installe sans message d'erreur (v 0.4.0.1).

J'ai l'impression que le problème vient de Python.
Dans Synaptic, le paquet python-uno est installé (v 4.2.3)
Quand je demande l'installation de python3-uno, j'obtiens le message 'refus d'installer pour dépendance non résolue'.

Savez-vous comment faire ?

Merci.

Bon WE et bonne fête des mères !

--
Éric HOFFMANN


--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Jean-Baptiste Faure Jean-Baptiste Faure
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

Bonjour,

Le 24/05/2014 15:43, Eric Hoffmann a écrit :
> Je constate que mon message précédent est mal mis en forme et donc
> difficile à lire. Je le re-poste au format texte :
>
> Bonjour,
>
> Je n'arrive pas à faire fonctionner Grammalecte sur LO 4.2.3 /Ubuntu
> 12.04 LTS.

Qu'est-ce qui te fait dire que Grammalecte ne fonctionne pas ?
Tu écris une phrase volontairement fautive et Grammalecte ne souligne
rien en bleu ? Vérifie que ton texte est bien configuré en français
(option de la police de caractères).

Bonne journée
JBF

--
Seuls des formats ouverts peuvent assurer la pérennité de vos documents.

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Thierry Munoz Thierry Munoz
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

Le 25/05/2014 11:01, Jean-Baptiste Faure a écrit :

> Bonjour,
>
> Le 24/05/2014 15:43, Eric Hoffmann a écrit :
>> Je constate que mon message précédent est mal mis en forme et donc
>> difficile à lire. Je le re-poste au format texte :
>>
>> Bonjour,
>>
>> Je n'arrive pas à faire fonctionner Grammalecte sur LO 4.2.3 /Ubuntu
>> 12.04 LTS.
> Qu'est-ce qui te fait dire que Grammalecte ne fonctionne pas ?
> Tu écris une phrase volontairement fautive et Grammalecte ne souligne
> rien en bleu ? Vérifie que ton texte est bien configuré en français
> (option de la police de caractères).
>
> Bonne journée
> JBF
>
Bonjour à tous,
Désolé, mais Grammalecte v0.4.0.1 ne fonctionne pas chez moi non plus
sous Ubuntu 12.04 et Libreoffice Officiel (Version: 4.2.4.2 Build ID:
420m0(Build:2) malgré une purge du profil (et sans avoir LanguageTool
installé). Problème avec Python ?
Cordialement,

Thierry

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Olivier R. Olivier R.
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

In reply to this post by Eric Hoffmann-2
Eric Hoffmann-2 wrote
Quand je demande l'installation de python3-uno, j'obtiens le message 'refus d'installer pour dépendance non résolue'.
Il ne suffit pas d’installer python3-uno. Il faut aussi installer Python 3.
Je parie que la distrib installe plutôt Python 2.7 par défaut.

Olivier
Olivier R. Olivier R.
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

Olivier R. wrote
Il ne suffit pas d’installer python3-uno. Il faut aussi installer Python 3.
Python 3.3 ou supérieur pour être exact.
Eric Hoffmann-2 Eric Hoffmann-2
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

Bonsoir,@ Jean-Baptiste : une phrase contenant une faute de grammaire
      simple (accord article-nom ou erreur de ponctuation/espace) n'est
      pas reconnue, pas de soulignement bleu.@ Olivier : effectivement, dans ma version de Ubuntu (12.04 LTS)
      Python 2.7 semble installé. Cependant 1 paquet Python3 (v3.2.3) et
      1 paquet Python3-minimal (v3.2.3) sont également installés. Cela
      est-il source de conflit ?Je n'ai rien trouvé dans doc.ubuntu-fr.org ni dans forum-fr.org.
      Je suis mal parti !Quelqu'un sait-il comment on fait pour installer proprement Python
      3.3 sur Ubuntu 12.04 ?Merci.Bonne soirée,Éric HOFFMANN
Le 26/05/2014 10:25, Olivier R. a écrit :
Olivier R. wroteIl ne suffit pas d’installer python3-uno. Il faut aussi installer Python
3.Python 3.3 ou supérieur pour être exact.




--
View this message in context:http://nabble.documentfoundation.org/Grammalecte-Python-tp4110059p4110282.htmlSent from the Users mailing list archive at Nabble.com.
--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Thierry Munoz Thierry Munoz
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

In reply to this post by Olivier R.
Le 26/05/2014 08:25, Olivier R. a écrit :

> Olivier R. wrote
>> Il ne suffit pas d’installer python3-uno. Il faut aussi installer Python
>> 3.
> Python 3.3 ou supérieur pour être exact.
>
>
>
> --
> View this message in context: http://nabble.documentfoundation.org/Grammalecte-Python-tp4110059p4110282.html
> Sent from the Users mailing list archive at Nabble.com.
>
Bonjour,
Merci pour la précision. Effectivement sur Ubuntu 12.04, j'ai Python
3.2.3 d'installé et ça ne marche pas.
Il y a par contre des difficultés pour installer Python3.3 sur Ubuntu
12.04... À voir,
Cordialement,

Thierry

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Olivier R. Olivier R.
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

In reply to this post by Eric Hoffmann-2
Eric Hoffmann-2 wrote
@ Olivier : effectivement, dans ma version de Ubuntu (12.04 LTS)
      Python 2.7 semble installé. Cependant 1 paquet Python3 (v3.2.3) et
      1 paquet Python3-minimal (v3.2.3) sont également installés. Cela
      est-il source de conflit ?
Python 3.2 ne peut en aucun cas satisfaire ce qu’on lui demande. Python 3.3 est REQUIS.

Mais je n’en sais pas plus, je ne sais pas quelles modifications qui compliquent la vie cette distribution a cru utile de faire.

Olivier
Franck Larrivé-2 Franck Larrivé-2
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

In reply to this post by Thierry Munoz
Le 26/05/2014 18:03, Thierry Munoz a écrit :
> Merci pour la précision. Effectivement sur Ubuntu 12.04, j'ai Python
> 3.2.3 d'installé et ça ne marche pas.
> Il y a par contre des difficultés pour installer Python3.3 sur Ubuntu
> 12.04... À voir,
Bonjour,
voila un lien pour surmonter les difficultés...
http://linuxg.net/how-to-install-python-3-3-on-ubuntu-13-04-12-10-and-12-04/

Cordialement,
Franck

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Jacques Spring Jacques Spring
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

Le 27/05/2014 22:33, Franck Larrivé a écrit :

> Le 26/05/2014 18:03, Thierry Munoz a écrit :
>> Merci pour la précision. Effectivement sur Ubuntu 12.04, j'ai Python
>> 3.2.3 d'installé et ça ne marche pas.
>> Il y a par contre des difficultés pour installer Python3.3 sur Ubuntu
>> 12.04... À voir,
> Bonjour,
> voila un lien pour surmonter les difficultés...
> http://linuxg.net/how-to-install-python-3-3-on-ubuntu-13-04-12-10-and-12-04/ 
>
>
> Cordialement,
> Franck
>

Bonjour,

ou bien peut-être :

  * _*Linux*_ : veillez à installer la « passerelle Python-UNO », le
    paquet se nomme en
    général/libreoffice-pyuno/,/python3-uno/ou/openoffice-python-uno/ou
    quelque chose d’approchant, ça dépend des
    distributions./Grammalecte/fonctionne avec Python 3.3, ou en version
    rétrocompatible avec Python 2.7. Si vous avez un problème persistant
    pour installer l’extension, installez les versions officielles de
    LibreOffice / OpenOffice.


ici : http://www.dicollecte.org/grammalecte/telecharger.php




--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés
Thierry Munoz Thierry Munoz
Reply | Threaded
Open this post in threaded view
|

Re: Grammalecte & Python

In reply to this post by Franck Larrivé-2
Le 27/05/2014 22:33, Franck Larrivé a écrit :

> Le 26/05/2014 18:03, Thierry Munoz a écrit :
>> Merci pour la précision. Effectivement sur Ubuntu 12.04, j'ai Python
>> 3.2.3 d'installé et ça ne marche pas.
>> Il y a par contre des difficultés pour installer Python3.3 sur Ubuntu
>> 12.04... À voir,
> Bonjour,
> voila un lien pour surmonter les difficultés...
> http://linuxg.net/how-to-install-python-3-3-on-ubuntu-13-04-12-10-and-12-04/ 
>
>
> Cordialement,
> Franck
>
Merci Franck pour ton lien.
Attention, il ne faut pas oublier d'installer le paquet
"python3-deadsnakes-all" et la version officielle de LibreOffice.
Malgré cela, il y a un problème de dépendances avec le paquet
"python-uno" (qui refuse de se désinstaller et lié à Libo 4.2.4 packagée
pour Ubuntu), mais là ça marche.
Cordialement,

Thierry

--
Envoyez un mail à [hidden email] pour savoir comment vous désinscrire
Les archives de la liste sont disponibles à http://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne pourront pas être supprimés