Icu error with Firebird 3.0 patch

classic Classic list List threaded Threaded
9 messages Options
marius adrian popa marius adrian popa
Reply | Threaded
Open this post in threaded view
|

Icu error with Firebird 3.0 patch


_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Adriano dos Santos Fernandes Adriano dos Santos Fernandes
Reply | Threaded
Open this post in threaded view
|

Re: [Firebird-devel] Icu error with Firebird 3.0 patch

On 31/03/2016 16:07, marius adrian popa wrote:

> I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)
>
> https://gist.github.com/mariuz/bcde7f783b657b2465e5
>
> and there are few issues with icu linking
>
> https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2
>
> https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036
>

Maybe if you explain how this patch or build environment differ from the
standalone Firebird one which is working...


Adriano

_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Lionel Elie Mamane Lionel Elie Mamane
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

In reply to this post by marius adrian popa
On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)

> https://gist.github.com/mariuz/bcde7f783b657b2465e5

> and there are few issues with icu linking

> https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036

It looks like it is being linked to a different libicutu.so than it
expects... I notice that the patch removes --with-system-icu from the
firebird configure options, is that the right thing to do?

--
Lionel
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Michal Kubecek Michal Kubecek
Reply | Threaded
Open this post in threaded view
|

Re: [Firebird-devel] Icu error with Firebird 3.0 patch

On Fri, Apr 01, 2016 at 12:48:00PM +0200, Lionel Elie Mamane wrote:

> On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> > I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)
>
> > https://gist.github.com/mariuz/bcde7f783b657b2465e5
>
> > and there are few issues with icu linking
>
> > https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036
>
> I notice that the patch removes --with-system-icu from the firebird
> configure options, is that the right thing to do?

This option has been removed in master branch by commit de453fcfd3de
("Check for presence of ICU development package in configure, related
cleanup") in November 2010.

                                                       Michal Kubecek

_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
marius adrian popa marius adrian popa
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

In reply to this post by Lionel Elie Mamane
FB3 has no ICU sources in the tree anymore so is using system-icu by default or the ones downloaded with libo tree (that is why it was removed from the configure flags --with-system-icu)

I will try now a libo build with 
./configure --enable-firebird-sdbc --without-system-firebird --with-system-icu --with-system-icu-for-build=yes

On Fri, Apr 1, 2016 at 1:48 PM, Lionel Elie Mamane <[hidden email]> wrote:
On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)

> https://gist.github.com/mariuz/bcde7f783b657b2465e5

> and there are few issues with icu linking

> https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036

It looks like it is being linked to a different libicutu.so than it
expects... I notice that the patch removes --with-system-icu from the
firebird configure options, is that the right thing to do?

--
Lionel


_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Lionel Elie Mamane Lionel Elie Mamane
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

Ah, I see.

On Fri, Apr 01, 2016 at 04:45:28PM +0300, marius adrian popa wrote:

> FB3 has no ICU sources in the tree anymore so is using system-icu by
> default or the ones downloaded with libo tree (that is why it was removed
> from the configure flags --with-system-icu)
>
> I will try now a libo build with
> ./configure --enable-firebird-sdbc --without-system-firebird
> --with-system-icu --with-system-icu-for-build=yes
>
> On Fri, Apr 1, 2016 at 1:48 PM, Lionel Elie Mamane <[hidden email]> wrote:
>
> > On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> > > I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)
> >
> > > https://gist.github.com/mariuz/bcde7f783b657b2465e5
> >
> > > and there are few issues with icu linking
> >
> > >
> > https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036
> >
> > It looks like it is being linked to a different libicutu.so than it
> > expects... I notice that the patch removes --with-system-icu from the
> > firebird configure options, is that the right thing to do?
> >
> > --
> > Lionel
> >
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
marius adrian popa marius adrian popa
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

False alarm it was the comments that i forgot in download.lst (I forgot to comment 2.5.5 and enable 3.0)

I have updated the patch and now it compiles fine on ubuntu 15.10 x64


-# FIREBIRD_MD5SUM := b259c2d1c60a03bd104108405ae990a7
-# export FIREBIRD_TARBALL := Firebird-3.0-alpha1-20130302.tar.gz
+# FIREBIRD_MD5SUM := 51d35d33d16980d765c0617683ecbcbf
+# export FIREBIRD_TARBALL := Firebird-3.0.0.32366-ReleaseCandidate2.tar.bz2

On Fri, Apr 1, 2016 at 4:47 PM, Lionel Elie Mamane <[hidden email]> wrote:
Ah, I see.

On Fri, Apr 01, 2016 at 04:45:28PM +0300, marius adrian popa wrote:
> FB3 has no ICU sources in the tree anymore so is using system-icu by
> default or the ones downloaded with libo tree (that is why it was removed
> from the configure flags --with-system-icu)
>
> I will try now a libo build with
> ./configure --enable-firebird-sdbc --without-system-firebird
> --with-system-icu --with-system-icu-for-build=yes
>
> On Fri, Apr 1, 2016 at 1:48 PM, Lionel Elie Mamane <[hidden email]> wrote:
>
> > On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> > > I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)
> >
> > > https://gist.github.com/mariuz/bcde7f783b657b2465e5
> >
> > > and there are few issues with icu linking
> >
> > >
> > https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036
> >
> > It looks like it is being linked to a different libicutu.so than it
> > expects... I notice that the patch removes --with-system-icu from the
> > firebird configure options, is that the right thing to do?
> >
> > --
> > Lionel
> >


_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
marius adrian popa marius adrian popa
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

Good news : Firebird 3.0 builds and works now with libreoffice

I have updated the patch and now it compiles fine on ubuntu 15.10 x64
https://gist.github.com/mariuz/bcde7f783b657b2465e5

Submited new gerrit
https://gerrit.libreoffice.org/23737

On Fri, Apr 1, 2016 at 7:22 PM, marius adrian popa <[hidden email]> wrote:
False alarm it was the comments that i forgot in download.lst (I forgot to comment 2.5.5 and enable 3.0)

I have updated the patch and now it compiles fine on ubuntu 15.10 x64


-# FIREBIRD_MD5SUM := b259c2d1c60a03bd104108405ae990a7
-# export FIREBIRD_TARBALL := Firebird-3.0-alpha1-20130302.tar.gz
+# FIREBIRD_MD5SUM := 51d35d33d16980d765c0617683ecbcbf
+# export FIREBIRD_TARBALL := Firebird-3.0.0.32366-ReleaseCandidate2.tar.bz2

On Fri, Apr 1, 2016 at 4:47 PM, Lionel Elie Mamane <[hidden email]> wrote:
Ah, I see.

On Fri, Apr 01, 2016 at 04:45:28PM +0300, marius adrian popa wrote:
> FB3 has no ICU sources in the tree anymore so is using system-icu by
> default or the ones downloaded with libo tree (that is why it was removed
> from the configure flags --with-system-icu)
>
> I will try now a libo build with
> ./configure --enable-firebird-sdbc --without-system-firebird
> --with-system-icu --with-system-icu-for-build=yes
>
> On Fri, Apr 1, 2016 at 1:48 PM, Lionel Elie Mamane <[hidden email]> wrote:
>
> > On Thu, Mar 31, 2016 at 10:07:41PM +0300, marius adrian popa wrote:
> > > I started refactoring firebird 3.0 patch for libreoffice (updated to rc2)
> >
> > > https://gist.github.com/mariuz/bcde7f783b657b2465e5
> >
> > > and there are few issues with icu linking
> >
> > >
> > https://gist.github.com/mariuz/68588eabb4f40c8aa008a601eade91e2#gistcomment-1739036
> >
> > It looks like it is being linked to a different libicutu.so than it
> > expects... I notice that the patch removes --with-system-icu from the
> > firebird configure options, is that the right thing to do?
> >
> > --
> > Lionel
> >



_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
David Tardon David Tardon
Reply | Threaded
Open this post in threaded view
|

Re: Icu error with Firebird 3.0 patch

In reply to this post by marius adrian popa
Hi,

On Fri, Apr 01, 2016 at 04:45:28PM +0300, marius adrian popa wrote:
> FB3 has no ICU sources in the tree anymore so is using system-icu by
> default or the ones downloaded with libo tree (that is why it was removed
> from the configure flags --with-system-icu)
>
> I will try now a libo build with
> ./configure --enable-firebird-sdbc --without-system-firebird
> --with-system-icu
> --with-system-icu-for-build=yes

This option is for cross-compilation.

D.
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice