Impressのアニメーションがうまく動かない6.3.5, 6.4.2

classic Classic list List threaded Threaded
9 messages Options
ANEZAKI AKIHIRO(姉崎 章博) ANEZAKI AKIHIRO(姉崎 章博)
Reply | Threaded
Open this post in threaded view
|

Impressのアニメーションがうまく動かない6.3.5, 6.4.2

姉崎です。

最新版のLibreOfficeでImpressのアニメーションがうまく動かないことがあって、
安定版ばかり使っていたのですが、
今の安定版6.3.5で特定のページのアニメーションがうまく動かないようです。
うまくいかなかったページの一つが下記のスライドです。

 https://jpn.nec.com/oss/osslc/Sample.odp

アニメーションの指定が多すぎるのかなぁ。1スライドに23個

試しに最新版の6.4.2にしてみました同じくダメでした。

前の安定版の6.2.8ではうまく表示されます。
Windows(10) 64-bit版です。

--

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

nogajun nogajun
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

野方です。
Linux(Debian Sid/amd64/Debian版/TDF版)ですが試してみました。

6.3.4(AppImage版)ではアニメーションが最後まで動きました。

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa

途中順番が変わったり途中で終わってしまったのは以下のバージョンでした。

バージョン: 6.3.5.2
Build ID: dd0751754f11728f69b42ee2af66670068624673
バージョン: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
バージョン: 7.0.0.0.alpha0+
Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab

2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:
> アニメーションの指定が多すぎるのかなぁ。1スライドに23個

試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。

サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。

アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。


2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:

>
> 姉崎です。
>
> 最新版のLibreOfficeでImpressのアニメーションがうまく動かないことがあって、
> 安定版ばかり使っていたのですが、
> 今の安定版6.3.5で特定のページのアニメーションがうまく動かないようです。
> うまくいかなかったページの一つが下記のスライドです。
>
>  https://jpn.nec.com/oss/osslc/Sample.odp
>
> アニメーションの指定が多すぎるのかなぁ。1スライドに23個
>
> 試しに最新版の6.4.2にしてみました同じくダメでした。
>
> 前の安定版の6.2.8ではうまく表示されます。
> Windows(10) 64-bit版です。
>
> --
>
> --
> Unsubscribe instructions: E-mail to [hidden email]
> Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
> List archive: https://listarchives.libreoffice.org/ja/users/
> Privacy Policy: https://www.documentfoundation.org/privacy
>


--
野方 純 (NOGATA,Jun) - mail: [hidden email]
                     - web: http://www.nofuture.tv/diary/

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy
ANEZAKI AKIHIRO(姉崎 章博) ANEZAKI AKIHIRO(姉崎 章博)
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

姉崎です。

野方さん

 追確認、ありがとうございます。

On 2020/03/26 20:28, Jun Nogata wrote:

> 6.3.4(AppImage版)ではアニメーションが最後まで動きました。
>
> Version: 6.3.4.2
> Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
>
> 途中順番が変わったり途中で終わってしまったのは以下のバージョンでした。
>
> バージョン: 6.3.5.2
> Build ID: dd0751754f11728f69b42ee2af66670068624673
> バージョン: 6.4.2.2
> Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
> バージョン: 7.0.0.0.alpha0+
> Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab

6.3.4.2ではうまく動くのですね。

> 2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:
>> アニメーションの指定が多すぎるのかなぁ。1スライドに23個
>
> 試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。
>
> サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
> アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。
>
> アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。

条件が読めないから、修正はあまり期待できないですね。

--

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

So So
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

矢内原です。

Mac でも再現しました。
バージョン: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS:Mac OS X 10.14.6; UI render: default; VCL: osx;
ロケール: ja-JP (ja_JP.UTF-8); UIの言語: ja-JP
Calc: threaded

6.3.5で入ったアニメーション関連の変更を探したら、次のバグの修正がありました。
https://bugs.documentfoundation.org/show_bug.cgi?id=125949

masterブランチで、この修正パッチで slideshow/source/engine/effectrewinder.cxx に追加された
skipSingleMainSequenceEffects() の呼び出し部分をコメントアウトしたら
最後までアニメーションが再生されるようになりました。

> 2020/03/27 9:41、ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>のメール:
>
> 姉崎です。
>
> 野方さん
>
>  追確認、ありがとうございます。
>
> On 2020/03/26 20:28, Jun Nogata wrote:
>> 6.3.4(AppImage版)ではアニメーションが最後まで動きました。
>>
>> Version: 6.3.4.2
>> Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
>>
>> 途中順番が変わったり途中で終わってしまったのは以下のバージョンでした。
>>
>> バージョン: 6.3.5.2
>> Build ID: dd0751754f11728f69b42ee2af66670068624673
>> バージョン: 6.4.2.2
>> Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
>> バージョン: 7.0.0.0.alpha0+
>> Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
>
> 6.3.4.2ではうまく動くのですね。
>
>> 2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:
>>> アニメーションの指定が多すぎるのかなぁ。1スライドに23個
>>
>> 試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。
>>
>> サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
>> アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。
>>
>> アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。
>
> 条件が読めないから、修正はあまり期待できないですね。
>
> --
>
> --
> Unsubscribe instructions: E-mail to [hidden email]
> Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
> List archive: https://listarchives.libreoffice.org/ja/users/
> Privacy Policy: https://www.documentfoundation.org/privacy
>


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy
JO3EMC JO3EMC
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

岩橋いさなです。

アニメーションどころかImpress自体門外漢なのですが、野方さんのプッシュを受けてサンプルファイルを眺めてみたところ、手元でも現象再現しました(たぶん?)。

バージョン: 6.4.2.2 (x64)
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 8; OS:Windows 10.0 Build 18362; UI render: default; VCL: win;
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: CL

素人なりに試行錯誤してみたところ、どうも「ズーム」効果でトラブってるみたいですね…。
これを他の効果(「円」とか)に変更すれば、次の「ズーム」まで順番通りに動いてくれるような気がします。

追跡確認したところ、「ズーム」の他、「ゴム」「ムービークレジット」「ターン」「スパイラルイン」でも似た現象となるようです。
また「ブレーキをかける」は、動作はしてますが、描画位置に不具合がありそうです。

ひとまず以上。Telegramでの速報を焼き直してお送りしましたw。
矢内原さんのレポート通り、次バージョンで修正されるといいですけどね。

---
岩橋 伴典
CALL SIGN: JO3EMC
E-mail: [hidden email]

-----------------------返信元のメール-----------------------
From:     So YANAIHARA <[hidden email]>
To:       "ANEZAKI AKIHIRO(姉崎 章博)" <[hidden email]>
Cc:       "[hidden email]" <[hidden email]>
Subject:  [ja-users] Re: [ja-users] [ja-users] Impressのアニメーションが
          うまく動かない6.3.5, 6.4.2

矢内原です。

Mac でも再現しました。
バージョン: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS:Mac OS X 10.14.6; UI render: default; VCL: osx;
ロケール: ja-JP (ja_JP.UTF-8); UIの言語: ja-JP
Calc: threaded

6.3.5で入ったアニメーション関連の変更を探したら、次のバグの修正がありました。
https://bugs.documentfoundation.org/show_bug.cgi?id=125949

masterブランチで、この修正パッチで slideshow/source/engine/effectrewinder.cxx に追加された
skipSingleMainSequenceEffects() の呼び出し部分をコメントアウトしたら
最後までアニメーションが再生されるようになりました。

> 2020/03/27 9:41、ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>のメール:
>
> 姉崎です。
>
> 野方さん
>
>  追確認、ありがとうございます。
>
> On 2020/03/26 20:28, Jun Nogata wrote:
>> 6.3.4(AppImage版)ではアニメーションが最後まで動きました。
>>
>> Version: 6.3.4.2
>> Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
>>
>> 途中順番が変わったり途中で終わってしまったのは以下のバージョンでした。
>>
>> バージョン: 6.3.5.2
>> Build ID: dd0751754f11728f69b42ee2af66670068624673
>> バージョン: 6.4.2.2
>> Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
>> バージョン: 7.0.0.0.alpha0+
>> Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
>
> 6.3.4.2ではうまく動くのですね。
>
>> 2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:
>>> アニメーションの指定が多すぎるのかなぁ。1スライドに23個
>>
>> 試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。
>>
>> サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
>> アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。
>>
>> アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。
>
> 条件が読めないから、修正はあまり期待できないですね。
>
> --
>
> --
> Unsubscribe instructions: E-mail to [hidden email]
> Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
> List archive: https://listarchives.libreoffice.org/ja/users/
> Privacy Policy: https://www.documentfoundation.org/privacy
>


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

ANEZAKI AKIHIRO(姉崎 章博) ANEZAKI AKIHIRO(姉崎 章博)
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users Impressのアニメーションがうまく動かない6.3.5, 6.4.2

姉崎です。

矢内原さん、岩橋さん

 ありがとうございます。

 次バージョンで修正されることを期待したいです。

--

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

So So
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] [ja-users] [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

In reply to this post by JO3EMC
矢内原です。

> 矢内原さんのレポート通り、次バージョンで修正されるといいですけどね。
いえ、6.3.5で行われた別のバグの修正が原因っぽいということです。

>>> 試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。
>>>
>>> サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
>>> アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。
>>>
>>> アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。
正常な部分は省いたシンプルな再現ファイルをつけてバグ報告しておく方が良いかと思います。
--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy
nogajun nogajun
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] Re: [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

In reply to this post by ANEZAKI AKIHIRO(姉崎 章博)
姉崎さん

野方です。
OSCのSlackを見て気になったので、ちょっと深く検証してみました。

ズームのアニメーションを使うと問題が出るようです。調べた結果はこんな感じでした。

- オブジェクトを2つ並べて、両方にズームのアニメーションを適用すると同じ現象がおきます。
- 1つだけの場合は、オブジェクトは表示されるけれどズームのアニメーションは実行されません。
- ズームのアニメーションを別のアニメーションに置き換えると大丈夫でした。
- テキストにつけたズームのアニメーションは問題ありません。
- オプションからハードウェアアクセラレーションを無効にするとオブジェクトも動きました。

Bigzillaを検索するとこういうバグが見つかりました。これと同じですね。

* 103423 – Linux: drawing object with Zoom animation not displayed in
Impress slideshow:
https://bugs.documentfoundation.org/show_bug.cgi?id=103423

6.4.4も7.0デイリービルドでも同じ症状だったので、全然直っていないことを追記したほうがいいかもですね。

とりあえず回避策としては
アニメーションにこだわりがなければ、ズームの部分を別のアニメーションに置き換えるのはいかがでしょうか。
ズームを使いたいなら、オプションのハードウェアアクセラレーションを無効にするのはいかがでしょうか。


2020年3月27日(金) 9:43 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:

>
> 姉崎です。
>
> 野方さん
>
>  追確認、ありがとうございます。
>
> On 2020/03/26 20:28, Jun Nogata wrote:
> > 6.3.4(AppImage版)ではアニメーションが最後まで動きました。
> >
> > Version: 6.3.4.2
> > Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
> >
> > 途中順番が変わったり途中で終わってしまったのは以下のバージョンでした。
> >
> > バージョン: 6.3.5.2
> > Build ID: dd0751754f11728f69b42ee2af66670068624673
> > バージョン: 6.4.2.2
> > Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
> > バージョン: 7.0.0.0.alpha0+
> > Build ID: 3eb14808495fc930c481ee6842574abf8f8608ab
>
> 6.3.4.2ではうまく動くのですね。
>
> > 2020年3月24日(火) 18:00 ANEZAKI AKIHIRO(姉崎 章博) <[hidden email]>:
> >> アニメーションの指定が多すぎるのかなぁ。1スライドに23個
> >
> > 試しに新規のスライドに23個オブジェクトを作ってアニメーションをつけましたが問題なく動作してました。
> >
> > サンプルでは描画スタイルが増殖してたので削除しても動作は変わらず。
> > アニメーションの正常に動くところを削除して、動作しないアニメーションだけにしても変わらず。
> >
> > アニメーションの動作がおかしくなる条件が、ちょっと読めないですね。
>
> 条件が読めないから、修正はあまり期待できないですね。
>
> --
>
> --
> Unsubscribe instructions: E-mail to [hidden email]
> Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
> List archive: https://listarchives.libreoffice.org/ja/users/
> Privacy Policy: https://www.documentfoundation.org/privacy
>


--
野方 純 (NOGATA,Jun) - mail: [hidden email]
                     - web: http://www.nofuture.tv/diary/

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy
ANEZAKI AKIHIRO(姉崎 章博) ANEZAKI AKIHIRO(姉崎 章博)
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] Impressのアニメーションがうまく動かない6.3.5, 6.4.2

姉崎です。

野方さん

 お世話になります。

On 2020/05/29 13:23, Jun Nogata wrote:
> OSCのSlackを見て気になったので、ちょっと深く検証してみました。

お手間取らせて、すいません。

> ズームのアニメーションを使うと問題が出るようです。調べた結果はこんな感じでした。
>
> - オブジェクトを2つ並べて、両方にズームのアニメーションを適用すると同じ現象がおきます。
> - 1つだけの場合は、オブジェクトは表示されるけれどズームのアニメーションは実行されません。
> - ズームのアニメーションを別のアニメーションに置き換えると大丈夫でした。
> - テキストにつけたズームのアニメーションは問題ありません。
> - オプションからハードウェアアクセラレーションを無効にするとオブジェクトも動きました。
>
> Bigzillaを検索するとこういうバグが見つかりました。これと同じですね。
>
> * 103423 – Linux: drawing object with Zoom animation not displayed in
> Impress slideshow:
> https://bugs.documentfoundation.org/show_bug.cgi?id=103423

6.2.8.2で登録されていますが、私の場合、6.2.8.2まで大丈夫だったし、
GPUごとで出たり出なかったりするみたいですね。
私のはIntel HD Graphics 520みたいです。

> 6.4.4も7.0デイリービルドでも同じ症状だったので、全然直っていないことを追記したほうがいいかもですね。
>
> とりあえず回避策としては
> アニメーションにこだわりがなければ、ズームの部分を別のアニメーションに置き換えるのはいかがでしょうか。
> ズームを使いたいなら、オプションのハードウェアアクセラレーションを無効にするのはいかがでしょうか。

サジェッションありがとうございます。

アニメーションは、会社のブランドステートメントを複数の画像をワイプで表示させるときに、
ハードウェアアクセラレーションを有効にしないとキレイに出ないんです。
 https://www.youtube.com/watch?v=YzlxUUyXqMI&t=34s
の20-27秒のところのタクトの動きが、無効にすると白いギザギザになるんです。

ズームの動きにこだわりは無いのですが、有償講義の150枚を超えるスライドで使っているところを
漏らさず探すのが大変で諦めました。
2017/08/01 11:09の時に教えてもらったcontent.xmlの中身を検索するしか無いのでしょうか?

アニメーションの効果を検索したり、デフォルト(私はほとんどワイプの左から、直前の動作の後が多い)を
指定できたり(統計情報で最頻ベスト3とかでもいいし)するといいのにね、と思う。
無い物ねだりですが。

--


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy