Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

classic Classic list List threaded Threaded
5 messages Options
Papamatti-2 Papamatti-2
Reply | Threaded
Open this post in threaded view
|

Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

Hallo,

ich habe ein Problem mit LO5.2. Wenn ich in einem Dokument ein
Inhaltsverzeichnis erstelle und die einzelnen Punkte/Überschriften als
Inhaltsverzeichniseinträge zufüge und anschließend das Dokument
speichere, LO beende und das Dokument wieder öffne fehlen die Einträge
im Dokument.

Kann das jemand nachvollziehen?

Gruß

Matthias

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Harald Köster-3 Harald Köster-3
Reply | Threaded
Open this post in threaded view
|

Re: Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

Hallo Matthias,

Am 13.09.2016 um 21:25 schrieb Papamatti:
> Hallo,
>
> ich habe ein Problem mit LO5.2. Wenn ich in einem Dokument ein
> Inhaltsverzeichnis erstelle und die einzelnen Punkte/Überschriften als
> Inhaltsverzeichniseinträge zufüge und anschließend das Dokument
> speichere, LO beende und das Dokument wieder öffne fehlen die Einträge
> im Dokument.
>
> Kann das jemand nachvollziehen?

mir ist nicht ganz klar, was Du gemacht hast. Kannst Du noch mal
genauer, am besten schrittweise, erklären, wie Du das Inhaltsverzeichnis
mit den Einträgen erstellt hast?

Grüße
Harald

--
LibreOffice - Die Freiheit nehm' ich mir! - www.libreoffice.de

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Papamatti-2 Papamatti-2
Reply | Threaded
Open this post in threaded view
|

Re: Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

Am 14.09.2016 um 10:32 schrieb Harald Köster:

> Hallo Matthias,
>
> Am 13.09.2016 um 21:25 schrieb Papamatti:
>> Hallo,
>>
>> ich habe ein Problem mit LO5.2. Wenn ich in einem Dokument ein
>> Inhaltsverzeichnis erstelle und die einzelnen Punkte/Überschriften als
>> Inhaltsverzeichniseinträge zufüge und anschließend das Dokument
>> speichere, LO beende und das Dokument wieder öffne fehlen die Einträge
>> im Dokument.
>>
>> Kann das jemand nachvollziehen?
> mir ist nicht ganz klar, was Du gemacht hast. Kannst Du noch mal
> genauer, am besten schrittweise, erklären, wie Du das Inhaltsverzeichnis
> mit den Einträgen erstellt hast?
>
> Grüße
> Harald
>
Hallo Harald,

danke für Deine Antwort:

Also als erstes erstellst Du ein neues Dokument.
Dann schreibst Du den Text und die Überschriften, als Beispiel so:

1. Überschrift 1

text1

2. Überschrift 2

text2

3.Überschrift 3

text3

Danach erstellst du am Anfang des Dokument ein Inhaltsverzeichnis über
EINFÜGEN -> VERZEICHNIS -> VERZEICHNIS -> [OK]

Nun markierst Du die "1.Überschrift 1" und gehst zu EINFÜGEN ->
VERZEICHNIS -> VERZEICHNISEINTRAG, dort Inhaltsverzeichnis auswählen und
dann auf [Einfügen] klicken. Das ganze wiederholst Du nun für die 2. und
3. Überschrift.

Wenn alle Überschriften zum Verzeichnis zugefügt hast gehst Du zum
Navigator im rechten Sidepanel. Unter "Verzeichnis" (Aufklappen!) müsste
nun der Eintrag "Inhaltsverzeichnis1" auftauchen, darauf rechtsklicken
und VERZEICHNIS -> AKTUALISIEREN klicken. Es erscheinen nun alle dem
Inhaltsverzeichnis zugefügten Einträge im Inhaltsverzeichnis des Dokuments.

Das Dokument speichern, LO beenden, Dokument wieder öffnen.

Unter LO5.2 sind nun die Überschriften nicht mehr markiert und
aktualisiert man das Verzeichnis verschwinden die Einträge komplett!
Unter LO5.1 bleibt alles wie es soll.

Hab es jetzt bei zwei Rechnern getestet und bei beiden das gleiche
Verhalten.
Jetzt liegt die Hoffnung bei Dir.


Gruß

Matthias


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Alois Klotz Alois Klotz
Reply | Threaded
Open this post in threaded view
|

Re: Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

Papamatti schrieb am 17.09.2016 um 09:32:

> Also als erstes erstellst Du ein neues Dokument.
> Dann schreibst Du den Text und die Überschriften, als Beispiel so:
>
> 1. Überschrift 1
> text1
> 2. Überschrift 2
> text2
> ...
>
> Danach erstellst du am Anfang des Dokument ein Inhaltsverzeichnis über
> EINFÜGEN -> VERZEICHNIS -> VERZEICHNIS -> [OK]
>
> Nun markierst Du die "1.Überschrift 1" und gehst zu EINFÜGEN ->
> VERZEICHNIS -> VERZEICHNISEINTRAG, dort Inhaltsverzeichnis auswählen
> und dann auf [Einfügen] klicken. Das ganze wiederholst Du nun für die
> 2. und 3. Überschrift.
>
> Wenn alle Überschriften zum Verzeichnis zugefügt hast gehst Du zum
> Navigator im rechten Sidepanel. Unter "Verzeichnis" (Aufklappen!)
> müsste nun der Eintrag "Inhaltsverzeichnis1" auftauchen, darauf
> rechtsklicken und VERZEICHNIS -> AKTUALISIEREN klicken. Es erscheinen
> nun alle dem Inhaltsverzeichnis zugefügten Einträge im
> Inhaltsverzeichnis des Dokuments.
>
> Das Dokument speichern, LO beenden, Dokument wieder öffnen.
>
> Unter LO5.2 sind nun die Überschriften nicht mehr markiert und
> aktualisiert man das Verzeichnis verschwinden die Einträge komplett!
> Unter LO5.1 bleibt alles wie es soll.
Hallo Matthias,
getestet mit Version: 5.2.1.2
Ich kann bestätigen, dass manuell eingefügte Inhaltsverzeichniseinträge
nach dem erneuten Öffnen verschwinden und das ist meiner Meinung nach
ein Bug.

Workaround: ich erstelle die Inhaltsverzeichniseinträge nicht manuell.
Wenn man die vorgegebenen Absatzvorlagen (Überschrift 1, etc.)
verwendet, erspart man sich die manuelle Zuweisung und die Überschriften
erscheinen zuverlässig im Inhaltsverzeichnis.

Hier ist ein Dokument zur Demonstration:
https://dl.dropboxusercontent.com/u/3483911/LO-divers/test-verzeichnis.odt

MfG Alois
--
www.easy4me.info

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert

Harald Köster-3 Harald Köster-3
Reply | Threaded
Open this post in threaded view
|

Re: Inhaltsverzeichnis in LO5.2 - Einträge gehen beim Speichern verloren!

In reply to this post by Papamatti-2
Hallo Matthias,

Am 17.09.2016 um 09:32 schrieb Papamatti:

>
> Also als erstes erstellst Du ein neues Dokument.
> Dann schreibst Du den Text und die Überschriften, als Beispiel so:
>
> 1. Überschrift 1
>
> text1
>
> 2. Überschrift 2
>
> text2
>
> 3.Überschrift 3
>
> text3
>
> Danach erstellst du am Anfang des Dokument ein Inhaltsverzeichnis über
> EINFÜGEN -> VERZEICHNIS -> VERZEICHNIS -> [OK]
>
> Nun markierst Du die "1.Überschrift 1" und gehst zu EINFÜGEN ->
> VERZEICHNIS -> VERZEICHNISEINTRAG, dort Inhaltsverzeichnis auswählen und
> dann auf [Einfügen] klicken. Das ganze wiederholst Du nun für die 2. und
> 3. Überschrift.
>
> Wenn alle Überschriften zum Verzeichnis zugefügt hast gehst Du zum
> Navigator im rechten Sidepanel. Unter "Verzeichnis" (Aufklappen!) müsste
> nun der Eintrag "Inhaltsverzeichnis1" auftauchen, darauf rechtsklicken
> und VERZEICHNIS -> AKTUALISIEREN klicken. Es erscheinen nun alle dem
> Inhaltsverzeichnis zugefügten Einträge im Inhaltsverzeichnis des Dokuments.
>
> Das Dokument speichern, LO beenden, Dokument wieder öffnen.
>
> Unter LO5.2 sind nun die Überschriften nicht mehr markiert und
> aktualisiert man das Verzeichnis verschwinden die Einträge komplett!
> Unter LO5.1 bleibt alles wie es soll.

jetzt hab ich es auch nachvollziehen können. Problem tritt definitiv
beim Speichern auf. Wenn ich ein Dokument mit Version 5.1.5 erstelle und
dies mit 5.2.1 öffne, sind die Verzeichniseinträge nach dem
Aktualisieren noch vorhanden.

In Bugzilla scheint es dazu noch keinen Bug Report zu geben, jedenfalls
habe ich nichts gefunden. Kannst Du einen Bug Report schreiben?

Grüße
Harald K.


--
LibreOffice - Die Freiheit nehm' ich mir! - www.libreoffice.de

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/users/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert