Installation of LO 6.0.0.3 (x64) on Win10Pro

classic Classic list List threaded Threaded
7 messages Options
Philip Jackson Philip Jackson
Reply | Threaded
Open this post in threaded view
|

Installation of LO 6.0.0.3 (x64) on Win10Pro

I'm mostly using LO on linux but I have kept a version [5.4. ish] of LO
on a Windows box for occasional testing of documents. Having read a
recent post which spoke enthusiastically about some LO 6 features, I
thought I would give it go.

I downloaded and installed both these two files from libreoffice.org's
download page :

LibreOffice_6.0.0_Win_x64.msi

LibreOffice_6.0.0_Win_x64_helppack_en-GB.msi

LibreOffice Writer, Calc and Impress applications appear to work
correctly but trying to get the LO Help (F1) to work brings up an error
message -

"The LibreOffice built-in help is not installed on your computer"

I downloaded the help pack a second time and ran the installer. It
recognised the first installation and offered the repair option, which I
accepted. But F1 help still does not work.

When looking in C:\Program Files\LibreOffice, the help directory appears
to be stuffed with lots of files.

Any ideas how to get the applications to recognise the presence of the
help files?

Philip

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3 (x64) on Win10Pro

On 02.02.2018 12:07, Philip Jackson wrote:

> I'm mostly using LO on linux but I have kept a version [5.4. ish] of LO
> on a Windows box for occasional testing of documents. Having read a
> recent post which spoke enthusiastically about some LO 6 features, I
> thought I would give it go.
>
> I downloaded and installed both these two files from libreoffice.org's
> download page :
>
> LibreOffice_6.0.0_Win_x64.msi
>
> LibreOffice_6.0.0_Win_x64_helppack_en-GB.msi
>
> LibreOffice Writer, Calc and Impress applications appear to work
> correctly but trying to get the LO Help (F1) to work brings up an error
> message -
>
> "The LibreOffice built-in help is not installed on your computer"
>
> I downloaded the help pack a second time and ran the installer. It
> recognised the first installation and offered the repair option, which I
> accepted. But F1 help still does not work.
>
> When looking in C:\Program Files\LibreOffice, the help directory appears
> to be stuffed with lots of files.
>
> Any ideas how to get the applications to recognise the presence of the
> help files?
>
> Philip
>
I am experiencing the same issue. The SHA256 checked download of
LibreOffice_6.0.0_Win_x64_helppack_en-GB.msi installs without any
problem, but calling help (F1 or menu) returns the "Not Installed"
message, although Windows installed programs shows the en_GB Help Pack
as being installed.

The problem does not appear when the en_US Help Pack is installed.

Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Philip Jackson Philip Jackson
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3 (x64) on Win10Pro

On 02/02/18 14:22, DaveB wrote:
> The problem does not appear when the en_US Help Pack is installed.

Thanks for that idea, Dave. I just downloaded and installed the en_US
pack and it all works as expected [at least at first glance. time will
tell].  I wondered about removing the en_GB help pack first but I didn't
- thought I'd just try the en_US.

So both are now installed and LO just recogniz(s)es the en_US version.

Maybe the LO help devs are based in the EU and they don't approve of
Brexit ?

Philip

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3 (x64) on Win10Pro

On 02/02/18 17:27, Philip Jackson wrote:

> On 02/02/18 14:22, DaveB wrote:
>> The problem does not appear when the en_US Help Pack is installed.
>
> Thanks for that idea, Dave. I just downloaded and installed the en_US
> pack and it all works as expected [at least at first glance. time will
> tell].  I wondered about removing the en_GB help pack first but I didn't
> - thought I'd just try the en_US.
>
> So both are now installed and LO just recogniz(s)es the en_US version.
>
> Maybe the LO help devs are based in the EU and they don't approve of
> Brexit ?

It works for me on up to date Windows 10. You haven't specified your
environment: that might be a good place to start in isolating your problem.

Peter HB


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
libreoffice-ml.mbourne libreoffice-ml.mbourne
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3

In reply to this post by Philip Jackson
Philip Jackson wrote:

> I'm mostly using LO on linux but I have kept a version [5.4. ish] of LO
> on a Windows box for occasional testing of documents. Having read a
> recent post which spoke enthusiastically about some LO 6 features, I
> thought I would give it go.
>
> I downloaded and installed both these two files from libreoffice.org's
> download page :
>
> LibreOffice_6.0.0_Win_x64.msi
>
> LibreOffice_6.0.0_Win_x64_helppack_en-GB.msi
>
> LibreOffice Writer, Calc and Impress applications appear to work
> correctly but trying to get the LO Help (F1) to work brings up an error
> message -
>
> "The LibreOffice built-in help is not installed on your computer"
>
> I downloaded the help pack a second time and ran the installer. It
> recognised the first installation and offered the repair option, which I
> accepted. But F1 help still does not work.
>
> When looking in C:\Program Files\LibreOffice, the help directory appears
> to be stuffed with lots of files.
>
> Any ideas how to get the applications to recognise the presence of the
> help files?

I'm still on 5.4 so can't check this but, if you haven't already, make
sure the UI language to "English (UK)" at Tools > Options > Language
Settings > Languages > User Interface. I don't know if it's the case
with LibreOffice, but at least one other application I use expects to
find help files in a language matching the UI setting. Even if it wasn't
the case in previous LibreOffice versions, I guess it's possible that
might have changed in 6.0.

--
Mark.


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3 (x64) on Win10Pro

In reply to this post by Philip Jackson
On 02.02.2018 17:27, Philip Jackson wrote:

> On 02/02/18 14:22, DaveB wrote:
>> The problem does not appear when the en_US Help Pack is installed.
> Thanks for that idea, Dave. I just downloaded and installed the en_US
> pack and it all works as expected [at least at first glance. time will
> tell].  I wondered about removing the en_GB help pack first but I didn't
> - thought I'd just try the en_US.
>
> So both are now installed and LO just recogniz(s)es the en_US version.
>
> Maybe the LO help devs are based in the EU and they don't approve of
> Brexit ?
>
> Philip

It doesn't seem to make any difference if you leave the en_GB installed
or not, the en_US edition is recognised and used in both cases.

Not a big issue for me, I've been married to an American for many years,
so I can accommodate their "odd" terminology & spelling ;)

Brexit!!! Who in their right mind could approve of it. This nonsense has
created many problems for me personally, so I sure as **** don't approve.

Peter: I was using Win 7_x64 Ult. and Philip gave the information in the
subject line of his original post. I switched to a fully updated Win
10_x64 box and got the same failure as previously reported.

Mark: You have almost nailed the solution. It's not the interface
language that has to be set, it is setting the global Locale to English
(UK) that allows the en_GB Help to work as expected. Thank you.

Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.



--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Philip Jackson Philip Jackson
Reply | Threaded
Open this post in threaded view
|

Re: Installation of LO 6.0.0.3 (x64) on Win10Pro

On 02/02/18 21:39, DaveB wrote:
> Mark: You have almost nailed the solution. It's not the interface
> language that has to be set, it is setting the global Locale to English
> (UK) that allows the en_GB Help to work as expected. Thank you.

I had assumed, wrongly in part, that as libreoffice.org recognised my OS
and environment and offered me the appropriate help-pack that it would
take this into account when making the installation.

But it fails to set the Tools > Options > Language Settings > Languages
> User interface to the value required.

The Locale setting was correct [UK] as was [mostly] the default document
language.

Mark was correct, in fact. It was sufficient to change the User
interface to UK to agree with the help pack and all worked ok.

I made a series of installs and removals (deleting the User AppData each
time) to confirm this.

I notice that the Office Suite contains English, French and Spanish
spell checking extensions as default. LO may have supposed my
requirement for English and French from my OS and environment but I
don't know where it got the idea to provide Spanish checker extensions
from. On one of my trial installations, it somehow got my default
document language as Spanish-Venezuela and every time I started a new
doc, the Default paragraph language was Spanish-Venezuelan.

Philip

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted