Installing 4.0 alongside 3.5

classic Classic list List threaded Threaded
10 messages Options
Johnny Rosenberg Johnny Rosenberg
Reply | Threaded
Open this post in threaded view
|

Installing 4.0 alongside 3.5

For some reasons I want to try the upcoming version 4.0. On the web
page, they say ”You are not recommended to use LibreOffice pre-release
builds for "mission-critical" purposes”. So obviously I need a stable
version as well, like the 3.5.7.2 that I have installed right now.

So I presume that I can use both versions at the same time, that they
are ”isolated” from each other as long as 4.0 is a pre-release, right?

But before I'm going to install it, I want to know rather than just assume…

So, is it possible? If so, can I just install the debs (operating
system=Ubuntu 12.04) and it will just work? Will I be able to run both
versions at the same time safely?


Johnny Rosenberg

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Paolo Debortoli Paolo Debortoli
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

Il 26/01/2013 20:02, Johnny Rosenberg ha scritto:

> For some reasons I want to try the upcoming version 4.0. On the web
> page, they say ”You are not recommended to use LibreOffice pre-release
> builds for "mission-critical" purposes”. So obviously I need a stable
> version as well, like the 3.5.7.2 that I have installed right now.
>
> So I presume that I can use both versions at the same time, that they
> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>
> But before I'm going to install it, I want to know rather than just assume…
>
> So, is it possible? If so, can I just install the debs (operating
> system=Ubuntu 12.04) and it will just work? Will I be able to run both
> versions at the same time safely?
>
>
> Johnny Rosenberg
>
hi. in theory it is possible, having the software different names (lo36
or lo40). then you bild different launchers to call different packages.
one problem may be given by the configuration files in your home/.config
directory:  inside you should find 2 directories: 3 & 4... installatio
may replace some libraries, but it shouldn't give conflicts or
problems...   you should also be able, for example, to add to submenus
(eg lo3 and lo4) to the menus... try with the packages names.

--
www.libreoffice.org


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Dan Lewis Dan Lewis
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

`
On 01/26/2013 02:52 PM, Paolo Debortoli wrote:

> Il 26/01/2013 20:02, Johnny Rosenberg ha scritto:
>> For some reasons I want to try the upcoming version 4.0. On the web
>> page, they say ”You are not recommended to use LibreOffice pre-release
>> builds for "mission-critical" purposes”. So obviously I need a stable
>> version as well, like the 3.5.7.2 that I have installed right now.
>>
>> So I presume that I can use both versions at the same time, that they
>> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>>
>> But before I'm going to install it, I want to know rather than just
>> assume…
>>
>> So, is it possible? If so, can I just install the debs (operating
>> system=Ubuntu 12.04) and it will just work? Will I be able to run both
>> versions at the same time safely?
>>
>>
>> Johnny Rosenberg
>>
> hi. in theory it is possible, having the software different names
> (lo36 or lo40). then you bild different launchers to call different
> packages. one problem may be given by the configuration files in your
> home/.config directory:  inside you should find 2 directories: 3 &
> 4... installatio may replace some libraries, but it shouldn't give
> conflicts or problems...   you should also be able, for example, to
> add to submenus (eg lo3 and lo4) to the menus... try with the packages
> names.
>
      In theory it is possible. In reality, you can run LO 3.5.7.2s and
4.0.0.2 at the same time. What you can not do is install the
desktop-integration file for both of these. In Ubuntu 12.04, you have to
Edit Menus. (I use gnome classic rather than Unity.)
      As a test, I ran LO 3.5.7.2 and 4.0.0.2 at the same time with no
problems. I also ran AOO 3.4.1. That is three different soffice.bin
files running at once. The key as mentioned is the configuration
folders. For anyone having installed 3.X.X and 4.0.0.2, the LibreOffice
folder in the .config folder is really two configuration folders: 3 and
4. The former is used by LO 3.5.x or 3.6.x, so these can not be run at
the same time.
      I had the Ubuntu version of LO 3.5.4 on my laptop. It also used  
.config/LibreOffice/3/. This prevented me from running the Ubuntu
version and LO 3.6.X from the LO website at the same time.

--Dan

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
upscope upscope
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

In reply to this post by Johnny Rosenberg
On Saturday, January 26, 2013 08:02:34 PM Johnny Rosenberg wrote:

> For some reasons I want to try the upcoming version 4.0. On the web
> page, they say ”You are not recommended to use LibreOffice pre-release
> builds for "mission-critical" purposes”. So obviously I need a stable
> version as well, like the 3.5.7.2 that I have installed right now.
>
> So I presume that I can use both versions at the same time, that they
> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>
> But before I'm going to install it, I want to know rather than just assume…
>
> So, is it possible? If so, can I just install the debs (operating
> system=Ubuntu 12.04) and it will just work? Will I be able to run both
> versions at the same time safely?
>
>
> Johnny Rosenberg
In the Linux enviroment I have 3.6.3 (openSUSE verssion), 3.6.4 and 4.0-dev
(from libreoffice download page0 all installed and running together at times.
install generated the icons and i Just select the one for the version I want.
Will as long at each version has a different name.

Not sure about the windows versions, I'll leave that to one of the Windows
users.
Russ
--
openSUSE 12.2(Linux 3.4.11-2.16-desktop x86_64)|
KDE 4.9.5 "release 3"|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-304.60)  


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Russ
m.a.riosv m.a.riosv
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

This post has NOT been accepted by the mailing list yet.
There is a page in The Document Foundation about it:
https://wiki.documentfoundation.org/Installing_in_parallel

also for windows there is an extension, that works fantastic:
http://extensions.libreoffice.org/extension-center/libreoffice-server-installation-gui

Miguel Ángel
Kolbjørn Stuestøl Kolbjørn Stuestøl
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

In reply to this post by upscope
Den 26.01.2013 22:59, skreiv upscope:

> On Saturday, January 26, 2013 08:02:34 PM Johnny Rosenberg wrote:
>> For some reasons I want to try the upcoming version 4.0. On the web
>> page, they say ”You are not recommended to use LibreOffice pre-release
>> builds for "mission-critical" purposes”. So obviously I need a stable
>> version as well, like the 3.5.7.2 that I have installed right now.
>>
>> So I presume that I can use both versions at the same time, that they
>> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>>
>> But before I'm going to install it, I want to know rather than just assume…
>>
>> So, is it possible? If so, can I just install the debs (operating
>> system=Ubuntu 12.04) and it will just work? Will I be able to run both
>> versions at the same time safely?
>>
>>
>> Johnny Rosenberg
> In the Linux enviroment I have 3.6.3 (openSUSE verssion), 3.6.4 and 4.0-dev
> (from libreoffice download page0 all installed and running together at times.
> install generated the icons and i Just select the one for the version I want.
> Will as long at each version has a different name.
>
> Not sure about the windows versions, I'll leave that to one of the Windows
> users.
> Russ
No problem in Windows.
As a translator I am running version 3.6.4.3 and version 4.0.0.0.beta2
(together with MS Excel) at the same time without any conflicts.
Kolbjoern


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

Hi :)
It should be fine in Ubuntu 12.04.  I'm not sure why people are talking about Windows but this guide covers both anyway
https://wiki.documentfoundation.org/Installing_in_parallel

(to answer my own questions it's probably because there's been a lot of traffic on-list so people have to skim through quickly and most questions tend to be about Windows)
Good luck and regards from
Tom :) 





>________________________________
> From: Kolbjørn Stuestøl <[hidden email]>
>To: [hidden email]
>Sent: Sunday, 27 January 2013, 11:28
>Subject: Re: [libreoffice-users] Installing 4.0 alongside 3.5
>
>Den 26.01.2013 22:59, skreiv upscope:
>> On Saturday, January 26, 2013 08:02:34 PM Johnny Rosenberg wrote:
>>> For some reasons I want to try the upcoming version 4.0. On the web
>>> page, they say ”You are not recommended to use LibreOffice pre-release
>>> builds for "mission-critical" purposes”. So obviously I need a stable
>>> version as well, like the 3.5.7.2 that I have installed right now.
>>>
>>> So I presume that I can use both versions at the same time, that they
>>> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>>>
>>> But before I'm going to install it, I want to know rather than just assume…
>>>
>>> So, is it possible? If so, can I just install the debs (operating
>>> system=Ubuntu 12.04) and it will just work? Will I be able to run both
>>> versions at the same time safely?
>>>
>>>
>>> Johnny Rosenberg
>> In the Linux enviroment I have 3.6.3 (openSUSE verssion), 3.6.4 and 4.0-dev
>> (from libreoffice download page0 all installed and running together at times.
>> install generated the icons and i Just select the one for the version I want.
>> Will as long at each version has a different name.
>>
>> Not sure about the windows versions, I'll leave that to one of the Windows
>> users.
>> Russ
>No problem in Windows.
>As a translator I am running version 3.6.4.3 and version 4.0.0.0.beta2
>(together with MS Excel) at the same time without any conflicts.
>Kolbjoern
>
>
>
--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Johnny Rosenberg Johnny Rosenberg
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

2013/1/27 Tom Davies <[hidden email]>:
> Hi :)
> It should be fine in Ubuntu 12.04.  I'm not sure why people are talking about Windows

That felt strange to me too, since I mentioned my operating system in
my original post. Even stranger is that I received that message at
all, since I have a filter that is supposed move all messages that
contains the word ”Windows” (or any of some other words) from my inbox
so I never have to read them, but obviously this does not work, which
doesn't have anything to do with LibreOffice anyway, so this is way
off topic…

> but this guide covers both anyway
> https://wiki.documentfoundation.org/Installing_in_parallel

Thanks. I'll take a look at it later.


Johnny Rosenberg

>
> (to answer my own questions it's probably because there's been a lot of traffic on-list so people have to skim through quickly and most questions tend to be about Windows)
> Good luck and regards from
> Tom :)
>
>
>
>
>
>>________________________________
>> From: Kolbjørn Stuestøl <[hidden email]>
>>To: [hidden email]
>>Sent: Sunday, 27 January 2013, 11:28
>>Subject: Re: [libreoffice-users] Installing 4.0 alongside 3.5
>>
>>Den 26.01.2013 22:59, skreiv upscope:
>>> On Saturday, January 26, 2013 08:02:34 PM Johnny Rosenberg wrote:
>>>> For some reasons I want to try the upcoming version 4.0. On the web
>>>> page, they say ”You are not recommended to use LibreOffice pre-release
>>>> builds for "mission-critical" purposes”. So obviously I need a stable
>>>> version as well, like the 3.5.7.2 that I have installed right now.
>>>>
>>>> So I presume that I can use both versions at the same time, that they
>>>> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>>>>
>>>> But before I'm going to install it, I want to know rather than just assume…
>>>>
>>>> So, is it possible? If so, can I just install the debs (operating
>>>> system=Ubuntu 12.04) and it will just work? Will I be able to run both
>>>> versions at the same time safely?
>>>>
>>>>
>>>> Johnny Rosenberg
>>> In the Linux enviroment I have 3.6.3 (openSUSE verssion), 3.6.4 and 4.0-dev
>>> (from libreoffice download page0 all installed and running together at times.
>>> install generated the icons and i Just select the one for the version I want.
>>> Will as long at each version has a different name.
>>>
>>> Not sure about the windows versions, I'll leave that to one of the Windows
>>> users.
>>> Russ
>>No problem in Windows.
>>As a translator I am running version 3.6.4.3 and version 4.0.0.0.beta2
>>(together with MS Excel) at the same time without any conflicts.
>>Kolbjoern
>>
>>
>>
> --
> For unsubscribe instructions e-mail to: [hidden email]
> Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be deleted

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Kolbjørn Stuestøl Kolbjørn Stuestøl
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

Den 27.01.2013 15:33, skreiv Johnny Rosenberg:
> 2013/1/27 Tom Davies <[hidden email]>:
>> Hi :)
>> It should be fine in Ubuntu 12.04.  I'm not sure why people are talking about Windows
> That felt strange to me too, since I mentioned my operating system in
> my original post.
I thought this forum was for *all* users.
I was answering the question because I thought there could be some
peoples running another OS wondering whether running different versions
of LibreOffice at the same time is possible.

Kolbjoern

> Even stranger is that I received that message at
> all, since I have a filter that is supposed move all messages that
> contains the word ”Windows” (or any of some other words) from my inbox
> so I never have to read them, but obviously this does not work, which
> doesn't have anything to do with LibreOffice anyway, so this is way
> off topic…
>
>> but this guide covers both anyway
>> https://wiki.documentfoundation.org/Installing_in_parallel
> Thanks. I'll take a look at it later.
>
>
> Johnny Rosenberg
>
>> (to answer my own questions it's probably because there's been a lot of traffic on-list so people have to skim through quickly and most questions tend to be about Windows)
>> Good luck and regards from
>> Tom :)
>>
>>
>>
>>
>>
>>> ________________________________
>>> From: Kolbjørn Stuestøl <[hidden email]>
>>> To: [hidden email]
>>> Sent: Sunday, 27 January 2013, 11:28
>>> Subject: Re: [libreoffice-users] Installing 4.0 alongside 3.5
>>>
>>> Den 26.01.2013 22:59, skreiv upscope:
>>>> On Saturday, January 26, 2013 08:02:34 PM Johnny Rosenberg wrote:
>>>>> For some reasons I want to try the upcoming version 4.0. On the web
>>>>> page, they say ”You are not recommended to use LibreOffice pre-release
>>>>> builds for "mission-critical" purposes”. So obviously I need a stable
>>>>> version as well, like the 3.5.7.2 that I have installed right now.
>>>>>
>>>>> So I presume that I can use both versions at the same time, that they
>>>>> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>>>>>
>>>>> But before I'm going to install it, I want to know rather than just assume…
>>>>>
>>>>> So, is it possible? If so, can I just install the debs (operating
>>>>> system=Ubuntu 12.04) and it will just work? Will I be able to run both
>>>>> versions at the same time safely?
>>>>>
>>>>>
>>>>> Johnny Rosenberg
>>>> In the Linux enviroment I have 3.6.3 (openSUSE verssion), 3.6.4 and 4.0-dev
>>>> (from libreoffice download page0 all installed and running together at times.
>>>> install generated the icons and i Just select the one for the version I want.
>>>> Will as long at each version has a different name.
>>>>
>>>> Not sure about the windows versions, I'll leave that to one of the Windows
>>>> users.
>>>> Russ
>>> No problem in Windows.
>>> As a translator I am running version 3.6.4.3 and version 4.0.0.0.beta2
>>> (together with MS Excel) at the same time without any conflicts.
>>> Kolbjoern
>>>
>>>
>>>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
NoOp NoOp
Reply | Threaded
Open this post in threaded view
|

Re: Installing 4.0 alongside 3.5

In reply to this post by Johnny Rosenberg
On 01/26/2013 11:02 AM, Johnny Rosenberg wrote:

> For some reasons I want to try the upcoming version 4.0. On the web
> page, they say ”You are not recommended to use LibreOffice pre-release
> builds for "mission-critical" purposes”. So obviously I need a stable
> version as well, like the 3.5.7.2 that I have installed right now.
>
> So I presume that I can use both versions at the same time, that they
> are ”isolated” from each other as long as 4.0 is a pre-release, right?
>
> But before I'm going to install it, I want to know rather than just assume…
>
> So, is it possible? If so, can I just install the debs (operating
> system=Ubuntu 12.04) and it will just work? Will I be able to run both
> versions at the same time safely?

Luckily, LODev4 (linux only [1]) installs as a separate install:

$ locate versionrc
/opt/libreoffice/ure/bin/versionrc
/opt/libreoffice3.4/basis3.4/program/versionrc
/opt/libreoffice3.4/program/versionrc
/opt/libreoffice3.4/ure/bin/versionrc
/opt/libreoffice3.5/program/versionrc
/opt/libreoffice3.6/program/versionrc
/opt/libreoffice4.0/program/versionrc
/opt/lodev4.0/program/versionrc
/opt/openoffice.org/basis3.4/program/versionrc
/opt/openoffice.org/ure/bin/versionrc
/opt/openoffice.org3/program/versionrc
/usr/lib/libreoffice/program/versionrc

Install & then create a new generic launcher to
/opt/lodev4.0/program/soffice and you'll be fine. You can run at the
same time as LO 3.x.


[1] NHote to Windows users that are reading this, Please *read*:
http://www.libreoffice.org/download/pre-releases/
NOTE: This build is in a release configuration and will replace your
existing LibreOffice install on Windows!


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted