LO 6.0.7.3: Unerwünschtes Verhalten von "Autoformat" bei Writer-Tabellen

classic Classic list List threaded Threaded
3 messages Options
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

LO 6.0.7.3: Unerwünschtes Verhalten von "Autoformat" bei Writer-Tabellen

Hallo zusammen,

bei der Nutzung von Autoformat für Writer-Tabellen habe ich zwischen
der jetzt und der vorher von mir verwendeten Version 4.2.8.2 eine
Veränderung festgestellt, mit der das Handling umständlicher ist.
Nachgestellt werden kann es einfach:

- In einem neuen Writer-Dokument eine Tabelle mit 3 Spalten und 11
  Zeilen (jedenfalls eine ungerade Zahl) einfügen;
- Funktion "Autoformat": Standardvorlage "Gelb" auswählen;
- letzte Zeile: komplett markieren und löschen.

Bei Schritt 3 wird das Format (Hintergrund) der bisherigen letzten
Zeile auf die neue letzte übertragen - obwohl "Autoformat" eigentlich
erledigt war und die Funktion nicht mehr aktiviert wird.

Bei LO 4.x blieb die Hintergrundfarbe der neuen letzten Zeile erhalten,
und die der alten wurde nicht mehr übertragen.

Ich verstehe nicht, was bezüglich der Entwicklung bei "Autoformat"
vorgeht. Auch LO 4.x verhielt sich schon Vorgängerversionen gegenüber
anders: Vorher wurde letzten Zeilen nach Nutzung von Autoformat die
Farbe zugewiesen, die jeweils chronologisch "dran" war - mit LO 4.x
nicht mehr, sondern diejenige, die in "Autoformat" für die letzte Zeile
definiert wurde. Die Folge war lediglich, dass ich meinen Arbeitsablauf
ändern musste: Löschung überschüssiger Zeilen nicht vor, sondern nach
"Autoformat". Jetzt allerdings nützt auch das nichts mehr: Selbst dann
noch zwingt Autoformat der letzten Zeile die Formatierung auf. Ziemlich
ärgerlich, das Ganze, denn es behindert den Arbeitsfluss.

Immerhin habe ich einen Workaround gefunden, mit dem sich die Sache
einigermaßen einfach lösen lässt: Letzte Zeile markieren und nochmal
"Autoformat" drüberbügeln. Das allerdings dürfte nur bei meinen selbst
erstellten, einfachen (Autoformat-)Vorlagen funktionieren. Sie wurden
übrigens nicht einmal mit Summenzeilen angefertigt: die bekommen sie
zwangsweise und nun noch nachhaltiger von "Autoformat". Jedenfalls
werden bei meinen Vorlagen ganzen Zeilen abwechselnd 2 Farben
zugewiesen. Bei den vorhandenen Standardvorlagen sind die Zuweisungen
komplexer und meist mehr Farben im Spiel.

Zur Illustration der nun verursachten Umstände 5 Screenshots
(Standardvorlage "Gelb"):

Eine autoformatierte Tabelle im Grundzustand:
http://sambalada.de/Autoformat_A 

eine autoformatierte Tabelle, bei der die 3 letzten, leeren Zeilen
gelöscht sind: http://sambalada.de/Autoformat_B

Markierung der drittletzten Zeile und Klick auf "Hintergrundfarbe", um
festzustellen, welche ich benötige: http://sambalada.de/Autoformat_C

Markierung der letzten Zeile, Klick auf "Hintergrundfarbe" und Auswahl
der vorher identifizierten: http://sambalada.de/Autoformat_D

fertiggestellte Tabelle: http://sambalada.de/Autoformat_E

Weiß jemand Näheres über die Gründe, warum "Autoformat" von
LO-Generation zu LO-Generation wie beschrieben entwickelt wird - ob es
also so gewollt oder doch ein Bug war/ist?

Viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Harald Köster-3 Harald Köster-3
Reply | Threaded
Open this post in threaded view
|

Re: [de-users] LO 6.0.7.3: Unerwünschtes Verhalten von "Autoformat" bei Writer-Tabellen

Hallo Rainer,

Am 18.08.2019 um 11:44 schrieb Rainer:

> Hallo zusammen,
>
> bei der Nutzung von Autoformat für Writer-Tabellen habe ich zwischen
> der jetzt und der vorher von mir verwendeten Version 4.2.8.2 eine
> Veränderung festgestellt, mit der das Handling umständlicher ist.
> Nachgestellt werden kann es einfach:
>
> - In einem neuen Writer-Dokument eine Tabelle mit 3 Spalten und 11
>   Zeilen (jedenfalls eine ungerade Zahl) einfügen;
> - Funktion "Autoformat": Standardvorlage "Gelb" auswählen;
> - letzte Zeile: komplett markieren und löschen.
>
> Bei Schritt 3 wird das Format (Hintergrund) der bisherigen letzten
> Zeile auf die neue letzte übertragen - obwohl "Autoformat" eigentlich
> erledigt war und die Funktion nicht mehr aktiviert wird.
>
> Bei LO 4.x blieb die Hintergrundfarbe der neuen letzten Zeile erhalten,
> und die der alten wurde nicht mehr übertragen.

ich habe das von Dir beobachtete Verhalten mit Version 6.3.0 unter Win10
nachvollziehen können. Ich hatte zunächst noch vermutet, dass nicht die
letzte Zeile gelöscht wird, sondern die vorletzte Zeile. In dem man die
Zellen mit Inhalten füllte, erkennt man aber sofort, dass dies nicht der
Fall ist. So weit ich das überprüft habe, tritt die Änderung erstmals in
der Version 5.1.0 auf.

Ich halte dies für einen Bug. Man kann aber sicherlich auch
argumentieren, dass die Tabellenvorlage grundsätzlich vorsieht, dass die
letzte Zeile immer eine andere Formatierung (bei mir Farbe und Schrift
fett) haben soll. Würdest Du einen Bug Report schreiben?

Grüße
Harald K.

--
LibreOffice - Die Freiheit nehm' ich mir! - www.libreoffice.de

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Rainer Rainer
Reply | Threaded
Open this post in threaded view
|

Re: [de-users] LO 6.0.7.3: Unerwünschtes Verhalten von "Autoformat" bei Writer-Tabellen

Hallo Harald,

Am Mon, 19 Aug 2019 21:00:55 +0200
schrieb Harald Köster <[hidden email]>:

> >
> > bei der Nutzung von Autoformat für Writer-Tabellen habe ich zwischen
> > der jetzt und der vorher von mir verwendeten Version 4.2.8.2 eine
> > Veränderung festgestellt, mit der das Handling umständlicher ist.
> > Nachgestellt werden kann es einfach:
> >
> > - In einem neuen Writer-Dokument eine Tabelle mit 3 Spalten und 11
> >   Zeilen (jedenfalls eine ungerade Zahl) einfügen;
> > - Funktion "Autoformat": Standardvorlage "Gelb" auswählen;
> > - letzte Zeile: komplett markieren und löschen.
> >
> > Bei Schritt 3 wird das Format (Hintergrund) der bisherigen letzten
> > Zeile auf die neue letzte übertragen - obwohl "Autoformat"
> > eigentlich erledigt war und die Funktion nicht mehr aktiviert wird.
> >
> > Bei LO 4.x blieb die Hintergrundfarbe der neuen letzten Zeile
> > erhalten, und die der alten wurde nicht mehr übertragen.  
>
> ich habe das von Dir beobachtete Verhalten mit Version 6.3.0 unter
> Win10 nachvollziehen können. Ich hatte zunächst noch vermutet, dass
> nicht die letzte Zeile gelöscht wird, sondern die vorletzte Zeile. In
> dem man die Zellen mit Inhalten füllte, erkennt man aber sofort, dass
> dies nicht der Fall ist. So weit ich das überprüft habe, tritt die
> Änderung erstmals in der Version 5.1.0 auf.
>
> Ich halte dies für einen Bug.

Da bin ich mir immer noch nicht sicher.

> Man kann aber sicherlich auch argumentieren, dass die Tabellenvorlage
> grundsätzlich vorsieht, dass die letzte Zeile immer eine andere
> Formatierung (bei mir Farbe und Schrift fett) haben soll.

Genau das wäre möglich. Leider weiß ich nicht, nach welchem Konzept
"Autoformat" gestrickt wurde (und wird) und kann deshalb nur
interpretieren, was ich sehe und erlebe. Offenbar wird der letzten
Zeile immer die Summenfunktion aufgezwungen - anders, als ich es bisher
kenne - jetzt sogar noch, _nachdem_ eine Tabelle autoformatiert wurde.
Wäre ja noch akzeptabel, wenn es so bei den vorhandenen
Standardvorlagen passiert.

Wenn aber sogar selbst erstellte Vorlagen so umformatiert werden, geht
es IMO zu weit: Writer-Tabellen werden doch für alles Mögliche genutzt,
wo es nicht um Zahlen und Summen geht. Wenn ich also Tabellem mit ganz
anderem Charakter erstelle: Wieso müssen sie von Autoformat dann
zurecht-/umgebogen werden? Hat mich schon gestört, als ich vor ein paar
Jahren mit LO 4.x begonnen habe, ließ sich durch eine Änderung im
Arbeitsablauf aber verhältnismäßig leicht lösen. Jetzt ist es wieder
eine Stufe schwieriger geworden. Leider habe ich den Eindruck, dass
diese Arbeitsweise von "Autoformat" durchaus beabsichtigt ist.

> Würdest Du einen Bug Report schreiben?
>
Wenn es ein Bug wäre, sollte er gemeldet werden, aber mit meinen
Englischkenntnissen bekomme ich es nicht angemessen hin. Nur: Ist es
wirklich ein Bug?

Viele Grüße

Rainer

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy