LO Scolling problems under Windows.

classic Classic list List threaded Threaded
7 messages Options
DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

LO Scolling problems under Windows.


I am encountering an increasing number of scroll rendering issues, with
ODF documents (.odt) opened in LO 5.3.4 and 5.4.0.2 under Windows 7, 8.1
& 10 The issue is that some (not all) documents take several seconds to
scroll single lines and up to a minute to scroll a few pages.

The issue does not manifest itself in LO 5.3.4 under Linux, AOO 4.3.1 or
LO 3.3 under Windows.

Is anyone else experiencing a similar issue, or is there a known
rendering problem in recent versions of LO?

Regards
Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Pedro Pedro
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

Dave-3 wrote
Is anyone else experiencing a similar issue, or is there a known
rendering problem in recent versions of LO?
LibreOffice has switched (don't know exactly which version) to OpenGL rendering which is on by default in recent versions.

Go to Tools > Options and select on the left listing LibreOffice, View and then uncheck "Use OpenGL for all rendering"

If this doesn't help, can you report a bug and append to it  one of the documents that causes problems?
Dave Barton-3 Dave Barton-3
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

On 23.07.2017 11:23, Pedro wrote:

> Dave-3 wrote
>> Is anyone else experiencing a similar issue, or is there a known
>> rendering problem in recent versions of LO?
>
> LibreOffice has switched (don't know exactly which version) to OpenGL
> rendering which is on by default in recent versions.
>
> Go to Tools > Options and select on the left listing LibreOffice, View and
> then uncheck "Use OpenGL for all rendering"
>
> If this doesn't help, can you report a bug and append to it  one of the
> documents that causes problems?

Hi Pedro,

Yes, I was aware of this change and I always disable OpenGL rendering.

The issue is the same if the option is checked or not.

Regards
Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

In reply to this post by DaveB
On 23.07.2017 11:07, Dave wrote:

> I am encountering an increasing number of scroll rendering issues, with
> ODF documents (.odt) opened in LO 5.3.4 and 5.4.0.2 under Windows 7, 8.1
> & 10 The issue is that some (not all) documents take several seconds to
> scroll single lines and up to a minute to scroll a few pages.
>
> The issue does not manifest itself in LO 5.3.4 under Linux, AOO 4.3.1 or
> LO 3.3 under Windows.
>
> Is anyone else experiencing a similar issue, or is there a known
> rendering problem in recent versions of LO?
>
> Regards
> Dave

For a little added clarification, the documents in question contain very
few graphics (in most cases none) and the scroll delay issue occurs in
parts of the document containing nothing other than straight forward
formatted text (eg. no images, no frames, no columns, no page breaks, no
TOC, or other content where similar issues have been previously reported
in Bugzilla.)

Regards
Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.


--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
David Lynch David Lynch
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

In reply to this post by DaveB
On 23/07/2017 10:07, Dave wrote:

> I am encountering an increasing number of scroll rendering issues, with
> ODF documents (.odt) opened in LO 5.3.4 and 5.4.0.2 under Windows 7, 8.1
> & 10 The issue is that some (not all) documents take several seconds to
> scroll single lines and up to a minute to scroll a few pages.
>
> The issue does not manifest itself in LO 5.3.4 under Linux, AOO 4.3.1 or
> LO 3.3 under Windows.
>
> Is anyone else experiencing a similar issue, or is there a known
> rendering problem in recent versions of LO?
>
> Regards
> Dave
>
I have reported this

<https://bugs.documentfoundation.org/show_bug.cgi?id=107770>

Please add clarification, comment or support.

David Lynch



--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

On 23.07.2017 17:37, David Lynch wrote:

> On 23/07/2017 10:07, Dave wrote:
>> I am encountering an increasing number of scroll rendering issues, with
>> ODF documents (.odt) opened in LO 5.3.4 and 5.4.0.2 under Windows 7, 8.1
>> & 10 The issue is that some (not all) documents take several seconds to
>> scroll single lines and up to a minute to scroll a few pages.
>>
>> The issue does not manifest itself in LO 5.3.4 under Linux, AOO 4.3.1 or
>> LO 3.3 under Windows.
>>
>> Is anyone else experiencing a similar issue, or is there a known
>> rendering problem in recent versions of LO?
>>
>> Regards
>> Dave
>>
> I have reported this
>
> <https://bugs.documentfoundation.org/show_bug.cgi?id=107770>
>
> Please add clarification, comment or support.
>
> David Lynch

Thanks David,

Calc is not the module I am experiencing this issue with. Only Writer
and only some (.odt) files opened in recent versions of LO under Windows.
I can't exactly pinpoint in which version of LO this became an issue for
me, but I don't recall seeing this slow/jerky scrolling in 5.1.x
releases. I grab a couple of earlier releases and try to track this down
to a more specific version.

Regards
Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
DaveB DaveB
Reply | Threaded
Open this post in threaded view
|

Re: LO Scolling problems under Windows.

In reply to this post by DaveB

My replies are given in-line with your original message.

-------- Original Message  --------
From: zahra a <[hidden email]>
To: Dave <[hidden email]>
Date: Sun, 23 Jul 2017 16:35:21 +0430

> hello.
> i have version 5.3.4.1 and for me libreoffice is faster than previous
> versions before 5.3!

Subjectively, 5.3.x & 5.4.x do seem to be slightly more responsive, more
so under Linux.

> openGl is activated for users since version 4.4 of libreoffice and
> switched to version 2.1 since version 5.1 of libreoffice which support
> more modern systems and newer graphical cards.

Yes, I am well aware of those changes, but as mentioned previously
OpenGL does not appear to be the culprit in this instance.

> hope that help and God bless you.

No, but thank you.

Regards
Dave

>
> On 7/23/17, Dave <[hidden email]> wrote:
>> On 23.07.2017 11:07, Dave wrote:
>>> I am encountering an increasing number of scroll rendering issues, with
>>> ODF documents (.odt) opened in LO 5.3.4 and 5.4.0.2 under Windows 7, 8.1
>>> & 10 The issue is that some (not all) documents take several seconds to
>>> scroll single lines and up to a minute to scroll a few pages.
>>>
>>> The issue does not manifest itself in LO 5.3.4 under Linux, AOO 4.3.1 or
>>> LO 3.3 under Windows.
>>>
>>> Is anyone else experiencing a similar issue, or is there a known
>>> rendering problem in recent versions of LO?
>>>
>>> Regards
>>> Dave
>>
>> For a little added clarification, the documents in question contain very
>> few graphics (in most cases none) and the scroll delay issue occurs in
>> parts of the document containing nothing other than straight forward
>> formatted text (eg. no images, no frames, no columns, no page breaks, no
>> TOC, or other content where similar issues have been previously reported
>> in Bugzilla.)
>>
>> Regards
>> Dave

--
Please address any reply to the mailing list only. Any messages sent to
this noreply@ address are automatically deleted from the server and will
never be read.

--
To unsubscribe e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted