LibreOffice 3.4.0

classic Classic list List threaded Threaded
6 messages Options
tronkel tronkel
Reply | Threaded
Open this post in threaded view
|

LibreOffice 3.4.0

Has anyone had a printing problem with 3.4.0?
3.2.2 was fine in this regard

3.4.0 shows a correctly installed CUPS printer but refuses to actually print the job.

What has changed between the two versions?
krackedpress krackedpress
Reply | Threaded
Open this post in threaded view
|

Re: LibreOffice 3.4.0

On 06/05/2011 11:06 AM, tronkel wrote:
> Has anyone had a printing problem with 3.4.0?
> 3.2.2 was fine in this regard
>
> 3.4.0 shows a correctly installed CUPS printer but refuses to actually print
> the job.
>
> What has changed between the two versions?
>
What Linux distro are you using?  I have to switched to 3.4.0 yet with
my Ubuntu 10.04LTS 64-bit system.  I am waiting for 3.4.1 [maybe] due
out at the end of the month.

Are you having any problems with any other printer?  I know that my
Epson uses CUPS, but I do not know if my two HP printers do, since they
had to use a "make" command to "compile" something before use.  The
Epson did not do that, just needed to install something that, I was
read, connected itself to CUPS to work properly.

Did you try to reinstall CUPS?
Do you have more than one CUPS printer to try?  How about the CUPS PDF
printer, does it work?



--
Unsubscribe instructions: E-mail to [hidden email]
In case of problems unsubscribing, write to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/www/users/
All messages sent to this list will be publicly archived and cannot be deleted

tronkel tronkel
Reply | Threaded
Open this post in threaded view
|

Re: Re: LibreOffice 3.4.0

Hello Krackedpress

The 2 systems on which I have tried LO 3.4.0 are Slackware 13.37 and Puppy Linux Wary 5.1.2. The printer itself is a Brother DCP7030 whose linux driver is supplied via the Brother website. Neither of these systems have a printing problem with LO 3.2.2. LO has never before given trouble when printing via any version of CUPS

Something has been changed in the latest LO 3.4.2 to stop printing working. I suspect it may be a permissions problem with USB.

Regards

tronkel

On , "krackedpress [via Document Foundation Mail Archive]" <[hidden email]> wrote:

>
>
> On 06/05/2011 11:06 AM, tronkel wrote:
>
> > Has anyone had a printing problem with 3.4.0?
>
> > 3.2.2 was fine in this regard
>
> >
>
> > 3.4.0 shows a correctly installed CUPS printer but refuses to actually print
>
> > the job.
>
> >
>
> > What has changed between the two versions?
>
> >
>
> What Linux distro are you using?  I have to switched to 3.4.0 yet with
>
> my Ubuntu 10.04LTS 64-bit system.  I am waiting for 3.4.1 [maybe] due
>
> out at the end of the month.
>
>
> Are you having any problems with any other printer?  I know that my
>
> Epson uses CUPS, but I do not know if my two HP printers do, since they
>
> had to use a "make" command to "compile" something before use.  The
>
> Epson did not do that, just needed to install something that, I was
>
> read, connected itself to CUPS to work properly.
>
>
> Did you try to reinstall CUPS?
>
> Do you have more than one CUPS printer to try?  How about the CUPS PDF
>
> printer, does it work?
>
>
>
>
> --
>
> Unsubscribe instructions: E-mail to [hidden email]
>
> In case of problems unsubscribing, write to [hidden email]
>
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/www/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>
>
>
>
>
>
>
>
>
>
> If you reply to this email, your message will be added to the discussion below:
>
> http://nabble.documentfoundation.org/LibreOffice-3-4-0-tp3026425p3027217.html
>
>
>
>
> To unsubscribe from LibreOffice 3.4.0, click here.
>
>
Nuno J. Silva Nuno J. Silva
Reply | Threaded
Open this post in threaded view
|

Re: Re: LibreOffice 3.4.0

tronkel <[hidden email]> writes:
>> On 06/05/2011 11:06 AM, tronkel wrote:
>
>> > 3.4.0 shows a correctly installed CUPS printer but refuses to actually   print
>> > the job.
[...]
>
> The 2 systems on which I have tried LO 3.4.0 are Slackware 13.37 and Puppy  
> Linux Wary 5.1.2. The printer itself is a Brother DCP7030 whose linux  
> driver is supplied via the Brother website. Neither of these systems have a  
> printing problem with LO 3.2.2. LO has never before given trouble when  
> printing via any version of CUPS
>
> Something has been changed in the latest LO 3.4.2 to stop printing working.  
> I suspect it may be a permissions problem with USB.


If you're using CUPS, USB permission issues should happen on the CUPS
side, or probably udev. (At least for the [Brother] scanner part you
need to add some udev rules, and these might get overwritten by some
system update.)

But as your problem is only with a specific version of a specific
program (LibreOffice), I seriously doubt USB permissions are the issue.

Does LibO even attempt to print? Check the CUPS log at
/var/log/cups/error_log and see if it mentions the job you're trying to
print (just go to the end of file and check the last lines).

The log here mentions jobs, even if there is no error (yes, in a file
called error_log). But of course this might depend on CUPS verbosity
settings.


Sorry for not providing feedback on printing with 3.4.0, I don't have
that version around here.

--
Nuno J. Silva (aka njsg)
gopher://sdf-eu.org/1/users/njsg

--
Unsubscribe instructions: E-mail to [hidden email]
In case of problems unsubscribing, write to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/www/users/
All messages sent to this list will be publicly archived and cannot be deleted

tronkel tronkel
Reply | Threaded
Open this post in threaded view
|

Re: Re: Re: LibreOffice 3.4.0

I'll need to eliminate the possibility that it's a problem with a particular Linux distro.

I'll download it again and try it in a Debian-based system this time.

Won't be today, but I'll do it in the next day or so

On , "Nuno J. Silva [via Document Foundation Mail Archive]" <[hidden email]> wrote:

>
>
> tronkel [hidden email]> writes:
>
> >> On 06/05/2011 11:06 AM, tronkel wrote:
>
> >
>
> >> > 3.4.0 shows a correctly installed CUPS printer but refuses to actually   print
>
> >> > the job.
>
> [...]
>
> >
>
> > The 2 systems on which I have tried LO 3.4.0 are Slackware 13.37 and Puppy  
>
> > Linux Wary 5.1.2. The printer itself is a Brother DCP7030 whose linux  
>
> > driver is supplied via the Brother website. Neither of these systems have a  
>
> > printing problem with LO 3.2.2. LO has never before given trouble when  
>
> > printing via any version of CUPS
>
> >
>
> > Something has been changed in the latest LO 3.4.2 to stop printing working.  
>
> > I suspect it may be a permissions problem with USB.
>
>
>
> If you're using CUPS, USB permission issues should happen on the CUPS
>
> side, or probably udev. (At least for the [Brother] scanner part you
>
> need to add some udev rules, and these might get overwritten by some
>
> system update.)
>
>
> But as your problem is only with a specific version of a specific
>
> program (LibreOffice), I seriously doubt USB permissions are the issue.
>
>
> Does LibO even attempt to print? Check the CUPS log at
>
> /var/log/cups/error_log and see if it mentions the job you're trying to
>
> print (just go to the end of file and check the last lines).
>
>
> The log here mentions jobs, even if there is no error (yes, in a file
>
> called error_log). But of course this might depend on CUPS verbosity
>
> settings.
>
>
>
> Sorry for not providing feedback on printing with 3.4.0, I don't have
>
> that version around here.
>
>
> --
>
> Nuno J. Silva (aka njsg)
>
> gopher://sdf-eu.org/1/users/njsg
>
>
> --
>
> Unsubscribe instructions: E-mail to [hidden email]
>
> In case of problems unsubscribing, write to [hidden email]
>
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/www/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>
>
>
>
>
>
>
>
>
>
> If you reply to this email, your message will be added to the discussion below:
>
> http://nabble.documentfoundation.org/LibreOffice-3-4-0-tp3026425p3032090.html
>
>
>
>
> To unsubscribe from LibreOffice 3.4.0, click here.
>
>
tronkel tronkel
Reply | Threaded
Open this post in threaded view
|

Re: Re: Re: LibreOffice 3.4.0

I've just re-installed the latest LO 3.4 in Linux Mint (a DEB compatible distro)

This Installation of Linux Mint already has LO 3.2 pre-installed. I downloaded the latest LO 3.4 from the Document Foundation website and it installed OK into the /opt folder - i.e. a in totally separate location from that of LO 3.2

Printing was previously set up to work under LO 3.2 and works fine.

Printing also now seems to work under LO 3.4 i.e. the CUPS setup from LO 3.2 was picked up no problem by LO 3.4

Not a conclusive test but at least printing appears to work under LO 3.4

The conclusion is then, that this apparent printing problem under LO 3.4 is related to a specific Distro and probably not due to LO 3.4 itself.

I'll test it further and will post any new findings here.