[Libreoffice-qa] Issues with Display of Dialogs of 5.0-beta2

classic Classic list List threaded Threaded
10 messages Options
Andreas Mantke Andreas Mantke
Reply | Threaded
Open this post in threaded view
|

[Libreoffice-qa] Issues with Display of Dialogs of 5.0-beta2

Hello,

I installed LibreOffice 5.0-beta2-x64 on my openSuSE 13.2 with KDE
4.14.8 and got issues with the display of some dialogs. E.g. if I open a
new presentation in Impress and call in the context menu 'Text' the
dialog gets only a small part with a grey background. The biggest part
of the dialog gets a transparent background.

But there are many of such dialogs in 5.0, that behave that way. It's an
regression to 4.4 etc.

I tried with the own dialogs of LibreOffice but that doesn't change
anything.

Is this only a KDE thing or is this behavior shown on other desktop
environments too?

Regards,
Andreas

--
## Developer LibreOffice
## Freie Office-Suite für Linux, Mac, Windows
## http://LibreOffice.org
## Support the Document Foundation (http://documentfoundation.org)
## Meine Seite: http://www.amantke.de 

_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
Terrence Enger Terrence Enger
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

On Thu, 2015-06-11 at 22:13 +0200, Andreas Mantke wrote:
> Hello,

Hi,

>
> I installed LibreOffice 5.0-beta2-x64 on my openSuSE 13.2 with KDE
> 4.14.8 and got issues with the display of some dialogs. E.g. if I open a
> new presentation in Impress and call in the context menu 'Text' the
> dialog gets only a small part with a grey background. The biggest part
> of the dialog gets a transparent background.

In late May we had a flurry of bugs which sounded like this.
tdf#01488 "[META] RenderContext related issues" collects a lot of
them.

However, I thought they were mostly fixed by the time of beta2.  Just
now in Impress in beta2, I see a fully-painted context menu in each of
the three big panes.

I hate to suggest that you are confused about what version you are
running, but well, right now I am talking about ...

    Version: 5.0.0.0.beta2
    Build ID: 059fa2b7a3bda92168c65c61e50cc5c6fda8cfac
    Locale: en-CA (en_CA.UTF-8)


>
> But there are many of such dialogs in 5.0, that behave that way. It's an
> regression to 4.4 etc.
>
> I tried with the own dialogs of LibreOffice but that doesn't change
> anything.
>
> Is this only a KDE thing or is this behavior shown on other desktop
> environments too?

My environment is debian-wheezy with gnome in a fallback mode.  So,
that difference might be the second thing I would look at.

BTW, you know that beta3 is available now, don't you?

Regards,
Terry.

>
> Regards,
> Andreas
>
>


_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
m.a.riosv m.a.riosv
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

At least for me issue in Menu/Data/Filter/Advanced filter,
it remains with Win7x64Ultimate
Version: 5.0.0.0.beta3 (x64) Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c

https://bugs.documentfoundation.org/show_bug.cgi?id=91882

Miguel Ángel.
Andreas Mantke Andreas Mantke
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

In reply to this post by Terrence Enger
Hello,

Am 11.06.2015 um 23:03 schrieb Terrence Enger:

> On Thu, 2015-06-11 at 22:13 +0200, Andreas Mantke wrote:
>> Hello,
> Hi,
>
>> I installed LibreOffice 5.0-beta2-x64 on my openSuSE 13.2 with KDE
>> 4.14.8 and got issues with the display of some dialogs. E.g. if I open a
>> new presentation in Impress and call in the context menu 'Text' the
>> dialog gets only a small part with a grey background. The biggest part
>> of the dialog gets a transparent background.
> In late May we had a flurry of bugs which sounded like this.
> tdf#01488 "[META] RenderContext related issues" collects a lot of
> them.
>
> However, I thought they were mostly fixed by the time of beta2.  Just
> now in Impress in beta2, I see a fully-painted context menu in each of
> the three big panes.
>
> I hate to suggest that you are confused about what version you are
> running, but well, right now I am talking about ...
>
>     Version: 5.0.0.0.beta2
>     Build ID: 059fa2b7a3bda92168c65c61e50cc5c6fda8cfac
>     Locale: en-CA (en_CA.UTF-8)
>
>
>> But there are many of such dialogs in 5.0, that behave that way. It's an
>> regression to 4.4 etc.
>>
>> I tried with the own dialogs of LibreOffice but that doesn't change
>> anything.
>>
>> Is this only a KDE thing or is this behavior shown on other desktop
>> environments too?
> My environment is debian-wheezy with gnome in a fallback mode.  So,
> that difference might be the second thing I would look at.
>
> BTW, you know that beta3 is available now, don't you?

I saw this message yesterday but didn't scroll down the list to the new
beta(3).

I installed the beta3 now and deleted my LibreOffice-dev user profile.
The dialogue for Text displays fine now, but if I call the paragraph
dialog instead (context menu) I get the issue again.

I tried again a second time (after deleting the profile again) with the
paragraph dialogue directly and get the rendering issue with that dialog
too.

I try to figure out, if there are more of such dialogs with issues left.

Regards,
Andreas

--
## Developer LibreOffice
## Freie Office-Suite für Linux, Mac, Windows
## http://LibreOffice.org
## Support the Document Foundation (http://documentfoundation.org)
## Meine Seite: http://www.amantke.de 

_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
V Stuart Foote V Stuart Foote
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

As Anreas is on Linux with KDE4, this is likely to be tdf#91301 which should be resolved with a 5.0.0beta4 build.

Unclear of any relation to the other tdf#91882 issue which remains with today's builds of master.
Version: 5.1.0.0.alpha1+
Build ID: bb9dad2ef23829b2500c9f99154bca6a8ba7d49a
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-12_00:27:07
Locale: en-US (en_US)
Terrence Enger Terrence Enger
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

In reply to this post by Andreas Mantke
On Fri, 2015-06-12 at 17:28 +0200, Andreas Mantke wrote:
>
> I installed the beta3 now and deleted my LibreOffice-dev user profile.
> The dialogue for Text displays fine now, but if I call the paragraph
> dialog instead (context menu) I get the issue again.
>
> I tried again a second time (after deleting the profile again) with the
> paragraph dialogue directly and get the rendering issue with that dialog
> too.

Hmm.  I think it is time to file a bug report through our bug tracker
<https://bugs.documentfoundation.org/>; you will need to create a user
account.  "How to Report Bugs in LibreOffice"
<https://wiki.documentfoundation.org/QA/BugReport> will provide
general guidance.

The level of detail that you write in your "steps to reproduce" is
important: it may allow people (like me) who are not very familiar
with Impress to move the bug report along.

Please add me, [hidden email], to the "cc" of the report.

Thank you for helping us out.
Terry,


_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
Terrence Enger Terrence Enger
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

Stuart's answer is obviously more to the point than mine.  Please
disregard what I wrote ...

On Fri, 2015-06-12 at 13:05 -0400, Terrence Enger wrote:
> Hmm.  I think it is time to file a bug report through our bug tracker


_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
Pedro Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

In reply to this post by m.a.riosv
Hola Miguel Ángel

m.a.riosv wrote
At least for me issue in Menu/Data/Filter/Advanced filter,
it remains with Win7x64Ultimate
Version: 5.0.0.0.beta3 (x64) Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c

https://bugs.documentfoundation.org/show_bug.cgi?id=91882
Same here.

For some reason your posts are not being accepted by the QA mailing list, although they show on Nabble...

Maybe the mailing list administrator can fix this?

Regards,
Pedro
m.a.riosv m.a.riosv
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

Olá Pedro,

I guess it's because I always use nabble, but not easy to understand why my comments need approbation, having my libreoffice.org email account in my register here. Although perhaps there are not filters for that or I'm not in the proper list.

Regards.
Miguel Ángel.
Jean-Baptiste Faure-3 Jean-Baptiste Faure-3
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Display of Dialogs of 5.0-beta2

In reply to this post by Andreas Mantke
Le 11/06/2015 22:13, Andreas Mantke a écrit :
> Hello,
>
> I installed LibreOffice 5.0-beta2-x64 on my openSuSE 13.2 with KDE
> 4.14.8 and got issues with the display of some dialogs. E.g. if I open a
> new presentation in Impress and call in the context menu 'Text' the
> dialog gets only a small part with a grey background. The biggest part
> of the dialog gets a transparent background.

Something like tis bug report:
https://bugs.documentfoundation.org/show_bug.cgi?id=90437 ?
I do not have KDE to test myself.

Best regards.
JBF

--
Seuls des formats ouverts peuvent assurer la pérennité de vos documents.
Disclaimer: my Internet Provider being located in France, each of our
exchanges over Internet will be scanned by French spying services.
_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: http://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/