MS word doc with tables: spell check does not work

classic Classic list List threaded Threaded
4 messages Options
Uwe Brauer Uwe Brauer
Reply | Threaded
Open this post in threaded view
|

MS word doc with tables: spell check does not work


Hi

I am running Ubuntu 16.04 and either libreoffice 5 as shipped by Ubuntu
or libreoffice 6, installed by myself. The problem is the same in both
versions. I have installed in both version the relevant dictionaries,
spanish/english/german.

And in both I can run the spell checker on a new odt document.

However I am facing the following problem:


I open a MS doc document, which contains a large table which I have to
fill in. I type a word in spanish, mark it, and press F7 for spell
checking. The word is ignored since no dictionary is chosen.

    1. So I try to set spanish myself, but this is impossible.

    2. I mark the whole document--> select right mouse--> select char-->
       select font--> select spanish. No effect.


I am really puzzled, I googled and did not find any answer.

Any help would be appreciated.

Uwe Brauer



--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy

libreoffice-ml.mbourne libreoffice-ml.mbourne
Reply | Threaded
Open this post in threaded view
|

Re: MS word doc with tables: spell check does not work

Uwe Brauer wrote:

>
> Hi
>
> I am running Ubuntu 16.04 and either libreoffice 5 as shipped by Ubuntu
> or libreoffice 6, installed by myself. The problem is the same in both
> versions. I have installed in both version the relevant dictionaries,
> spanish/english/german.
>
> And in both I can run the spell checker on a new odt document.
>
> However I am facing the following problem:
>
>
> I open a MS doc document, which contains a large table which I have to
> fill in. I type a word in spanish, mark it, and press F7 for spell
> checking. The word is ignored since no dictionary is chosen.
>
>      1. So I try to set spanish myself, but this is impossible.
>
>      2. I mark the whole document--> select right mouse--> select char-->
>         select font--> select spanish. No effect.
>
>
> I am really puzzled, I googled and did not find any answer.
>
> Any help would be appreciated.

I assume the word you're typing is spelled incorrectly? Of course the
spell checker will skip over it if spelled correctly in the selected
language.

You could try on the menu Tools > Language > For All Text > Spanish. If
Spanish isn't already listed there select More and then, under the
"Default Languages for Documents" section of the options dialog which
appears, select Spanish and check "For the current document only".

Check that the Spanish dictionary is definitely installed correctly. In
the dropdown box where you select the language, there should be a tick
with "ABC" alongside "Spanish".

If that still doesn't work, it might be worth saving the document in ODT
format, close and then open the ODT version. I don't think that's likely
to make any difference, but you may as well try if nothing else helps.

If none of that helps, perhaps someone else here with more experience of
working in different languages might have some ideas...

--
Mark.


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Uwe Brauer Uwe Brauer
Reply | Threaded
Open this post in threaded view
|

Re: MS word doc with tables: spell check does not work

>>> "libreoffice-ml" == libreoffice-ml mbourne <[hidden email]> writes:

   > Uwe Brauer wrote:
   > I assume the word you're typing is spelled incorrectly? Of course the
   > spell checker will skip over it if spelled correctly in the selected
   > language.

   > You could try on the menu Tools > Language > For All Text > Spanish.
   > If Spanish isn't already listed there select More and then, under the
   > "Default Languages for Documents" section of the options dialog which
   > appears, select Spanish and check "For the current document only".

   > Check that the Spanish dictionary is definitely installed correctly.
   > In the dropdown box where you select the language, there should be a
   > tick with "ABC" alongside "Spanish".

   > If that still doesn't work, it might be worth saving the document in
   > ODT format, close and then open the ODT version. I don't think that's
   > likely to make any difference, but you may as well try if nothing else
   > helps.

   > If none of that helps, perhaps someone else here with more experience
   > of working in different languages might have some ideas...

Nothing helped, thanks.

 I presume it is something wired with the fields in the table, the way
there were generated by MS Word

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Felmon Davis Felmon Davis
Reply | Threaded
Open this post in threaded view
|

Re: MS word doc with tables: spell check does not work

On Mon, 6 Aug 2018, Uwe Brauer wrote:

>>>> "libreoffice-ml" == libreoffice-ml mbourne <[hidden email]> writes:
>
>   > Uwe Brauer wrote:
>   > I assume the word you're typing is spelled incorrectly? Of course the
>   > spell checker will skip over it if spelled correctly in the selected
>   > language.
>
>   > You could try on the menu Tools > Language > For All Text > Spanish.
>   > If Spanish isn't already listed there select More and then, under the
>   > "Default Languages for Documents" section of the options dialog which
>   > appears, select Spanish and check "For the current document only".
>
>   > Check that the Spanish dictionary is definitely installed correctly.
>   > In the dropdown box where you select the language, there should be a
>   > tick with "ABC" alongside "Spanish".
>
>   > If that still doesn't work, it might be worth saving the document in
>   > ODT format, close and then open the ODT version. I don't think that's
>   > likely to make any difference, but you may as well try if nothing else
>   > helps.
>
>   > If none of that helps, perhaps someone else here with more experience
>   > of working in different languages might have some ideas...
>
> Nothing helped, thanks.
>
> I presume it is something wired with the fields in the table, the way
> there were generated by MS Word

can you try copying the contents of a field onto the clipboard and
pasting them back but using "paste special" and selecting your word
processor's format?

I have lost track of the thread so forgive if already tried but what
about saving the document as LO and then working on it?

f.

--
Felmon Davis
Schenectady, NY

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy