Manually installed LibreOffice reports a wrong version number

classic Classic list List threaded Threaded
2 messages Options
Babak Razmjoo Babak Razmjoo
Reply | Threaded
Open this post in threaded view
|

Manually installed LibreOffice reports a wrong version number

Hi, I have downloaded LibreOffice 6.2.2.2 from the website and installed it by its 'install' script. An older version of LibreOffice (6.1.5.2) was installed on my PC by default and I installed 6.2.2.2 in a local folder. Now 'soffice' binary resides in that folder and PATH refers to it correctly. If I type 'which soffcie', it responds as :
  /mnt/home/install/libreoffice/opt/libreoffice6.2/program/soffice
But when i type 'soffcie --version' it gives me:
  LibreOffice 6.1.5.2 10(Build:2)
Also the reported version in About dialogs in components started by 'soffice --impress' or 'soffice --writer' is 6.1.5.2 too.
I have this problem from this morning, or maybe yesterday. So please tell me what is wrong here?

Sent with [ProtonMail](https://protonmail.com) Secure Email.
--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
sberg sberg
Reply | Threaded
Open this post in threaded view
|

Re: Manually installed LibreOffice reports a wrong version number

On 11/04/2019 13:31, Babak Razmjoo wrote:
> Hi, I have downloaded LibreOffice 6.2.2.2 from the website and installed it by its 'install' script. An older version of LibreOffice (6.1.5.2) was installed on my PC by default and I installed 6.2.2.2 in a local folder. Now 'soffice' binary resides in that folder and PATH refers to it correctly. If I type 'which soffcie', it responds as :
>    /mnt/home/install/libreoffice/opt/libreoffice6.2/program/soffice
> But when i type 'soffcie --version' it gives me:
>    LibreOffice 6.1.5.2 10(Build:2)
> Also the reported version in About dialogs in components started by 'soffice --impress' or 'soffice --writer' is 6.1.5.2 too.
> I have this problem from this morning, or maybe yesterday. So please tell me what is wrong here?

Does typing `hash soffice` in that shell help (so it forgets about a
hashed path to the old soffice instance)?

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy