MariaDB configure error with autogen.sh

classic Classic list List threaded Threaded
6 messages Options
Wols Lists Wols Lists
Reply | Threaded
Open this post in threaded view
|

MariaDB configure error with autogen.sh

Just building a new libreoffice, and --with-systgem-mariadb is
complaining that mariadb 5.5 is too old, it wants 5.0 or 5.1 :-)

Cheers,
Wol
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
Lionel Elie Mamane Lionel Elie Mamane
Reply | Threaded
Open this post in threaded view
|

Re: MariaDB configure error with autogen.sh

On Fri, Apr 26, 2013 at 10:54:22AM +0100, Wols Lists wrote:
> Just building a new libreoffice, and --with-systgem-mariadb is
> complaining that mariadb 5.5 is too old, it wants 5.0 or 5.1 :-)

Please show us the output of "mariadb_config --version". Thanks.

--
Lionel
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
Wols Lists Wols Lists
Reply | Threaded
Open this post in threaded view
|

Re: MariaDB configure error with autogen.sh

On 26/04/13 11:12, Lionel Elie Mamane wrote:
> On Fri, Apr 26, 2013 at 10:54:22AM +0100, Wols Lists wrote:
>> Just building a new libreoffice, and --with-systgem-mariadb is
>> complaining that mariadb 5.5 is too old, it wants 5.0 or 5.1 :-)
>
> Please show us the output of "mariadb_config --version". Thanks.
>
anthony@tigger ~ $ mariadb_config --version
-bash: mariadb_config: command not found
anthony@tigger ~ $ emerge --search mariadb
Searching...
[ Results for search key : mariadb ]
[ Applications found : 1 ]

*  dev-db/mariadb
      Latest version available: 5.5.30
      Latest version installed: 5.5.30
      Size of files: 29,076 kB
      Homepage:      http://mariadb.org/
      Description:   An enhanced, drop-in replacement for MySQL
      License:       GPL-2

anthony@tigger ~ $


Hmm ... so that means I need to track down where mariadb_config has
disappeared ...

Cheers,
Wol
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
Wols Lists Wols Lists
Reply | Threaded
Open this post in threaded view
|

Re: MariaDB configure error with autogen.sh

On 27/04/13 01:02, Wols Lists wrote:

> On 26/04/13 11:12, Lionel Elie Mamane wrote:
>> On Fri, Apr 26, 2013 at 10:54:22AM +0100, Wols Lists wrote:
>>> Just building a new libreoffice, and --with-systgem-mariadb is
>>> complaining that mariadb 5.5 is too old, it wants 5.0 or 5.1 :-)
>>
>> Please show us the output of "mariadb_config --version". Thanks.
>>
> anthony@tigger ~ $ mariadb_config --version
> -bash: mariadb_config: command not found
> anthony@tigger ~ $ emerge --search mariadb
> Searching...
> [ Results for search key : mariadb ]
> [ Applications found : 1 ]
>
> *  dev-db/mariadb
>       Latest version available: 5.5.30
>       Latest version installed: 5.5.30
>       Size of files: 29,076 kB
>       Homepage:      http://mariadb.org/
>       Description:   An enhanced, drop-in replacement for MySQL
>       License:       GPL-2
>
> anthony@tigger ~ $
>
>
> Hmm ... so that means I need to track down where mariadb_config has
> disappeared ...
>
I've found it ...

tigger anthony # mysql_config --version
5.5.30
tigger anthony # emerge --search mysql
Searching...
[ Results for search key : mysql ]
[ Applications found : 47 ]

*  dev-db/mysql
      Latest version available: 5.1.67
      Latest version installed: [ Not Installed ]
      Size of files: 26,054 kB
      Homepage:      http://www.mysql.com/
      Description:   A fast, multi-threaded, multi-user SQL database server.
      License:       GPL-2

So on gentoo they haven't changed the name, it's still called
mysql_config despite me having mariadb installed and no mysql.

Hmmm ... what do we do now?

Cheers,
Wol
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
Wols Lists Wols Lists
Reply | Threaded
Open this post in threaded view
|

Re: MariaDB configure error with autogen.sh

On 27/04/13 01:08, Wols Lists wrote:
> So on gentoo they haven't changed the name, it's still called
> mysql_config despite me having mariadb installed and no mysql.
>
> Hmmm ... what do we do now?

Bug reported to gentoo - hopefully mariadb_config will be part of the
next update.

Cheers,
Wol
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice
Fridrich Strba-4 Fridrich Strba-4
Reply | Threaded
Open this post in threaded view
|

Re: MariaDB configure error with autogen.sh

In reply to this post by Wols Lists
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

In your autogen.input or autogen.lastrun, just add similar line:

MARIADBCONFIG=/full/path/to/mysql_config

The configury will know what to do.

F.

On 27/04/13 02:08, Wols Lists wrote:
> So on gentoo they haven't changed the name, it's still called
> mysql_config despite me having mariadb installed and no mysql.
>
> Hmmm ... what do we do now?
>
> Cheers, Wol
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlF7lNQACgkQu9a1imXPdA+ZJACghD10OUJOA+sbrQezN/Lp03YL
Jm4An0KRwf2iHCmUs+7xfAuFChdsLQF0
=cZKr
-----END PGP SIGNATURE-----
_______________________________________________
LibreOffice mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/libreoffice