Pb d'éditeur dans l'IDE LibreOffice

classic Classic list List threaded Threaded
8 messages Options
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|

Pb d'éditeur dans l'IDE LibreOffice

Bonsoir,

j'ai passé deux postes sous LinuxMint 19 64b. Testé sous les
environnements Cinnamon et XFCE, sous LibreOffice packagé (6.0.3) et
LibreOffice officiel (5.4.7).

Les lignes de texte dans l'éditeur sous l'IDE macros sont très serrées,
si bien que cet éditeur est très pénible à utiliser : les lignes se
chevauchent en partie, le texte peut être très difficile à lire.

Je ne connais pas d'option interne qui permette de changer ça.

Je n'ai pas (encore) cherché dans bugzilla mais mes recherches web n'ont
rien donné.

Des idées ?

Merci d'avance. Bien cordialement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
yves dutrieux yves dutrieux
Reply | Threaded
Open this post in threaded view
|

Re: [fr-qa] Pb d'éditeur dans l'IDE LibreOffice

Jean-Baptiste serait là, il te demanderait de voir si Libreoffice tourne
avec quelle version de GTK..
de mémoire, il me semble qu'on peut le forcer via une variable
d'environnement.

== copie d'une de ses discussions pour un problème d'affichage :
Le 09/10/2017 à 16:30, Rpnpif a écrit :

> Le  9 octobre 2017, Jean-Baptiste Faure a écrit :
> [...]
>
>> Sur quelle version ?
>> Avec GTK2 ou GTK3 ?
>>
>
> J'ai le même problème sous Debian Jessie et sous Stretch.
>

ça ne me parle pas beaucoup ;-)
Si tu as LibreOffice avec gtk2 je te suggère d'essayer avec gtk3 en
installant le paquet libreoffice-gtk3.
Tu peux essayer l'un ou l'autre en lançant LO dans un terminal. Il suffit
de définir la variable d'environnement idoine avant :
$ export SAL_USE_VCLPLUGIN="gtk3"
$ libreoffice
Pour gtk2 c'est export SAL_USE_VCLPLUGIN="gtk"
=========
si ça peut t'aider à y voir plus clair ... si j'ose dire ;)

Yves


Le 18 juillet 2018 à 22:58, Jean-Francois Nifenecker <
[hidden email]> a écrit :

> Bonsoir,
>
> j'ai passé deux postes sous LinuxMint 19 64b. Testé sous les
> environnements Cinnamon et XFCE, sous LibreOffice packagé (6.0.3) et
> LibreOffice officiel (5.4.7).
>
> Les lignes de texte dans l'éditeur sous l'IDE macros sont très serrées, si
> bien que cet éditeur est très pénible à utiliser : les lignes se
> chevauchent en partie, le texte peut être très difficile à lire.
>
> Je ne connais pas d'option interne qui permette de changer ça.
>
> Je n'ai pas (encore) cherché dans bugzilla mais mes recherches web n'ont
> rien donné.
>
> Des idées ?
>
> Merci d'avance. Bien cordialement,
> --
> Jean-Francois Nifenecker, Bordeaux
>
>
> --
> Envoyez un mail à [hidden email] pour vous désinscrire
> Les archives de la liste sont disponibles à https://listarchives.libreoffi
> ce.org/fr/qa/
> Privacy Policy: https://www.documentfoundation.org/privacy
>



--
web site : http://www.molenbaix.com

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|

Re: Pb d'éditeur dans l'IDE LibreOffice

Bonjour Yves,

Le 18/07/2018 à 23:31, yves dutrieux a écrit :
> Jean-Baptiste serait là, il te demanderait de voir si Libreoffice tourne
> avec quelle version de GTK..
> de mémoire, il me semble qu'on peut le forcer via une variable
> d'environnement.

oui, j'avais bien souvenir de ça, merci pour le rappel. J'ai posté
depuis un autre PC que ma machine habituelle, si bien que je n'avais pas
d'archives.

> si ça peut t'aider à y voir plus clair ... si j'ose dire ;)

J'ai testé et... plantage de LibreOffice :(

Je reste donc dans la brume.


Amicalement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Alex Thurgood Alex Thurgood
Reply | Threaded
Open this post in threaded view
|

Re: Pb d'éditeur dans l'IDE LibreOffice

In reply to this post by Jean-Francois Nifenecker
Bonjour Jean-François,

Quelle est ta police système ?

De mémoire, il me semble que l'IDE reprend la police système, je ne suis
pas certain que tu puisse le changer au sein de la configuration de LO,
mais tu peux préciser s'il s'agit d'une police proportionnelle ou non,
ainsi que la taille par défaut.

Il y a peut-être du coup un bug entre l'IDE et la police système choisie
par Mint.

Sous Outils > Options > Polices, tu as quoi comme options pour
"Paramétrages de Police pour les Sources HTML, Basic et SQL" ?


Alex




--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Jean-Baptiste Faure-3 Jean-Baptiste Faure-3
Reply | Threaded
Open this post in threaded view
|

Re: [fr-qa] Pb d'éditeur dans l'IDE LibreOffice

In reply to this post by yves dutrieux
Bonjour,

Le 18/07/2018 à 23:31, yves dutrieux a écrit :
> Jean-Baptiste serait là, il te demanderait de voir si Libreoffice tourne
> avec quelle version de GTK..
> de mémoire, il me semble qu'on peut le forcer via une variable
> d'environnement.
Exact :-)
Et je proposerais aussi de tester avec ou sans OpenGL (pour ça il faut
passer par la configuration avancée).

Si je voulais troller, j'irais jusqu'à suggérer de tester avec une vraie
distribution Ubuntu... ;-)

Remarque : la version courante de la branche 6.0 est la 6.0.5, pas la 6.0.3.

Bonne journée
JBF

--
Seuls des formats ouverts peuvent assurer la pérennité de vos documents.
Disclaimer: my Internet Provider being located in France, each of our
exchanges over Internet will be scanned by French spying services.


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|

Re: Pb d'éditeur dans l'IDE LibreOffice

In reply to this post by Alex Thurgood
Bonjour Alexandre,

merci pour tes questions qui m'ont mis sur la voie !

Le 19/07/2018 à 09:35, Alexander Thurgood a écrit :

>
> De mémoire, il me semble que l'IDE reprend la police système, je ne suis
> pas certain que tu puisse le changer au sein de la configuration de LO,
> mais tu peux préciser s'il s'agit d'une police proportionnelle ou non,
> ainsi que la taille par défaut.
>
> Il y a peut-être du coup un bug entre l'IDE et la police système choisie
> par Mint.
>
> Sous Outils > Options > Polices, tu as quoi comme options pour
> "Paramétrages de Police pour les Sources HTML, Basic et SQL" ?

le choix était celui trouvé habituellement : Automatique
si bien que je n'y prête jamais attention et que même j'avais oublié son
existence...

Après plusieurs essais, j'ai constaté que Liberation Mono est la police
qui pose problème (et c'est peut-être celle prise par défaut). Les
autres polices que j'ai essayées redonnent vie à l'éditeur !

Donc problème résolu. J'ai choisi Source Code Pro et je peux retravailler !


PS: au passage j'ai détecté un léger bug. Lors du changement de police
pour l'IDE, celle utilisée pour la numérotation des lignes n'est pas
actualisée, si bien qu'il y a un décalage entre la numérotation et les
lignes de code. Comme il suffit de supprimer/ajouter la numérotation, je
ne signale pas.


Amicalement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|

Re: [fr-qa] Pb d'éditeur dans l'IDE LibreOffice

In reply to this post by Jean-Baptiste Faure-3
Bonjour Jean-Baptiste,

Le 19/07/2018 à 12:32, Jean-Baptiste Faure a écrit :
> Exact :-)

:-)

> Et je proposerais aussi de tester avec ou sans OpenGL (pour ça il faut
> passer par la configuration avancée).

Pas dit mais essayé aussi :)

Bon, Alex m'a mis sur la voie. La coupable est la police "Automatique"
qui /semble/ être Liberation Mono. Le choix d'une autre que celle-là
permet de rétablir la situation.

>
> Si je voulais troller, j'irais jusqu'à suggérer de tester avec une vraie
> distribution Ubuntu... ;-)

Il n'y a pas de vraie distribution Ubunutu. La seule vraie, c'est Debian :-P

[1] Pour connaître une distribution, il faut l'utiliser au quotidien.
LinuxMint est très populaire, je regarde donc en détails ce qu'elle vaut
pour être capable de la (dé)conseiller si besoin.

>
> Remarque : la version courante de la branche 6.0 est la 6.0.5, pas la
> 6.0.3.

Exact. Mais c'est la version packagée par Mint. Je n'utilise *jamais*
les versions packagées que je m'empresse de supprimer pour les remplacer
par une des deux versions officielles. Ici, j'ai voulu voir ce qu'il en
était du pb d'IDE dans différents contextes (voir ma remarque [1]
ci-dessus).


Amicalement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy
Jean-Francois Nifenecker Jean-Francois Nifenecker
Reply | Threaded
Open this post in threaded view
|

Re: Pb d'éditeur dans l'IDE LibreOffice

In reply to this post by Jean-Francois Nifenecker
Bonjour,

Le 18/07/2018 à 22:58, Jean-Francois Nifenecker a écrit :
>
> j'ai passé deux postes sous LinuxMint 19 64b. Testé sous les
> environnements Cinnamon et XFCE, sous LibreOffice packagé (6.0.3) et
> LibreOffice officiel (5.4.7).
>
> Les lignes de texte dans l'éditeur sous l'IDE macros sont très serrées,
> si bien que cet éditeur est très pénible à utiliser : les lignes se
> chevauchent en partie, le texte peut être très difficile à lire.
>

après installation d'une Debian 9.5 sous XFCE, il s'avère que là
l'éditeur de l'IDE a un comportement tout à fait standard. Pas besoin de
modifier la police par défaut. C'est donc bien la distribution qui
génère le comportement signalé.

Merci à tous pour vos retours et pistes.


Bien cordialement,
--
Jean-Francois Nifenecker, Bordeaux


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/qa/
Privacy Policy: https://www.documentfoundation.org/privacy