Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

classic Classic list List threaded Threaded
9 messages Options
VinceB VinceB
Reply | Threaded
Open this post in threaded view
|

Problem: Generating a Table in LO Base from a LO Calc Spreadsheet


Hello Group:

I hope you are healthy and safe.

I am having a problem when I attempt  to create a LO Base table from a
LO Calc spreadsheet, and I am stumped.

This is what I have done:

In Windows 10 Home x64, I highlighted & Copied the data, A1:E161, from a
LO vers 6.4.4.2 (x64) Calc file to the win10 clipboard.

In LO Base-Tables panel, I used Ctl-V to paste the data. Under
Tables-Options, selected Definition and data. Check marks placed at "Use
first line as column (i.e., field) names", and also at "Create new field
as primary key". Primary key named: Passwrd-ID.
then clicked the Create button. Table1 appeared in Tables panel.

Doing a left mouse click on Table1, I see the field names, but do not
see the record data. If I select a field, at the top, the record data is
visible only as white text on a dark blue background.

Why am I not able to see the record data throughout each field when
doing the above described procedure?  What am I not doing correctly?

I am a novice at creating a Base table from a Calc file. At present, I
have five tables created within the same LO Base file; only one of the
five tables is fully showing the record data. I do not recall the
precise procedure used when creating that one table.

HELP!

Your guidance/reply info will be greatly appreciated.

VinceB.



--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Brian Barker Brian Barker
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

At 13:15 04/08/2020 -0400, Vince Bonly wrote:

>I am having a problem when I attempt to create a LO Base table from
>a LO Calc spreadsheet, and I am stumped. This is what I have done:
>
>In Windows 10 Home x64, I highlighted & Copied the data, A1:E161,
>from a LO vers 6.4.4.2 (x64) Calc file to the win10 clipboard. In LO
>Base-Tables panel, I used Ctl-V to paste the data. Under
>Tables-Options, selected Definition and data. Check marks placed at
>"Use first line as column (i.e., field) names", and also at "Create
>new field as primary key". Primary key named: Passwrd-ID. then
>clicked the Create button. Table1 appeared in Tables panel.
>
>Doing a left mouse click on Table1, I see the field names, but do
>not see the record data. If I select a field, at the top, the record
>data is visible only as white text on a dark blue background. Why am
>I not able to see the record data throughout each field when doing
>the above described procedure? What am I not doing correctly?

This is a pure guess, based on the experience of another user. Are
the column titles in your spreadsheet (which become field names)
formatted as white text on a coloured background? (And why not?) If
so, it may be that the text colour, but not background colour, has
been carried over and - unhelpfully - applied to all of the records
in addition. If that is the problem, there are two alternative
solutions, I think:

o Change the spreadsheet formatting (perhaps temporarily) so that the
headings are no longer in white text. Create the database table anew.

o In the database Tables panel, use Edit | Paste Special... (or
right-click | Paste Special...) instead of ordinary Paste and select
an alternative option - perhaps "Formatted text [RTF]"?

I trust this helps.

Brian Barker


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

In reply to this post by VinceB
Hi Vince,
>
> Doing a left mouse click on Table1, I see the field names, but do not
> see the record data. If I select a field, at the top, the record data is
> visible only as white text on a dark blue background.

The data are part of the database. This is good. But the format of the
table is the problem.

Open the table and mark the whole content (Click with the mouse left
beside the first fieldname). Then right mousclick → Tableformat. You
could choose the color for the font there. Best choise would be
"automatic" ord "black".

Regards

Robert
--
Homepage: https://www.familiegrosskopf.de/robert


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
VinceB VinceB
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet


On 8/4/2020 2:52 PM, Robert Großkopf wrote:

> Hi Vince,
>> Doing a left mouse click on Table1, I see the field names, but do not
>> see the record data. If I select a field, at the top, the record data is
>> visible only as white text on a dark blue background.
> The data are part of the database. This is good. But the format of the
> table is the problem.
>
> Open the table and mark the whole content (Click with the mouse left
> beside the first fieldname). Then right mousclick → Tableformat. You
> could choose the color for the font there. Best choise would be
> "automatic" ord "black".
>
> Regards
>
> Robert


Thank you very much, Robert.  I changed the font effect color to
Automatic, and also the character size, to 10 pts (easier on my 75 y/o
eyes).   So, I have learned that some formatting from Calc is not
carried over to Base.

I am now wondering where/if there is a (global) default setting for the
table formatting, and I will look for that now. I was not expecting a
need to change the font effect format.

Ciao!

VinceB.



--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
VinceB VinceB
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

In reply to this post by Robert Großkopf

On 8/4/2020 2:52 PM, Robert Gro??kopf wrote:

>
> The data are part of the database. This is good. But the format of the
> table is the problem.
>
> Open the table and mark the whole content (Click with the mouse left
> beside the first fieldname). Then right mousclick ??? Tableformat. You
> could choose the color for the font there. Best choise would be
> "automatic" ord "black".
>
> Regards
>
> Robert


I am having the same type of problem with another Calc sheet conversion
to a Base table. This time, data within each field have an underline
present.?? How do I remove the underscores/underlining?

The Font Effects | Text Description | Underling: control box option
indicates "(Without)", but after clicking OK button, nothing happens.
What am I missing here?

VinceB.




--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

Hi Vince,
>
>
> I am having the same type of problem with another Calc sheet conversion
> to a Base table. This time, data within each field have an underline
> present.?? How do I remove the underscores/underlining?
>
> The Font Effects | Text Description | Underling: control box option
> indicates "(Without)", but after clicking OK button, nothing happens.
> What am I missing here?

Could you please send me an example for this behavior? Or write down who
to get this behavior? I have never seen this before. The only thing I
could say: The format of the fonts in the table isn't part of the
database and isn't saved anywhere elese. It wouldn't appear in a form,
for example.

Regards

Robert
--
Homepage: https://www.familiegrosskopf.de/robert


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Brian Barker Brian Barker
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

In reply to this post by VinceB
At 11:02 07/08/2020 -0400, Vince Bonly wrote:

>On 8/4/2020 2:52 PM, Robert Großkopf wrote:
>>The data are part of the database. This is
>>good. But the format of the table is the problem.
>>
>>Open the table and mark the whole content
>>(Click with the mouse left beside the first
>>fieldname). Then right mousclick | Tableformat.
>>You could choose the color for the font there.
>>Best choice would be "automatic" or "black".
>
>I am having the same type of problem with
>another Calc sheet conversion to a Base table.
>This time, data within each field have an
>underline present. How do I remove the
>underscores/underlining? The Font Effects | Text
>Description | Underling: control box option
>indicates "(Without)", but after clicking OK
>button, nothing happens. What am I missing here?

As I suggested earlier, some aspects of
formatting of some parts of the column headings
in a spreadsheet are carried over - perhaps
unhelpfully - not into the relevant field names
but instead *all* the records copied. My previous
solution will work: apply default formatting to
the column heading row in your spreadsheet before
copying the data. You can easily undo such a
change in your spreadsheet if you wish.

A workaround may be to use Table Format... to
change the Underlining style to something other
than "(Without)" and then back again.

I trust this helps.

Brian Barker


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy

VinceB VinceB
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

In reply to this post by Robert Großkopf
Good Afternoon, Robert:

I am sorry to have wasted your time and the mail list bandwidth.?? I just
now realized that the column headings in the source Calc file are
underscored!

I'll now clean my eyeglass lens, and continue my experimentation and
self-learning in LibreOffice-Base.

VinceB. ????


On 8/7/2020 1:00 PM, Robert Gro??kopf wrote:

> Hi Vince,
>>
>> I am having the same type of problem with another Calc sheet conversion
>> to a Base table. This time, data within each field have an underline
>> present.?? How do I remove the underscores/underlining?
>>
>> The Font Effects | Text Description | Underling: control box option
>> indicates "(Without)", but after clicking OK button, nothing happens.
>> What am I missing here?
> Could you please send me an example for this behavior? Or write down who
> to get this behavior? I have never seen this before. The only thing I
> could say: The format of the fonts in the table isn't part of the
> database and isn't saved anywhere elese. It wouldn't appear in a form,
> for example.
>
> Regards
>
> Robert

--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Problem: Generating a Table in LO Base from a LO Calc Spreadsheet

In reply to this post by Brian Barker
Hi Brian, Vince, *

I have written a bug-description for this behavior:
https://bugs.documentfoundation.org/show_bug.cgi?id=135540

Could someone confirm this bug?

Regards

Robert
--
Homepage: https://www.familiegrosskopf.de/robert


--
To unsubscribe e-mail to: [hidden email]
Problems? https://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/global/users/
Privacy Policy: https://www.documentfoundation.org/privacy