Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

classic Classic list List threaded Threaded
10 messages Options
WirBeide WirBeide
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

Hallo in die Runde,
Gerhard Weydt war so nett, dieses Problem in diese Runde zu posten.
Bisher gibt es keinerlei Reaktion? Wie soll ich das verstehen? Ist das
Problem schlecht beschrieben, zu kompliziert oder sollte es wirklich
niemand geben, der dazu etwas sagen kann? Mich bewegt es schon längere
Zeit und ich würde es gern "mal vom Tisch" kriegen.
Beste Grüße,
Peter

--
+-----------
|  Gabiriela und Peter Kiesel
|  Telefon: +49 8142 443987 - Web: http://www.gupki.de
|  E-Mail: [hidden email] - Mobil: +49 151 57825047


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

Hallo Peter,

> Gerhard Weydt war so nett, dieses Problem in diese Runde zu posten.
> Bisher gibt es keinerlei Reaktion? Wie soll ich das verstehen? Ist das
> Problem schlecht beschrieben, zu kompliziert oder sollte es wirklich
> niemand geben, der dazu etwas sagen kann? Mich bewegt es schon längere
> Zeit und ich würde es gern "mal vom Tisch" kriegen.

Vielleicht gibt es einfach zu wenig Leute hier, die mit so einer
Kombination arbeiten. Ich z.B. speichere nur lokal und nutze auch sonst
kein NAS.

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Michael Höhne Michael Höhne
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Peter,

> Bisher gibt es keinerlei Reaktion? Wie soll ich das verstehen? Ist
> das Problem schlecht beschrieben, zu kompliziert oder sollte es
> wirklich niemand geben, der dazu etwas sagen kann? Mich bewegt es
> schon längere Zeit und ich würde es gern "mal vom Tisch" kriegen.

Ich kann erst einmal bestätigen, dass ich das gleiche Problem hätte,
wenn ich die Funktion nutzen würde, was ich aber nur für diese Test das
erste mal getan habe.

Aus deinen Info schließe ich, dass du sowohl unter Windows, als auch
unter Linux die Dateien der betreffenden Freigabe über einen direkten
(UNC-)Pfad ansprichst, also unter:

        Windows: \\server\freigabe\...
        Linux: smb://server/freigabe/...


Du schreibst ja, dass der Link im Dokument als "smb://..." gespeichert
wäre.

Leider heißt das ja nicht, das Linux und Windows hier auf die gleiche
Nomenklatur zurück greifen, sondern nur, dass sich die
LibreOffice-Macher für die Speicherung des Netzwerkpfades auf diese
Nomenklatur geeinigt haben... Das macht ja auch Sinn, da man die gleiche
Schreibweise für diverse andere Protokolle verwenden kann: ftp://... ,
http://...

Bei der Übergabe an das Windows-System, das mit dieser Angabe so gar
nicht anfangen kann, wird diese Angabe wohl in die dort übliche
UNC-Pfadangabe (\\...\...\...) gewandelt, während es bei Linux direkt
an den Desktop übergeben wird.

Unter Linux hingegen ist das SMB-Protokoll ja nicht nativ eingebaut, so
dass der Desktop entsprechende "Helfer" bemühen muss. Hier scheint dann
aber der Hund begraben zu sein:

Genau wie bei dir, bekomme ich Problemlos einen Link z.B. zu einer
Überschrift eines Dokumentes auf meinem NAS nur dann eingerichtet, wenn
ich den kompletten Pfad zum Dokument manuell vorgebe (hier:
smb://192.168.3.12/public/Test.odt).

Wenn ich hingegen mit dem sich öffnenden Dateiauswahlfenster zu der
Datei "navigiere", so scheitere ich! Selbst wenn ich die Eingabe per
Textzeile einschalte und den Pfad bis

        smb://192.168.3.12/

oder gar bis

        smb://192.168.3.12/public

vorgebe, bekomme ich eine Fehlermeldung, das dies kein Ordner wäre und
kann auch nicht weiter navigieren.

Das ganze auf einem Laptop mit xfce unter Ubuntu.

So wie es ausschaut, gibt es da ein Kommunikationsproblem zwischen LO
und dem Desktop, so dass LO keine als gültig interpretierbare Angabe
zum Dateipfad zurück geliefert bekommt.

Wenn man das häufiger braucht, ist der Fehler natürlich lästig.

Ich würde dir empfehlen wollen, den Netzwerkpfad durch das "Mounten" der
Freigabe zu vermeiden. So würdest du einfach zu einem Dokument
innerhalb des Dateibaums verlinken und das "smb://" als
Protokollangabe könnte entfallen. Aber dann hast du ein Problem bei den
Windows-Rechnern, bei denen das "Mounten" ja nur als "Netzlaufwerk" mit
"Laufwerksbuchstaben" vorgesehen ist. Damit bekommt man schwerlich
einen Dateipfad, der sowohl unter Linux als auch unter Windows
identisch ist...

Gruß,
Michael
--
    ____        
   / / / / /__/      Michael Höhne /
  /   / / /  /  [hidden email] /
 ________________________________/


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
WirBeide WirBeide
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Michael,
danke für Deine Rückantwort. Sie ist für mich die erste Bestätigung,
dass mein Problem echt ist und offenbar ist es mir auch gelungen, es
recht gut zu beschrieben, denn alle Deine Aussagen passen genau zu
meinem Problem. Ich habe ein etwas abweichendes Erscheinungsbild, als
Du, ich bekomme, wenn ich in Linux den Link in der Form smb://...
manuell eingebe
keine Fehlermeldung, sondern dann wird dieser Eintrag korrekt
gespeichert und funktioniert auch in Linux und in Windows (vielleicht
liegt es daran, dass ich LinuxMint-MATE nutze?). Was mich nur noch stört
ist, dass es nicht benutzerfreundlich über einen Menüpunkt funktioniert
(als Arbeitserleichterung). Und was mich "politisch" stört, dass man bei
diesem Problem den Eindruck hat, dass Windows das bessere System ist.
Deine abschließende Empfehlung ist mir bewusst, ist aber keine Lösung
meines Problems, ich möchte ja gerade mit gleicher Funktionalität in
Linux und Windows arbeiten können. Als einziger Lösungsansatz bleibt
wohl nur, es als Bug zu melden.

Eine Frage in die Runde:

Gibt es eine Möglichkeit, diesen Diskussionthread direkt als Bug an
LibreOffice zu melden (mein Englisch ist nicht so gut, dass ich mir dies
in englisch zumuten will)?

Besten Dank und beste Grüße,

Peter


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Michael Höhne Michael Höhne
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

Hallo Peter

Du schriebst:

> Ich habe ein etwas abweichendes Erscheinungsbild, als
> Du, ich bekomme, wenn ich in Linux den Link in der Form smb://...
> manuell eingebe > keine Fehlermeldung, sondern dann wird dieser
> Eintrag korrekt gespeichert und funktioniert auch in Linux und in
> Windows (vielleicht liegt es daran, dass ich LinuxMint-MATE nutze?).

Nur zur Klarstellung: Die Fehlermeldung bekomme ich nur, wenn ich den
_unvollständigen_Pfad_ zur Datei angebe. Wenn ich den _kompletten_
Pfadnamen der Datei verwende, kann ich ebenfalls damit arbeiten.

Beispiel:

        a) Ich rufe "Einfügen/Hyperlink" auf

        b) Ich wähle als Ziel "Dokument" aus

        c) Im Feld Pfad klicke ich auf den Auswahlknopf

        d) Im sich öffnenden Dateiauswahlfenster aktiviere ich die
           Eingabe als Text (Knopf mit dem Stift) und tippe dort
           "smb://" ein

Wenn ich nun die Return-Taste betätige, zeigt der Dateiauswahldialog
oben (neben dem Knopf) als Pfad "Windows-Netzwerk" an. Darunter kann
ich die "Arbeitsgruppe" auswählen. Da ist u.a. der Eintrag "Workgroup"
zu sehen.

Wähle ich nun "Workgroup" mit einem Doppelklick aus, so erhalte ich
keine Liste der Computer in dieser Arbeitsgruppe, sondern die
Fehlermeldung:

        "Inhalt von WORKGROUP konnte nicht gelesen werden / kein Ordner"

Wiederhole ich dieses Vorgehen und gebe bei Schritt d) nun auch die
IP-Adresse ein: "smb://192.168.3.12", so erhalte ich die
erwartete Liste mit Freigaben meines NAS.

Wähle ich nun wieder mit Doppelklick eine der Freigaben aus, so
erhalte ich wieder die obige Fehlermeldung.

Gebe ich weitere Unterordner oder gar eine konkrete Datei vor, so
bekomme ich keine Fehlermeldung mehr, aber der Pfadname wird nicht
mehr übernommen.

Erst wenn ich den gesamten Pfadnamen in das Eingabefeld von LO
eintrage, kann ich einen Link setzen.  
               

> Und was mich "politisch" stört, dass man bei diesem Problem den
> Eindruck hat, dass Windows das bessere System ist.

Der Begriff "besser" ist sowohl richtig als auch falsch: Das
SMB-Protokoll ist halt in Windows ein integraler Bestandteil des OS,
während es in Linux eine Zusatzkomponente ist. Zudem gibt es unter
Windows nur einen integrierten Desktop, während Linux diverse
Desktop-Environments bietet.

Wer mit dieser Art von Bevormundung klar kommt, für den ist Windows
natürlich das "bessere" System. Wer hingegen eine gewisse Vielfalt
bevorzugt und "Herr im Hause" bleiben möchte, für den ist Linux die
bessere Wahl...

Ich gebe dir aber Recht: Wenn der Auswahldialog angeboten wird, sollte
er auch funktionieren.

Mir fiel auch noch ein, dass es früher(tm) eine Einstellung gab, ob man
die LO-Dialoge, oder die des Systems nutzen will. Die Hilfe dazu sagt:

> System-Dateidialoge oder LibreOffice Dialoge
> Unter den meisten Betriebssystemen können Sie wählen, ob Sie die
> Systemdialoge oder die LibreOffice Dialoge verwenden möchten.
> • Wählen Sie Extras - Optionen... - LibreOffice - Allgemein, um
>   den Typ der Dialoge Speichern und Öffnen festzulegen. Die
>   LibreOffice-Dialoge unterstützen das Laden und Speichern über eine
>   sichere https-Verbindung.

Leider ist der Menüpunkt dort nicht mehr zu finden! Aber mit dem Umweg
über die "Erweiterten Einstellungen" konnte ich die Einstellung
vornehmen: org.openoffice.Office.Common/Misc/UseSystemFileDialog
umstellen.

Leider änderte sich durch die Verwendung der LO-Dialoge das Verhalten
auch nicht.

Zuletzt habe ich eine virtuelle Win7-Maschine mit einer Gastfreigabe
verwendet, aber auch dort konnte ich den Dialog nicht verwenden!

> Deine abschließende Empfehlung ist mir bewusst, ist aber keine Lösung
> meines Problems, ich möchte ja gerade mit gleicher Funktionalität in
> Linux und Windows arbeiten können.

Ist klar. Man müsste ja auch einen Trick finden, mit dem man den Pfad
auf beiden Systemen gleich "gestalten" kann. Das ist aber nicht gerade
trivial umzusetzen...

Gruß,
Michael...

...der dir am kommenden WE gerne hilft, das ganze in englisch zu
beschreiben, sich aber jetzt erst einmal eine Woche ausklinken muss...

--
    ____        
   / / / / /__/      Michael Höhne /
  /   / / /  /  [hidden email] /
 ________________________________/


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Michael Höhne Michael Höhne
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

Am Sun, 13 Jan 2019 14:25:57 +0100
schrieb Michael Höhne <[hidden email]>:

Wieder unpräzise:

> Zuletzt habe ich eine virtuelle Win7-Maschine mit einer Gastfreigabe
> verwendet, aber auch dort konnte ich den Dialog nicht verwenden!

Der Widows-Rechner diente als SMB-Fileserver, also als Alternative zu
meinen QNAP-NAS, das ja ein Linux-OS hat.

Gruß,
Michael

--
    ____        
   / / / / /__/      Michael Höhne /
  /   / / /  /  [hidden email] /
 ________________________________/


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Peter,
>
> Gibt es eine Möglichkeit, diesen Diskussionthread direkt als Bug an
> LibreOffice zu melden (mein Englisch ist nicht so gut, dass ich mir dies
> in englisch zumuten will)?

Mit dem Diskussionsthread hättest Du das gleiche Problem: Der ist ja in
Deutsch.

Eine Bugmeldung muss so kurz und präzise wie möglich gehalten werden.
Einen Thread wird sich da niemand durchlesen.

Vielleicht hat dies ja etwas mit dem Bug zu tun:
https://bugs.documentfoundation.org/show_bug.cgi?id=119267

Gruß

Robert
--
Homepage: http://robert.familiegrosskopf.de
LibreOffice Community: http://robert.familiegrosskopf.de/map_3


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
WirBeide WirBeide
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Michael,
danke, alles, was Du schreibst, kann ich nur bestätigen und die Effekte,
die Du beschreibst sind genau die, um die es mir geht. Auch zu Deiner
vertieften Beschreibung zum "besseren BS" kann ich nur zustimmen.
Schade, dass dieser Teil ein eigener Thread wurde, weil ich
wahrscheinlich noch nicht ausreichend qualifiziert im Umgang mit dieser
Mailingliste bin (ich habe nur die Digest-Variante abonniert). Gibt es
vielleicht eine Möglichkeit, die beiden Threads zusammen zu führen? Mal
sehen, ob es bis zum nächsten Wochenende noch vorwärts geht, wenn nicht
komme ich gern auf Dein Angebot zurück. Und nochmals bis hierher erst
einmal besten Dank.
Beste Grüße,
Peter

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
WirBeide WirBeide
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Michael,
danke, alles, was Du schreibst, kann ich nur bestätigen und die Effekte,
die Du beschreibst sind genau die, um die es mir geht. Auch zu Deiner
vertieften Beschreibung zum "besseren BS" kann ich nur zustimmen. Mal
sehen, ob es bis zum nächsten Wochenende noch vorwärts geht, wenn nicht
komme ich gern auf Dein Angebot zurück. Und nochmals bis hierher erst
einmal besten Dank.
Beste Grüße,
Peter

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy
WirBeide WirBeide
Reply | Threaded
Open this post in threaded view
|

Re: <Link lässt sich bei Nutzung eines NAS als Fileserver nicht erzeugen>

In reply to this post by WirBeide
Hallo Robert,
auch Dir danke für Deine Hinweise. Den Link habe ich mir mal angesehen
und wenn man auch auf den ersten Eindruck auf die Idee kommen kann, dass
es hier vielleicht einen Zusammenhang geben könnte, so kann ich es
wirklich erst endgültig beurteilen, wenn man Informationen hat, wie
beide Probleme gelöst wurden. Aktuell neige ich eher dazu dass es 2
verschiedene Probleme sind, denn wir (ich beziehe hier mal die von
Michael gelieferten Informationen mit ein)können ja problemlos mit dem
Server verbinden und auch wenn wir die Datei mit smb://... manuell
eintragen funktioniert alles so, wie erwartet. Wir wünschen uns ja
eigentlich "nur" eine Option für die Linux-LibreOffice-Version (oder
einen Automatismus), dass wir dies nicht manuell vornehmen müssen, sind
uns aber bewusst, dass dies als Programmieraufgabe eine gewisse
Herausforderung darstellt. In der Windows-Version ist solch eine
Funktion nicht erforderlich. Vielleicht ist diese Option bisher einfach
"vergessen" oder bisher nicht mit entsprechender Priorisierung umgesetzt
worden. Mit Michael bin ich mir einig, dass dies eine wünschenswerte
Option in der Linux-LibreOffice-Version wäre.
Besten Dank und besten Gruß,
Peter


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? https://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: https://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: https://listarchives.libreoffice.org/de/users/
Datenschutzerklärung: https://www.documentfoundation.org/privacy