Re: minutes of ESC call ...

classic Classic list List threaded Threaded
5 messages Options
Xisco Fauli Xisco Fauli
Reply | Threaded
Open this post in threaded view
|

Re: minutes of ESC call ...

Hello


El 15/09/16 a les 17:06, Michael Meeks ha escrit:

>     + Keywords - what is their meaning ?
>
>       + NeedsDevEval vs. needAdvise
>
>       + used randomly apparently.
>
>         => prefer needsDevEval
>
>       => replace all needAdvise -> needsDevEval.
>
> || ||
>
> ||    + UNCONFIRMED: 813||
>
>          + up 100 over the last two weeks.
>
> ||        + enhancements: 90||
>
> ||        + needsUXEval: 52||
>
> ||    + needsDevEval at 73||
>
> || ||
>
>      + needsDevEval - looking at (JanI)
>
>          + if not an easy-hack, and multiple ways to solve a problem.
>
>          + needs a core dev to say: "this problem should be solved in XYZ
> place"
>
>          + easy hacks shouldn't contain needsDevEval ? (Xisco)
>
>              + if missing code pointers, set to NEEDINFO
>
>              + ping people to provide pointers on NEEDINFOs (JanI

After the meeting, Jan, Beluga and I had a long conversation in IRC with
regards to needAdvise/needsDevEval keywords and we arrive to the
following conclusions:

     - needAdvise: Used when help from developers in needed to confirm
an UNCONFIRMED bug. Info:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Keywords#needAdvice.
         * Problem 1: Name is confusing.
             + Action: Rename it to 'needsConfirmationAdvise'
         * Problem 2: No New or resolved bugs should use it.
             + Action: Clean it up and create a new gardening task.

     - needsDevEval: Should be used when a plausible easyhack lacks the
code pointer, the difficulty, the topic or the skill and a developer
needs to provide the information missing.
         * Problem 1: It has been used to propose easyhacks over the
last months.
             + Action: Update the wiki accordingly:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Keywords#needsDevEval 
and
https://wiki.documentfoundation.org/Development/EasyHacks/Creating_a_new_Easy_Hack

         * Problem 2: Name is confusing.
             + Action: Rename it to 'needsEasyHackValidation'

         * Problem 3: The combination of NEEDINFO + easyhack has been
used instead. NEEDINFO should only be used when feedback from the bug
reporters is needed.
             + Action: Change all NEEDINFO + easyhack to
'needsEasyHackValidation'

         * Problem 4: 476 bugs use the keyword 'needsDevEval' nowadays.
             + Action: Evaluate one by one to see whether they're
actually an easyhack or not. If so, change 'needsDevEval' keyword to
'easyhack' and if possible, add the topic, code pointer, skill and
difficulty. Adding Jan as CC helps too. In case the topic, the code
pointer, the skill or the difficulty couldn't be provided for lack of
knowledge, Jan could help on that as he's monitoring all easyhacks. If
he couldn't, then the 'needsEasyHackValidation' keyword should be used.

NOTE: In order to propose new easyhacks, the same procedure as in
Problem 4 should be followed.

Feel free to ask if you have any question.

Regards

--
Xisco Faulí
Libreoffice QA Team

_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: https://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
Adolfo Jayme Barrientos-3 Adolfo Jayme Barrientos-3
Reply | Threaded
Open this post in threaded view
|

Re: minutes of ESC call ...

El dia 19/09/2016 5:43 a. m., "Xisco Fauli" <[hidden email]> va escriure:
[…]
>         * Problem 2: Name is confusing.
>             + Action: Rename it to 'needsEasyHackValidation'

Curiously, this keyword’s first name was “proposedEasyHack”, which at some point was found “confusing” by someone. I just find it a bit funny that a similar name is being proposed now… ;-)


_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: https://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
jan iversen jan iversen
Reply | Threaded
Open this post in threaded view
|

Re: minutes of ESC call ...

Curiously, this keyword’s first name was “proposedEasyHack”, which at some point was found “confusing” by someone. I just find it a bit funny that a similar name is being proposed now… ;-)


I too found needsEasyhackEvaluation a bit curious.

But I have to admit that the current use:
    keyword=easyhack and status=NEEDINFO
is not the best way to do it.

So adding a keyword seemed as a sensible option, I preferred just to keep keyword=needsDevEval, since that can be used independent of easy hack, but I leave that decision to the QA team.

the renaming of keyword=needAdvice to keyword=needsConfirmationAdvice is a bit strange to me. If a bug is not confirmed, it has status=UNCONFIRMED, so I am unsure why we keep needAdvice/needsConfirmationAdvice

We should be careful not to have too many keywords, and especially not to make workflows into changing keywords. 

rgds
jan I


_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: https://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
Xisco Fauli Xisco Fauli
Reply | Threaded
Open this post in threaded view
|

Re: minutes of ESC call ...

Hello Jan,


El 20/09/16 a les 10:30, Jan Iversen ha escrit:

>>
>> Curiously, this keyword’s first name was “proposedEasyHack”, which at
>> some point was found “confusing” by someone. I just find it a bit
>> funny that a similar name is being proposed now… ;-)
>>
>
> I too found needsEasyhackEvaluation a bit curious.
>
> But I have to admit that the current use:
>     keyword=easyhack and status=NEEDINFO
> is not the best way to do it.
>
> So adding a keyword seemed as a sensible option, I preferred just to
> keep keyword=needsDevEval, since that can be used independent of easy
> hack, but I leave that decision to the QA team.
“proposedEasyHack” was confusing at the time whitewords were used as the
search engine didn't work well with ie. 'proposedEasyHack' and
'easyhack'. However, now we use keywords and it works differently as the
number of keywords is fixed and it searches for the entire word.

The point of changing the word to 'needsEasyHackValidation' is to limit
its use to only easyhacks. 'needsDevEval' is too general and could be
use in order cases where we don't want contributors to use it.
>
> the renaming of keyword=needAdvice to keyword=needsConfirmationAdvice
> is a bit strange to me. If a bug is not confirmed, it has
> status=UNCONFIRMED, so I am unsure why we keep
> needAdvice/needsConfirmationAdvice
>
> We should be careful not to have too many keywords, and especially not
> to make workflows into changing keywords.
Same here. According to the wiki, 'needAdvice' is meant to used for
unconfirmed bugs which need help from a developer in order to get
confirmed. Thus, using 'needsConfirmationAdvice' we limit its use to
just that, avoiding contributors to use it somewhere else.

Regards

--
Xisco Faulí
Libreoffice QA Team

_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: https://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/
jan iversen jan iversen
Reply | Threaded
Open this post in threaded view
|

Re: minutes of ESC call ...


> The point of changing the word to 'needsEasyHackValidation' is to limit its use to only easyhacks. 'needsDevEval' is too general and could be use in order cases where we don't want contributors to use it.
Well you reach out to the same group of people, to do the same thing….provide advice, like code pointers, implementation advice, etc.

I still do no see the difference of “needsDevEval” on a non-easyHack to “needsDevEval” on a easy hack.

It seems with the proposed solution I can end up with keywords=“easyHack,needsDevEval,needsEasyHackValidation” for a bug where the following info is needed
- code pointer (needsEasyHackValidation)
- How to best implement it (needsDevEval)

Seems a but over the top, considering that most likely the same developer will provide both.



> Same here. According to the wiki, 'needAdvice' is meant to used for unconfirmed bugs which need help from a developer in order to get confirmed. Thus, using 'needsConfirmationAdvice' we limit its use to just that, avoiding contributors to use it somewhere else.

Well you could use “needsDevEval” since it again is asking the same people for the same information.

rgds
jan I

Ps. I am all for changing “status=NEEDINFO,keyword=easyHack”, but I prefer not to make things more complicated than they already are.

_______________________________________________
List Name: Libreoffice-qa mailing list
Mail address: [hidden email]
Change settings: https://lists.freedesktop.org/mailman/listinfo/libreoffice-qa
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://lists.freedesktop.org/archives/libreoffice-qa/