Return of the bug? ;-) Bug 61522 gefixt und wieder broken

classic Classic list List threaded Threaded
14 messages Options
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Return of the bug? ;-) Bug 61522 gefixt und wieder broken

Servus,

ich stolpere gerade darüber, dass ich in einem Writer-Dokument ein
Eingabefeld nicht per Klick öffnen kann. Und zwar klappt es zwar mit
LO 4.1.6.2, nicht aber mit 4.2.5.2 und auch nicht mit 4.3.0.2

Die Erscheinung deckt sich mit der Beschreibung in einem alten Bug:

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=61522

Der sollte aber schon in 4.0.2 und 4.1.0 gefixt sein.

Kann das mal jemand bitte gegenchecken? Einfach mal mit dem
Beispieldokument, das am Bug hängt ausprobieren.

Danke und Gruß,

Stefan

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Robert Großkopf Robert Großkopf
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

Hallo Stefan,
>
> ich stolpere gerade darüber, dass ich in einem Writer-Dokument ein
> Eingabefeld nicht per Klick öffnen kann. Und zwar klappt es zwar mit
> LO 4.1.6.2, nicht aber mit 4.2.5.2 und auch nicht mit 4.3.0.2

Das Verhalten der Eingabefelder hat sich geändert. Du klickst auf das
Feld. Das Feld erhält eine Umrandung, in der auch der Cursor steht. Du
schreibst den neuen Text rein.
Es erscheint kein Fenster mehr.
Ob das sinnvoll ist steht auf einem anderen Blatt.

Gruß

Robert

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
user user
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ; -) Bug 61522 gefixt und wieder broken

In reply to this post by Stefan Weigel
  Also wenn "öffnen" heisst, das der Cursor im Feld aktiv wird und ich
was reinschreiben kann, das klappt bei mir problemlos mit

Win Vista (32bit)
LibreOffice 4.2.5. portable
OpenOffice 4.1


Gruß,

Kalle H.


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Robert Großkopf
Hallo Robert,

Am 15.07.2014 20:30, schrieb Robert Großkopf:

>> ich stolpere gerade darüber, dass ich in einem Writer-Dokument ein
>> Eingabefeld nicht per Klick öffnen kann. Und zwar klappt es zwar mit
>> LO 4.1.6.2, nicht aber mit 4.2.5.2 und auch nicht mit 4.3.0.2

> Das Verhalten der Eingabefelder hat sich geändert. Du klickst auf das
> Feld. Das Feld erhält eine Umrandung, in der auch der Cursor steht. Du
> schreibst den neuen Text rein.
> Es erscheint kein Fenster mehr.

Ok. Aber: Buuuh. :-)

Und: Doch das Fenster gibt es noch!

Magst du mal bitte das Verhalten dieses Beispiels mit LO 4.5.2 ansehen?
http://www.biggi.de/Beispiel.ott

Beim Öffnen erscheint für jedes Eingabefeld (das von früher
gewohnte) Popup-Fenster.

Danach verhalten sich die ersten beiden Eingabefelder beim
Anklicken, wie von früher gewohnt mit einem Popup-Fenster. Die
beiden anderen Eingabefelder verhalten sich, wie von Dir als neues
Verhalten beschrieben. Ich kann mir nicht vorstellen, dass diese
Inkonsitenz von uns beabsichtigt ist. ;-)

Ein weiteres Problem bei den Feldern mit dem neuen Verhalten ist,
dass wenn man deren Inhalt löscht, dass es dann nicht mehr gelingt,
den Cursor hineinzusetzen, um wieder etwas einzutragen.

(Der Unterschied im Hintergrund ist: Die ersten beiden Felder haben
eine Referenz auf eine Variable im Dokument, die anderen beiden nicht.)

In der Version 4.1.6 verhalten sich alle vier Felder noch identisch
auf die alte gewohnte Weise und ohne Probleme.

Gruß,
Stefan






--
LibreOffice - Die Freiheit nehm' ich mir!

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Stefan Weigel
Hallo,

Am 15.07.2014 20:15, schrieb Stefan Weigel:

> ich stolpere gerade darüber, dass ich in einem Writer-Dokument ein
> Eingabefeld nicht per Klick öffnen kann. Und zwar klappt es zwar mit
> LO 4.1.6.2, nicht aber mit 4.2.5.2 und auch nicht mit 4.3.0.2

Mag das vielleicht doch nochmal jemand gegenchecken?

Ein Beispieldokument wäre hier:
http://www.biggi.de/Beispiel.ott

Es enthält vier Eingabefelder. Die ersten beiden Felder haben
eine Referenz auf eine Variable im Dokument, die anderen beiden
nicht. Und offenbar neuerdings abhängig davon, verhalten sich die
Eingabefelder völlig unterschiedlich.

Zunächst, beim Öffnen des Dokuments, erscheint für jedes Eingabefeld
automatisch (das von früher gewohnte) Popup-Fenster zur Eingabe des
Wertes. Dann, bei der weiteren Benutzung des Dokuments verhalten
sich die Eingabefelder aber neuerdings uneinheitlich.

Die ersten beiden Eingabefelder kann man anklicken und es öffnet
sich ein Popup-Fenster zur Eingabe des Wertes.

Wenn man die beiden anderen Eingabefelder anklickt, blinkt in diesen
der Cursor und man kann den Wert direkt eintippen. Wenn diese Felder
aber leer sind, also keinen Wert enthalten, dann gelingt es nicht
mehr, den Cursor dort hinein zu setzen, um wieder einen Wert
einzutragen.

Ein weiteres Problem besteht, wenn man sich mit Strg+F9 die
Feldnamen im Dokument anzeigen lassen will. Bei den ersten beiden
Feldern funktioniert das nach wie vor einwandfrei. Bei den beiden
anderen Feldern funktioniert das mit jüngeren LO-Versionen nicht
mehr. Es werden die Feldnamen nicht angezeigt.

Ich habe hier eine Anwendung in einer Behörde, die durch das Upgrade
von LO 4.1.6 auf LO 4.2.5 nun etliche Dokumente nicht mehr nutzen
kann. :-/

Bestätigung, Kommentare, Tipps etc. willkommen. ;-)

Gruß,
Stefan

--
LibreOffice - Die Freiheit nehm' ich mir!

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Regina Henschel Regina Henschel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

Hallo Stefan,

Stefan Weigel schrieb:
> Hallo,
>
> Am 15.07.2014 20:15, schrieb Stefan Weigel:
>
[..]
>
> Wenn man die beiden anderen Eingabefelder anklickt, blinkt in diesen
> der Cursor und man kann den Wert direkt eintippen. Wenn diese Felder
> aber leer sind, also keinen Wert enthalten, dann gelingt es nicht
> mehr, den Cursor dort hinein zu setzen, um wieder einen Wert
> einzutragen.

Schreibe dazu bitte einen Bug-Report auf dem AOO Bugzilla
https://issues.apache.org/ooo/ Das Feature wurde bei AOO entwickelt.

>
> Ein weiteres Problem besteht, wenn man sich mit Strg+F9 die
> Feldnamen im Dokument anzeigen lassen will. Bei den ersten beiden
> Feldern funktioniert das nach wie vor einwandfrei. Bei den beiden
> anderen Feldern funktioniert das mit jüngeren LO-Versionen nicht
> mehr. Es werden die Feldnamen nicht angezeigt.

Soweit ich sehe, haben diese keinen Feldnamen, aber der Typ sollte
trotzdem angezeigt werden.

Daher bitte einen weiteren Bug-Report.

>
> Ich habe hier eine Anwendung in einer Behörde, die durch das Upgrade
> von LO 4.1.6 auf LO 4.2.5 nun etliche Dokumente nicht mehr nutzen
> kann. :-/
>
> Bestätigung, Kommentare, Tipps etc. willkommen. ;-)
>

Fehler kann ich bestätigen. Solange noch in irgendeinem der Input-Felder
(die ohne user variable) etwas steht, kann man sich im readonly Modus
mit der Tab-Taste weiterhangeln. Ist natürlich kein Zustand.

Weise in deinem Bug-Report darauf hin, dass solche Formula in Behörden
benutzt werden.

Mit freudlichen Grüßen
Regina

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
user user
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ; -) Bug 61522 gefixt und wieder broken

In reply to this post by Stefan Weigel
Die oben beiden Felder öffnen beim Anklicken ein Eingabefeld, die unten
beiden Felder nicht, bei ihnen wird einfach der Cursor im Feld aktiviert
und man kann direkt reinschreiben.

Getestet mit LibreOffice 4.2.5 (portable) und Apache OpenOffice 4.1
unter Windows Vista (32-bit)


Gruß,

Kalle H.


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Regina Henschel

Hallo Regina,

Am 19.07.2014 13:09, schrieb Regina Henschel:
> Schreibe dazu bitte einen Bug-Report auf dem AOO Bugzilla
> https://issues.apache.org/ooo/ Das Feature wurde bei AOO entwickelt.

Dort würde man aber zurecht erwarten, dass ich das Problem mit
Apache OpenOffice beschreibe und angebe, in welcher AOO-Version ich
den Bug festgestellt habe und bis zu welcher AOO-Version es noch
funktioniert hat und so weiter. Ich habe aber kein AOO und will es
auch nicht haben. ;-)

Wäre es denn absolut nicht zielführend, den Bug bei LO aufzugeben?

Gruß,
Stefan

--
LibreOffice - Die Freiheit nehm' ich mir!

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Michael Höhne Michael Höhne
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

Hallo Stefan,

> Dort würde man aber zurecht erwarten, dass ich das Problem mit
> Apache OpenOffice beschreibe und angebe, in welcher AOO-Version ich
> den Bug festgestellt habe und bis zu welcher AOO-Version es noch
> funktioniert hat und so weiter. Ich habe aber kein AOO und will es
> auch nicht haben. ;-)

Würde sich für dich auch nicht lohnen: Der Fehler tritt sowohl bei AOO
4.1 als auch bei LO 4.2.5 auf (jeweils Originalversion unter XUbuntu
14.04) ;-)

Gruß,
Michael

--
    ____        
   / / / / /__/      Michael Höhne /
  /   / / /  /  [hidden email] /
 ________________________________/


--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Regina Henschel Regina Henschel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Stefan Weigel
Hallo Stefan,

Stefan Weigel schrieb:

>
> Hallo Regina,
>
> Am 19.07.2014 13:09, schrieb Regina Henschel:
>> Schreibe dazu bitte einen Bug-Report auf dem AOO Bugzilla
>> https://issues.apache.org/ooo/ Das Feature wurde bei AOO entwickelt.
>
> Dort würde man aber zurecht erwarten, dass ich das Problem mit
> Apache OpenOffice beschreibe und angebe, in welcher AOO-Version ich
> den Bug festgestellt habe und bis zu welcher AOO-Version es noch
> funktioniert hat und so weiter. Ich habe aber kein AOO und will es
> auch nicht haben. ;-)

Ja beide beobachten ist aufwändig.

>
> Wäre es denn absolut nicht zielführend, den Bug bei LO aufzugeben?

Bei einem neuen Feature denke ich dass es passend ist, wenn der
ursprüngliche Entwickler sich drum kümmert, hier also Oliver-Rainer
Wittmann. Aber dass du kein AOO installiert hast, ist natürlich ein
Argument. Ich werde die Reports für AOO also selbst schreiben.

Mit freundlichen Grüßen
Regina

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken


Am 19.07.2014 14:35, schrieb Regina Henschel:
> Aber dass du kein AOO installiert hast, ist natürlich ein
> Argument. Ich werde die Reports für AOO also selbst schreiben.

Großer Dank dafür!

:-)

Stefan

--
LibreOffice - Die Freiheit nehm' ich mir!

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Stefan Weigel Stefan Weigel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Michael Höhne
Hi nochmal,

Am 19.07.2014 14:16, schrieb Michael Höhne:

> Der Fehler tritt sowohl bei AOO
> 4.1 als auch bei LO 4.2.5 auf (jeweils Originalversion unter XUbuntu
> 14.04) ;-)

Ist es bei AOO auch so, dass sich die Eingabefelder beim Anklicken
unterschiedlich verhalten, je nachdem, ob sie an eine Variable im
Dokument gebunden sind? (Im Beispiel regieren die ersten beiden
Felder mit einem Popup-Dialog für die Werteingabe, die anderen
beiden nicht.)

Und ist es bei AOO auch so, dass beim Öffnen des Dokuments von der
Vorlage für *alle* Felder sehr wohl der altgewohnte Popup-Dialog
erscheint?

Gruß,
Stefan


--
LibreOffice - Die Freiheit nehm' ich mir!

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Regina Henschel Regina Henschel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

Hallo Stefan,

Stefan Weigel schrieb:
> Hi nochmal,
>
> Am 19.07.2014 14:16, schrieb Michael Höhne:
>
>> Der Fehler tritt sowohl bei AOO
>> 4.1 als auch bei LO 4.2.5 auf (jeweils Originalversion unter XUbuntu
>> 14.04) ;-)

Das gesamte Feature ist in
https://wiki.openoffice.org/wiki/Writer/Input_Fields beschrieben. Nur
der Doppelklick fehlt in der Beschreibung.

>
> Ist es bei AOO auch so, dass sich die Eingabefelder beim Anklicken
> unterschiedlich verhalten, je nachdem, ob sie an eine Variable im
> Dokument gebunden sind? (Im Beispiel regieren die ersten beiden
> Felder mit einem Popup-Dialog für die Werteingabe, die anderen
> beiden nicht.)

Nein, die Felder verhalten sich gleich. Und das Verhalten ist
differenzierter als in LO. In AOO aktiviert ein Einfachklick das Feld
so, dass der gesamte Inhalt markiert und daher durch eine Eingabe
ersetzt wird. Mit einem weitere Einfachklick wird die Gesamtmarkierung
aufgehoben und der Cursor steht dann im Feld, so dass man innerhalb des
schon vorhandenen Textes etwas ändern kann. Mit einem Doppelklick öffnet
der Dialog, den man sonst unter Bearbeiten > Felder erhalten hat.

>
> Und ist es bei AOO auch so, dass beim Öffnen des Dokuments von der
> Vorlage für *alle* Felder sehr wohl der altgewohnte Popup-Dialog
> erscheint?

Ja, beim Erstellen aus einer Dokumentvorlage werden die Felder jeweils
mit einem Popup-Dialog gefüllt. Ich weiß nicht, ob dies beabsichtigt ist
oder ob dieser Anwendungsfall vergessen wurde.

Mit freundlichen Grüßen
Regina

--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert
Regina Henschel Regina Henschel
Reply | Threaded
Open this post in threaded view
|

Re: Return of the bug? ;-) Bug 61522 gefixt und wieder broken

In reply to this post by Stefan Weigel
Hallo Stefan,

Stefan Weigel schrieb:

> Hi nochmal,
>
> Am 19.07.2014 14:16, schrieb Michael Höhne:
>
>> Der Fehler tritt sowohl bei AOO
>> 4.1 als auch bei LO 4.2.5 auf (jeweils Originalversion unter XUbuntu
>> 14.04) ;-)
>
> Ist es bei AOO auch so, dass sich die Eingabefelder beim Anklicken
> unterschiedlich verhalten, je nachdem, ob sie an eine Variable im
> Dokument gebunden sind? (Im Beispiel regieren die ersten beiden
> Felder mit einem Popup-Dialog für die Werteingabe, die anderen
> beiden nicht.)
>

Eine Korrektur: In der von dir angegebenen Dokumentvorlage gehören die
ersten beiden Eingabefelder zur Sorte "simple variable". Es sind
Variablen, die man oben im Dialog auswählt, und die im Dokumentverlauf
unterschiedliche Werte annehmen können. Solche Variablen sind nicht von
der Änderung betroffen, sondern verhalten sich wie vorher auch.
Allerdings kann man diese Variablen auch nicht im read-only Modus des
Dokuments benutzen, sie sind daher eigentlich für Formulare ungeeignet.

Ich meinte in meiner vorigen Mail die "user variable", die man unten im
Dialog setzt. Bei denen erscheint bei AOO und -wie ich gerade
festgestellt habe- auch bei LO kein Dialog und diese Felder sind auch
für Formulare im readonly Modus geeignet.

Mit freundlichen Grüßen
Regina



--
Liste abmelden mit E-Mail an: [hidden email]
Probleme? http://de.libreoffice.org/hilfe-kontakt/mailing-listen/abmeldung-liste/
Tipps zu Listenmails: http://wiki.documentfoundation.org/Netiquette/de
Listenarchiv: http://listarchives.libreoffice.org/de/discuss/
Alle E-Mails an diese Liste werden unlöschbar öffentlich archiviert