SVGファイルがうまく表示されない

classic Classic list List threaded Threaded
6 messages Options
User Ribbon User Ribbon
Reply | Threaded
Open this post in threaded view
|

SVGファイルがうまく表示されない

LibreOffice 3.5.0 でSVGファイルがうまく表示されない現象が出ています。

OS: Windows7

うまく表示されないファイル
http://openclipart.org/detail/32443/network-card-by-jasonfilley

一度ギャラリーにSVGファイルを引き込み、その後 impress/draw の
描画画面にコピーします。まず、ギャラリーに引き込む時点で、
ギャラリーの表示が変(カード部分が見えない)になります。
描画画面では正常に表示されているように見えるのですが、
この図形を縮小すると、カード部分(緑の部分)が見えなくなります。

OS: OpenSUSE 11.3のLibre Office 3.4.2 でやってみると、
こちらは正常に縮小が出来ますし、ギャラリーの表示も問題ありません。

では、別の図形ではどうか、というと、特に問題なく出来るのですね。
この図形だけ変な動作をします。

この図形の情報が変なのでしょうか?

oota

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted

jmeguro jmeguro
Reply | Threaded
Open this post in threaded view
|

Re: [ja-users] SVGファイルがうまく表示されない

目黒です。


問題のファイルをデスクトップにDL後、Drawのファイル>開く から直接開いてみましたが、特に問題は無いようです。

> 一度ギャラリーにSVGファイルを引き込み
という部分は実際にはどのような操作を行っているのでしょうか?

ちなみに検証環境は
 Ver:LibreOffice3.5.0RC1
 OS:Mint
です。

2012年3月10日22:03 ribbon <[hidden email]>:

> LibreOffice 3.5.0 でSVGファイルがうまく表示されない現象が出ています。
>
> OS: Windows7
>
> うまく表示されないファイル
> http://openclipart.org/detail/32443/network-card-by-jasonfilley
>
> 一度ギャラリーにSVGファイルを引き込み、その後 impress/draw の
> 描画画面にコピーします。まず、ギャラリーに引き込む時点で、
> ギャラリーの表示が変(カード部分が見えない)になります。
> 描画画面では正常に表示されているように見えるのですが、
> この図形を縮小すると、カード部分(緑の部分)が見えなくなります。
>
> OS: OpenSUSE 11.3のLibre Office 3.4.2 でやってみると、
> こちらは正常に縮小が出来ますし、ギャラリーの表示も問題ありません。
>
> では、別の図形ではどうか、というと、特に問題なく出来るのですね。
> この図形だけ変な動作をします。
>
> この図形の情報が変なのでしょうか?
>
> oota
>
> --
> Unsubscribe instructions: E-mail to [hidden email]
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/ja/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted
User Ribbon User Ribbon
Reply | Threaded
Open this post in threaded view
|

Re: SVGファイルがうまく表示されない

On Sat, Mar 10, 2012 at 10:33:56PM +0900, jun meguro wrote:
>
> > 一度ギャラリーにSVGファイルを引き込み
> という部分は実際にはどのような操作を行っているのでしょうか?

1) impressを起動し、新しい(白紙の)スライドを作ります。
2) ツール->ギャラリー でギャラリーを表示させます。
3) 独自のテーマをクリックし選択します。
4) 右クリックしてプロパティを開きます。
5) ファイルタブを選択し、追加 を選びます。
6) ファイル一覧が表示されるので、追加したいファイル(network_card.svg)を指定します。
7) 開くを選び、ギャラリーに引き込みます。

この時点で、ギャラリーに当該SVGファイルが入りますが、すでにこの時点で、ギャラリーの
一覧表示がおかしくなっています。

>  Ver:LibreOffice3.5.0RC1

は同じでした。今最終バージョンをダウンロードし、これからテストしてみます。

oota

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted

User Ribbon User Ribbon
Reply | Threaded
Open this post in threaded view
|

Re: SVGファイルがうまく表示されない

On Sun, Mar 11, 2012 at 08:09:51AM +0900, ribbon wrote:
> 一覧表示がおかしくなっています。
>
> >  Ver:LibreOffice3.5.0RC1
>
> は同じでした。今最終バージョンをダウンロードし、これからテストしてみます。

3.5.0 リリース版でも変化はありませんでした。

oota

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tomofumi Yagi Tomofumi Yagi
Reply | Threaded
Open this post in threaded view
|

Re: SVGファイルがうまく表示されない

In reply to this post by User Ribbon
八木 です。

私の環境では、画像に適用されているフィルタを除去しておけば、ギャラリーの
一覧表示が期待通りに動作しました(SVG ファイルを編集可能なソフトで、
network_card.svg を事前に編集しておく)。

LibreOffice 3.5.1 RC2(32ビット Windows 7上) で試しました。

追伸:フィルタ feGaussianBlur の stdDeviation の値が小さいと、
  表示がおかしくなるような気がします。バグだと思います。

(12/03/11 8:09), ribbon wrote:

> On Sat, Mar 10, 2012 at 10:33:56PM +0900, jun meguro wrote:
>>> 一度ギャラリーにSVGファイルを引き込み
>> という部分は実際にはどのような操作を行っているのでしょうか?
> 1) impressを起動し、新しい(白紙の)スライドを作ります。
> 2) ツール->ギャラリー でギャラリーを表示させます。
> 3) 独自のテーマをクリックし選択します。
> 4) 右クリックしてプロパティを開きます。
> 5) ファイルタブを選択し、追加 を選びます。
> 6) ファイル一覧が表示されるので、追加したいファイル(network_card.svg)を指定します。
> 7) 開くを選び、ギャラリーに引き込みます。
>
> この時点で、ギャラリーに当該SVGファイルが入りますが、すでにこの時点で、ギャラリーの
> 一覧表示がおかしくなっています。
>
>>  Ver:LibreOffice3.5.0RC1
> は同じでした。今最終バージョンをダウンロードし、これからテストしてみます。
>
> oota
>



--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted

User Ribbon User Ribbon
Reply | Threaded
Open this post in threaded view
|

Re: SVGファイルがうまく表示されない

On Sun, Mar 11, 2012 at 11:07:39PM +0900, Tomofumi Yagi wrote:

> 私の環境では、画像に適用されているフィルタを除去しておけば、ギャラリーの
> 一覧表示が期待通りに動作しました(SVG ファイルを編集可能なソフトで、
> network_card.svg を事前に編集しておく)。

Libre Office の draw ではどうやってフィルタをいじったらいいか
わからなかったので、inkscapeを使ってみました。
inkscapeのフィルタメニューを使い、フィルタを全部外して、
再度やってみたら、確かに問題なく処理できました。
Libre Office 3.5.0rc3で確認しました。

> LibreOffice 3.5.1 RC2(32ビット Windows 7上) で試しました。
>
> 追伸:フィルタ feGaussianBlur の stdDeviation の値が小さいと、
>   表示がおかしくなるような気がします。バグだと思います。

そうですね。フィルタがあるとおかしくなることと、3.4.xでは
うまくいっているように見えるので、3.5.xでのバグではないかと
思います。
英語でレポートが書けたら、バグ報告してみます。

oota

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/ja/users/
All messages sent to this list will be publicly archived and cannot be deleted