Update to 3.6.1

classic Classic list List threaded Threaded
31 messages Options
Next » 12
Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Update to 3.6.1

I've just updated to LibO 3.6.1 and hit the following problem when
trying to access my address book

Does anyone recognise it, Google doesn't?
___________________________________________________________________________
The attempt to load the file resulted in the following error message
(com.sun.star.lang.IllegalArgumentException):

Unsupported URL <file:///home/phb/..../AddressBook.ods>
___________________________________________________________________________

Ubuntu 12.04 64 bit
Java 1.7_06 (and 05)

All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
carried out by complete removal of 3.6.0 via Synaptic and clean
installation of the "real" product, downloaded from the LibreOffice web
site via dpkg -iR

Thanks for any helpful response.

Peter HB


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

On 29/08/12 16:03, Peter Hillier-Brook wrote:

> I've just updated to LibO 3.6.1 and hit the following problem when
> trying to access my address book
>
> Does anyone recognise it, Google doesn't?
> ___________________________________________________________________________
> The attempt to load the file resulted in the following error message
> (com.sun.star.lang.IllegalArgumentException):
>
> Unsupported URL <file:///home/phb/..../AddressBook.ods>
> ___________________________________________________________________________
>
> Ubuntu 12.04 64 bit
> Java 1.7_06 (and 05)
>
> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
> carried out by complete removal of 3.6.0 via Synaptic and clean
> installation of the "real" product, downloaded from the LibreOffice web
> site via dpkg -iR

Interestingly everything is fine on a 32 bit installation!


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

Hi :)
Errr, on the 64bit Ubuntu is the java also 64bit?  If it is then can you try installing a 32 bit version of 1.6_32?  LO can be told which version of java to use so it might work
Tools - Options - Java 
Regards from
Tom :) 


--- On Wed, 29/8/12, Peter Hillier-Brook <[hidden email]> wrote:

From: Peter Hillier-Brook <[hidden email]>
Subject: Re: [libreoffice-users] Update to 3.6.1
To: [hidden email]
Date: Wednesday, 29 August, 2012, 17:55

On 29/08/12 16:03, Peter Hillier-Brook wrote:

> I've just updated to LibO 3.6.1 and hit the following problem when
> trying to access my address book
>
> Does anyone recognise it, Google doesn't?
> ___________________________________________________________________________
> The attempt to load the file resulted in the following error message
> (com.sun.star.lang.IllegalArgumentException):
>
> Unsupported URL <file:///home/phb/..../AddressBook.ods>
> ___________________________________________________________________________
>
> Ubuntu 12.04 64 bit
> Java 1.7_06 (and 05)
>
> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
> carried out by complete removal of 3.6.0 via Synaptic and clean
> installation of the "real" product, downloaded from the LibreOffice web
> site via dpkg -iR

Interestingly everything is fine on a 32 bit installation!


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Andreas Säger Andreas Säger
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Peter Hillier-Brook
Am 29.08.2012 18:55, Peter Hillier-Brook wrote:

> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>> I've just updated to LibO 3.6.1 and hit the following problem when
>> trying to access my address book
>>
>> Does anyone recognise it, Google doesn't?
>> ___________________________________________________________________________
>>
>> The attempt to load the file resulted in the following error message
>> (com.sun.star.lang.IllegalArgumentException):
>>
>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>> ___________________________________________________________________________
>>
>>
>> Ubuntu 12.04 64 bit
>> Java 1.7_06 (and 05)
>>
>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>> carried out by complete removal of 3.6.0 via Synaptic and clean
>> installation of the "real" product, downloaded from the LibreOffice web
>> site via dpkg -iR
>
> Interestingly everything is fine on a 32 bit installation!
>
>

Hi,
Since many years I use to update my office suites without removal. All
major versions (OOo 1 and 2, LibO and OOo 3) are separate applications
with separated profile folders anyway.
Any problems (if any) are related to the user profile which can be reset
by renaming a folder. Within the profile issues, the installed
extensions are the major culprit (but not the ones I use to have
installed). So I extract the downloaded archive, change to the extracted
directory/DEBS and run
sudo dpkg -i *.deb
If I want that version to be the default program with menu and
everything I change to the desktop-integration subdirectory and install
that package too.
If I do not want that version to be the default program I add a couple
of my own desktop links to the respective executables. There were times
when I had OOo 1.1.5, 2.4.3, 3.4beta, LibO 3.3 and 3.5.x installed in
parallel without any problem.

Problems that come up quite frequently on this list are not the normal
case. It is designed to be update out of the box, particularly on Linux.
Just my 2 Cents,
A.S.


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

NoOp NoOp
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Peter Hillier-Brook
On 08/29/2012 08:03 AM, Peter Hillier-Brook wrote:

> I've just updated to LibO 3.6.1 and hit the following problem when
> trying to access my address book
>
> Does anyone recognise it, Google doesn't?
> ___________________________________________________________________________
> The attempt to load the file resulted in the following error message
> (com.sun.star.lang.IllegalArgumentException):
>
> Unsupported URL <file:///home/phb/..../AddressBook.ods>
> ___________________________________________________________________________
>
> Ubuntu 12.04 64 bit
> Java 1.7_06 (and 05)
>
> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
> carried out by complete removal of 3.6.0 via Synaptic and clean
> installation of the "real" product, downloaded from the LibreOffice web
> site via dpkg -iR
...

At least your's runs... Mine errored on the dictionaries & failed to run
at all:

http://pastebin.com/3aKwSYP1
$ /opt/libreoffice3.6/program/soffice
terminate called after throwing an instance of
'com::sun::star::uno::RuntimeException'

$ java -version
java version "1.7.0_06"
Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
Java HotSpot(TM) 64-Bit Server VM (build 23.2-b09, mixed mode)

I suspect that it doesn't like that I didn't uninstall 3.6.0 first.




--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Dan Lewis Dan Lewis
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

NoOp wrote:

> On 08/29/2012 08:03 AM, Peter Hillier-Brook wrote:
>> I've just updated to LibO 3.6.1 and hit the following problem when
>> trying to access my address book
>>
>> Does anyone recognise it, Google doesn't?
>> ___________________________________________________________________________
>> The attempt to load the file resulted in the following error message
>> (com.sun.star.lang.IllegalArgumentException):
>>
>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>> ___________________________________________________________________________
>>
>> Ubuntu 12.04 64 bit
>> Java 1.7_06 (and 05)
>>
>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>> carried out by complete removal of 3.6.0 via Synaptic and clean
>> installation of the "real" product, downloaded from the LibreOffice web
>> site via dpkg -iR
> ...
>
> At least your's runs... Mine errored on the dictionaries & failed to run
> at all:
>
> http://pastebin.com/3aKwSYP1
> $ /opt/libreoffice3.6/program/soffice
> terminate called after throwing an instance of
> 'com::sun::star::uno::RuntimeException'
>
> $ java -version
> java version "1.7.0_06"
> Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
> Java HotSpot(TM) 64-Bit Server VM (build 23.2-b09, mixed mode)
>
> I suspect that it doesn't like that I didn't uninstall 3.6.0 first.

      Remember that 3.6.1.2 is a pre-release. I'm thinking that renaming
the extension folder may resolve the problems with the dictionaries.

--Dan

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
NoOp NoOp
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

On 08/29/2012 12:38 PM, Dan wrote:
> NoOp wrote:
>> On 08/29/2012 08:03 AM, Peter Hillier-Brook wrote:
...

>>>
>>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>>> carried out by complete removal of 3.6.0 via Synaptic and clean
>>> installation of the "real" product, downloaded from the LibreOffice web
>>> site via dpkg -iR
>> ...
>>
>> At least your's runs... Mine errored on the dictionaries & failed to run
>> at all:
>>
>> http://pastebin.com/3aKwSYP1
>> $ /opt/libreoffice3.6/program/soffice
>> terminate called after throwing an instance of
>> 'com::sun::star::uno::RuntimeException'
>>
>> $ java -version
>> java version "1.7.0_06"
>> Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
>> Java HotSpot(TM) 64-Bit Server VM (build 23.2-b09, mixed mode)
>>
>> I suspect that it doesn't like that I didn't uninstall 3.6.0 first.
>
>       Remember that 3.6.1.2 is a pre-release. I'm thinking that renaming
> the extension folder may resolve the problems with the dictionaries.
>
> --Dan
>

Not according to this:
<https://www.libreoffice.org/download/>

3.6.1 is the default on that page & nodetect:
<https://www.libreoffice.org/download/?nodetect>
  <https://www.libreoffice.org/download/?type=deb-x86_64>

I don't even see 3.6.0 until I get here:
<https://www.libreoffice.org/download/?type=deb-x86_64&lang=en-US>
and clicking puts me here:
<https://www.libreoffice.org/download/?type=deb-x86_64&lang=en-US&version=3.6.1>
No mention of pre-release there.

No pre-release versions available until September:
<https://www.libreoffice.org/download/pre-releases/>
"There's presently no current pre-release version available, stay tuned
for 3.6.2 builds, scheduled for September 2012."




--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Mirosław Zalewski Mirosław Zalewski
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Dan Lewis
On 29/08/2012 at 21:38, Dan <[hidden email]> wrote:

>  Remember that 3.6.1.2 is a pre-release.

Isn't 3.6.1 bit-by-bit identical with 3.6.1.2 (rc2)? I am sure that in .0
releases, they are identical with their last RC. And since 3.6.1 had only two
RCs...

In release note [0] there are links to fixes in 3.6.1-1 and 3.6.1-2, but no
mention about 3.6.1-3 or 3.6.1-final.

[0] http://blog.documentfoundation.org/2012/08/29/the-document-foundation-
announces-libreoffice-3-6-1/
--
Best regards
Mirosław Zalewski

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
NoOp NoOp
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by NoOp
On 08/29/2012 12:31 PM, NoOp wrote:
...

> At least your's runs... Mine errored on the dictionaries & failed to run
> at all:
>
> http://pastebin.com/3aKwSYP1
> $ /opt/libreoffice3.6/program/soffice
> terminate called after throwing an instance of
> 'com::sun::star::uno::RuntimeException'
>
> $ java -version
> java version "1.7.0_06"
> Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
> Java HotSpot(TM) 64-Bit Server VM (build 23.2-b09, mixed mode)
>
> I suspect that it doesn't like that I didn't uninstall 3.6.0 first.


My bad... I forgot that I had previously set the user profile for
libreoffice3.6/user vs libreoffice/user. Modified bootstraprc for
libreoffice3.6 and 3.6.1 now starts.

@Peter: I cannot replicate your error in 64bit or 32bit.

@Dan: I moved /libreoffice3.6/share/extensions to
/libreoffice3.6/share/extensions_bak and did another install. Same errors:
Errors were encountered while processing:
 libreoffice3.6-dict-en_3.6.1.2-2_amd64.deb
 libreoffice3.6-dict-es_3.6.1.2-2_amd64.deb
 libreoffice3.6-dict-fr_3.6.1.2-2_amd64.deb
(and on 32bit deb as well).

I'll test by removing 3.6 completely.





--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted
Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Peter Hillier-Brook
On 29/08/12 17:55, Peter Hillier-Brook wrote:

> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>> I've just updated to LibO 3.6.1 and hit the following problem when
>> trying to access my address book
>>
>> Does anyone recognise it, Google doesn't?
>> ___________________________________________________________________________
>>
>> The attempt to load the file resulted in the following error message
>> (com.sun.star.lang.IllegalArgumentException):
>>
>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>> ___________________________________________________________________________
>>
>>
>> Ubuntu 12.04 64 bit
>> Java 1.7_06 (and 05)
>>
>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>> carried out by complete removal of 3.6.0 via Synaptic and clean
>> installation of the "real" product, downloaded from the LibreOffice web
>> site via dpkg -iR
>
> Interestingly everything is fine on a 32 bit installation!

It gets even more murky! My problem occurred under Kubuntu. Installing
on another machine running Ubuntu with the dreaded Unity went just fine.

Thanks for all the feedback.

Peter HB


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Tom
On 29/08/12 18:50, Tom Davies wrote:
> Hi :) Errr, on the 64bit Ubuntu is the java also 64bit?  If it is
> then can you try installing a 32 bit version of 1.6_32?  LO can be
> told which version of java to use so it might work Tools - Options -
> Java Regards from Tom :)

That sounds like Windows solution! :-)

Peter HB

--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

krackedpress krackedpress
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

On 08/29/2012 05:05 PM, Peter Hillier-Brook wrote:

> On 29/08/12 18:50, Tom Davies wrote:
>> Hi :) Errr, on the 64bit Ubuntu is the java also 64bit?  If it is
>> then can you try installing a 32 bit version of 1.6_32?  LO can be
>> told which version of java to use so it might work Tools - Options -
>> Java Regards from Tom :)
>
> That sounds like Windows solution! :-)
>
> Peter HB
>

For Ubuntu, I run "openjdk-6-jre" instead of the "default-jre" from
Oracle.  There are RPM downloads, but no DEB versions on Oracle's web
site.  Maybe Debian/Ubuntu do not want you to have to choose yourself,
or Oracle does not know how to make a proper DEB install file.  Either
way, I am sticking with 1.6_x for Windows and "openjdk-6" for Ubuntu so
I so not have to deal with Java 1.7_x.

Also, Oracle has "special instructions" on their web site about 64-bit
installs.




--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Peter Hillier-Brook
Hi :)
LibreOffice doesn't have a 64bit version and allegedly needs java to be 32 bit too.
Regards from
Tom :) 


--- On Wed, 29/8/12, Peter Hillier-Brook <[hidden email]> wrote:

From: Peter Hillier-Brook <[hidden email]>
Subject: Re: [libreoffice-users] Update to 3.6.1
To: [hidden email]
Date: Wednesday, 29 August, 2012, 22:05

On 29/08/12 18:50, Tom Davies wrote:
> Hi :) Errr, on the 64bit Ubuntu is the java also 64bit?  If it is
> then can you try installing a 32 bit version of 1.6_32?  LO can be
> told which version of java to use so it might work Tools - Options -
> Java Regards from Tom :)

That sounds like Windows solution! :-)

Peter HB

-- For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Andreas Säger
Hi :) 
This guide might help if y9ou want to run a few versions of LO and/or AOO alongside each other
http://wiki.documentfoundation.org/Installing_in_parallel
Regards from
Tom :) 



--- On Wed, 29/8/12, Andreas Säger <[hidden email]> wrote:

From: Andreas Säger <[hidden email]>
Subject: [libreoffice-users] Re: Update to 3.6.1
To: [hidden email]
Date: Wednesday, 29 August, 2012, 19:05

Am 29.08.2012 18:55, Peter Hillier-Brook wrote:

> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>> I've just updated to LibO 3.6.1 and hit the following problem when
>> trying to access my address book
>>
>> Does anyone recognise it, Google doesn't?
>> ___________________________________________________________________________
>>
>> The attempt to load the file resulted in the following error message
>> (com.sun.star.lang.IllegalArgumentException):
>>
>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>> ___________________________________________________________________________
>>
>>
>> Ubuntu 12.04 64 bit
>> Java 1.7_06 (and 05)
>>
>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>> carried out by complete removal of 3.6.0 via Synaptic and clean
>> installation of the "real" product, downloaded from the LibreOffice web
>> site via dpkg -iR
>
> Interestingly everything is fine on a 32 bit installation!
>
>

Hi,
Since many years I use to update my office suites without removal. All major versions (OOo 1 and 2, LibO and OOo 3) are separate applications with separated profile folders anyway.
Any problems (if any) are related to the user profile which can be reset by renaming a folder. Within the profile issues, the installed extensions are the major culprit (but not the ones I use to have installed). So I extract the downloaded archive, change to the extracted directory/DEBS and run
sudo dpkg -i *.deb
If I want that version to be the default program with menu and everything I change to the desktop-integration subdirectory and install that package too.
If I do not want that version to be the default program I add a couple of my own desktop links to the respective executables. There were times when I had OOo 1.1.5, 2.4.3, 3.4beta, LibO 3.3 and 3.5.x installed in parallel without any problem.

Problems that come up quite frequently on this list are not the normal case. It is designed to be update out of the box, particularly on Linux.
Just my 2 Cents,
A.S.


-- For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Dan Lewis Dan Lewis
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Tom
      As far as I know, only Windows does not have a 64 bit version. Linux
has 64 bit version for both DEB and RPM. The following is the folder
containing the installation files for LO 3.6.1.2 The Java I use is also 64
bit that I get from the Ubuntu Repository (OpenJDK Java 6) with all the
patches.

LibO_3.6.1.2_Linux_x86-64_install-deb_en-US

--Dan


Tom Davies wrote:

> Hi :)
> LibreOffice doesn't have a 64bit version and allegedly needs java to be 32 bit too.
> Regards from
> Tom :)
>
>
> --- On Wed, 29/8/12, Peter Hillier-Brook <[hidden email]> wrote:
>
> From: Peter Hillier-Brook <[hidden email]>
> Subject: Re: [libreoffice-users] Update to 3.6.1
> To: [hidden email]
> Date: Wednesday, 29 August, 2012, 22:05
>
> On 29/08/12 18:50, Tom Davies wrote:
>> Hi :) Errr, on the 64bit Ubuntu is the java also 64bit?  If it is
>> then can you try installing a 32 bit version of 1.6_32?  LO can be
>> told which version of java to use so it might work Tools - Options -
>> Java Regards from Tom :)
>
> That sounds like Windows solution! :-)
>
> Peter HB
>
> -- For unsubscribe instructions e-mail to: [hidden email]
> Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Dan Lewis Dan Lewis
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Tom
Tom Davies wrote:
> Hi :)
> This guide might help if you want to run a few versions of LO and/or AOO alongside each other
> http://wiki.documentfoundation.org/Installing_in_parallel
> Regards from
> Tom :)

      This may also be a Windows problem. My tower uses Ubuntu 11.10 (64
bit). Right now I have LO 3.4.6, 3.5.6, 3.6.1, AND AOO 3.4.1. Side note: If
I want to run say 3.6.1 and 3.6.2 installing in parallel might be a good idea.
      I have found that I can not run 3.5.6 and 3.6.1 at the same time. Yet
I can run either one of them with LO 3.4.6 or AOO 3.4.1. So I can have
three different "soffice" instances running at the same time as long as two
of them are 3.5 and 3.6. This is true even when I use these two:
/opt/libreoffice3.6/program/soffice
/opt/libreoffice3.5/program/soffice

--Dan

>
> --- On Wed, 29/8/12, Andreas Säger <[hidden email]> wrote:
>
> From: Andreas Säger <[hidden email]>
> Subject: [libreoffice-users] Re: Update to 3.6.1
> To: [hidden email]
> Date: Wednesday, 29 August, 2012, 19:05
>
> Am 29.08.2012 18:55, Peter Hillier-Brook wrote:
>> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>>> I've just updated to LibO 3.6.1 and hit the following problem when
>>> trying to access my address book
>>>
>>> Does anyone recognise it, Google doesn't?
>>> ___________________________________________________________________________
>>>
>>> The attempt to load the file resulted in the following error message
>>> (com.sun.star.lang.IllegalArgumentException):
>>>
>>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>>> ___________________________________________________________________________
>>>
>>>
>>> Ubuntu 12.04 64 bit
>>> Java 1.7_06 (and 05)
>>>
>>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>>> carried out by complete removal of 3.6.0 via Synaptic and clean
>>> installation of the "real" product, downloaded from the LibreOffice web
>>> site via dpkg -iR
>>
>> Interestingly everything is fine on a 32 bit installation!
>>
>>
>
> Hi,
> Since many years I use to update my office suites without removal. All major versions (OOo 1 and 2, LibO and OOo 3) are separate applications with separated profile folders anyway.
> Any problems (if any) are related to the user profile which can be reset by renaming a folder. Within the profile issues, the installed extensions are the major culprit (but not the ones I use to have installed). So I extract the downloaded archive, change to the extracted directory/DEBS and run
> sudo dpkg -i *.deb
> If I want that version to be the default program with menu and everything I change to the desktop-integration subdirectory and install that package too.
> If I do not want that version to be the default program I add a couple of my own desktop links to the respective executables. There were times when I had OOo 1.1.5, 2.4.3, 3.4beta, LibO 3.3 and 3.5.x installed in parallel without any problem.
>
> Problems that come up quite frequently on this list are not the normal case. It is designed to be update out of the box, particularly on Linux.
> Just my 2 Cents,
> A.S.
>
>
> -- For unsubscribe instructions e-mail to: [hidden email]
> Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

Hi :)
Ahh, yes, most of the guide is about making sure none of the quick-starter or any other back-ground process is running.  The only problem with multiple versions is nothing to do with the actual install itself, it's about running them at the same time as that 'cant' be done yet afaik. 

It's interesting to hear that possibly pre-3.5.x can be run at the same time as a 3.5.x or later.  I wonder if a AOO can be run at the same time as a 3.5.x or later too? 

Regards from
Tom :) 


--- On Thu, 30/8/12, Dan <[hidden email]> wrote:

From: Dan <[hidden email]>
Subject: Re: [libreoffice-users] Re: Update to 3.6.1
To: [hidden email]
Date: Thursday, 30 August, 2012, 1:06

Tom Davies wrote:
> Hi :)
> This guide might help if you want to run a few versions of LO and/or AOO alongside each other
> http://wiki.documentfoundation.org/Installing_in_parallel
> Regards from
> Tom :)

      This may also be a Windows problem. My tower uses Ubuntu 11.10 (64
bit). Right now I have LO 3.4.6, 3.5.6, 3.6.1, AND AOO 3.4.1. Side note: If
I want to run say 3.6.1 and 3.6.2 installing in parallel might be a good idea.
      I have found that I can not run 3.5.6 and 3.6.1 at the same time. Yet
I can run either one of them with LO 3.4.6 or AOO 3.4.1. So I can have
three different "soffice" instances running at the same time as long as two
of them are 3.5 and 3.6. This is true even when I use these two:
/opt/libreoffice3.6/program/soffice
/opt/libreoffice3.5/program/soffice

--Dan

>
> --- On Wed, 29/8/12, Andreas Säger <[hidden email]> wrote:
>
> From: Andreas Säger <[hidden email]>
> Subject: [libreoffice-users] Re: Update to 3.6.1
> To: [hidden email]
> Date: Wednesday, 29 August, 2012, 19:05
>
> Am 29.08.2012 18:55, Peter Hillier-Brook wrote:
>> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>>> I've just updated to LibO 3.6.1 and hit the following problem when
>>> trying to access my address book
>>>
>>> Does anyone recognise it, Google doesn't?
>>> ___________________________________________________________________________
>>>
>>> The attempt to load the file resulted in the following error message
>>> (com.sun.star.lang.IllegalArgumentException):
>>>
>>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>>> ___________________________________________________________________________
>>>
>>>
>>> Ubuntu 12.04 64 bit
>>> Java 1.7_06 (and 05)
>>>
>>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the upgrade,
>>> carried out by complete removal of 3.6.0 via Synaptic and clean
>>> installation of the "real" product, downloaded from the LibreOffice web
>>> site via dpkg -iR
>>
>> Interestingly everything is fine on a 32 bit installation!
>>
>>
>
> Hi,
> Since many years I use to update my office suites without removal. All major versions (OOo 1 and 2, LibO and OOo 3) are separate applications with separated profile folders anyway.
> Any problems (if any) are related to the user profile which can be reset by renaming a folder. Within the profile issues, the installed extensions are the major culprit (but not the ones I use to have installed). So I extract the downloaded archive, change to the extracted directory/DEBS and run
> sudo dpkg -i *.deb
> If I want that version to be the default program with menu and everything I change to the desktop-integration subdirectory and install that package too.
> If I do not want that version to be the default program I add a couple of my own desktop links to the respective executables. There were times when I had OOo 1.1.5, 2.4.3, 3.4beta, LibO 3.3 and 3.5.x installed in parallel without any problem.
>
> Problems that come up quite frequently on this list are not the normal case. It is designed to be update out of the box, particularly on Linux.
> Just my 2 Cents,
> A.S.
>
>
> -- For unsubscribe instructions e-mail to: [hidden email]
> Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
> List archive: http://listarchives.libreoffice.org/global/users/
> All messages sent to this list will be publicly archived and cannot be deleted
>
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Dan Lewis Dan Lewis
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

Tom Davies wrote:

> Hi :)
> Ahh, yes, most of the guide is about making sure none of the quick-starter
> or any other back-ground process is running.  The only problem with
> multiple versions is nothing to do with the actual install itself, it's
> about running them at the same time as that 'cant' be done yet afaik.
>
> It's interesting to hear that possibly pre-3.5.x can be run at the same
> time as a 3.5.x or later.  I wonder if a AOO can be run at the same time as
> a 3.5.x or later too?
>
> Regards from
> Tom :)

      I do all the time.

--Dan

>
>
> --- On *Thu, 30/8/12, Dan /<[hidden email]>/* wrote:
>
>
>     From: Dan <[hidden email]>
>     Subject: Re: [libreoffice-users] Re: Update to 3.6.1
>     To: [hidden email]
>     Date: Thursday, 30 August, 2012, 1:06
>
>     Tom Davies wrote:
>      > Hi :)
>      > This guide might help if you want to run a few versions of LO and/or
>     AOO alongside each other
>      > http://wiki.documentfoundation.org/Installing_in_parallel
>      > Regards from
>      > Tom :)
>
>            This may also be a Windows problem. My tower uses Ubuntu 11.10 (64
>     bit). Right now I have LO 3.4.6, 3.5.6, 3.6.1, AND AOO 3.4.1. Side
>     note: If
>     I want to run say 3.6.1 and 3.6.2 installing in parallel might be a
>     good idea.
>            I have found that I can not run 3.5.6 and 3.6.1 at the same
>     time. Yet
>     I can run either one of them with LO 3.4.6 or AOO 3.4.1. So I can have
>     three different "soffice" instances running at the same time as long as
>     two
>     of them are 3.5 and 3.6. This is true even when I use these two:
>     /opt/libreoffice3.6/program/soffice
>     /opt/libreoffice3.5/program/soffice
>
>     --Dan
>
>      >
>      > --- On Wed, 29/8/12, Andreas Säger <[hidden email]
>     </mc/compose?to=[hidden email]>> wrote:
>      >
>      > From: Andreas Säger <[hidden email]
>     </mc/compose?to=[hidden email]>>
>      > Subject: [libreoffice-users] Re: Update to 3.6.1
>      > To: [hidden email]
>     </mc/compose?to=[hidden email]>
>      > Date: Wednesday, 29 August, 2012, 19:05
>      >
>      > Am 29.08.2012 18:55, Peter Hillier-Brook wrote:
>      >> On 29/08/12 16:03, Peter Hillier-Brook wrote:
>      >>> I've just updated to LibO 3.6.1 and hit the following problem when
>      >>> trying to access my address book
>      >>>
>      >>> Does anyone recognise it, Google doesn't?
>      >>>
>     ___________________________________________________________________________
>      >>>
>      >>> The attempt to load the file resulted in the following error message
>      >>> (com.sun.star.lang.IllegalArgumentException):
>      >>>
>      >>> Unsupported URL <file:///home/phb/..../AddressBook.ods>
>      >>>
>     ___________________________________________________________________________
>      >>>
>      >>>
>      >>> Ubuntu 12.04 64 bit
>      >>> Java 1.7_06 (and 05)
>      >>>
>      >>> All was well with LibO 3.6.0 and Java 1.7_05 just prior to the
>     upgrade,
>      >>> carried out by complete removal of 3.6.0 via Synaptic and clean
>      >>> installation of the "real" product, downloaded from the
>     LibreOffice web
>      >>> site via dpkg -iR
>      >>
>      >> Interestingly everything is fine on a 32 bit installation!
>      >>
>      >>
>      >
>      > Hi,
>      > Since many years I use to update my office suites without removal.
>     All major versions (OOo 1 and 2, LibO and OOo 3) are separate
>     applications with separated profile folders anyway.
>      > Any problems (if any) are related to the user profile which can be
>     reset by renaming a folder. Within the profile issues, the installed
>     extensions are the major culprit (but not the ones I use to have
>     installed). So I extract the downloaded archive, change to the
>     extracted directory/DEBS and run
>      > sudo dpkg -i *.deb
>      > If I want that version to be the default program with menu and
>     everything I change to the desktop-integration subdirectory and install
>     that package too.
>      > If I do not want that version to be the default program I add a
>     couple of my own desktop links to the respective executables. There
>     were times when I had OOo 1.1.5, 2.4.3, 3.4beta, LibO 3.3 and 3.5.x
>     installed in parallel without any problem.
>      >
>      > Problems that come up quite frequently on this list are not the
>     normal case. It is designed to be update out of the box, particularly
>     on Linux.
>      > Just my 2 Cents,
>      > A.S.
>      >
>      >
>      > -- For unsubscribe instructions e-mail to:
>     [hidden email]
>     </mc/compose?to=[hidden email]>
>      > Problems?
>     http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>      > Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
>      > List archive: http://listarchives.libreoffice.org/global/users/
>      > All messages sent to this list will be publicly archived and cannot
>     be deleted
>      >
>      >
>
>
>     --
>     For unsubscribe instructions e-mail to:
>     [hidden email]
>     </mc/compose?to=[hidden email]>
>     Problems?
>     http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>     Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
>     List archive: http://listarchives.libreoffice.org/global/users/
>     All messages sent to this list will be publicly archived and cannot be
>     deleted
>


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Peter Hillier-Brook Peter Hillier-Brook
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Tom
On 29/08/12 23:39, Tom Davies wrote:
> Hi :)
> LibreOffice doesn't have a 64bit version and allegedly needs java to be 32 bit too.
> Regards from
> Tom :)

I don't know where you got that idea from, unless you haven't noticed
that I'm talking about Linux, not the MS product. ;-)

I've been using fully 64 bit systems for several years, firstly with OOo
and then LO and, as indicated further down this thread, the combination
is functioning perfectly well on another system with the same software
installation(s). I'm guessing that the mal-functioning is related to the
profile somewhere. Experiments continue.

Peter HB


--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Tom Tom
Reply | Threaded
Open this post in threaded view
|

Re: Update to 3.6.1

In reply to this post by Dan Lewis
Hi :)
Ahh, so that is not the issue then.  Sorry!

Does the version of java have to match the app or the OS?  I would have thought it has to match the app?  Sorry, i'm still curious even tho it's not the issue in this thread.
Regards from
Tom :) 






>________________________________
> From: Dan <[hidden email]>
>To: "[hidden email]" <[hidden email]>
>Sent: Thursday, 30 August 2012, 0:56
>Subject: Re: [libreoffice-users] Update to 3.6.1
>
>      As far as I know, only Windows does not have a 64 bit version. Linux
>has 64 bit version for both DEB and RPM. The following is the folder
>containing the installation files for LO 3.6.1.2 The Java I use is also 64
>bit that I get from the Ubuntu Repository (OpenJDK Java 6) with all the
>patches.
>
>LibO_3.6.1.2_Linux_x86-64_install-deb_en-US
>
>--Dan
>
>
>Tom Davies wrote:
>> Hi :)
>> LibreOffice doesn't have a 64bit version and allegedly needs java to be 32 bit too.
>> Regards from
>> Tom :)
>>
>>
>> --- On Wed, 29/8/12, Peter Hillier-Brook <[hidden email]> wrote:
>>
>> From: Peter Hillier-Brook <[hidden email]>
>> Subject: Re: [libreoffice-users] Update to 3.6.1
>> To: [hidden email]
>> Date: Wednesday, 29 August, 2012, 22:05
>>
>> On 29/08/12 18:50, Tom Davies wrote:
>>> Hi :) Errr, on the 64bit Ubuntu is the java also 64bit?  If it is
>>> then can you try installing a 32 bit version of 1.6_32?  LO can be
>>> told which version of java to use so it might work Tools - Options -
>>> Java Regards from Tom :)
>>
>> That sounds like Windows solution! :-)
>>
>> Peter HB
>>
>> -- For unsubscribe instructions e-mail to: [hidden email]
>> Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>> Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
>> List archive: http://listarchives.libreoffice.org/global/users/
>> All messages sent to this list will be publicly archived and cannot be deleted
>>
>>
>
>
>--
>For unsubscribe instructions e-mail to: [hidden email]
>Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
>Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
>List archive: http://listarchives.libreoffice.org/global/users/
>All messages sent to this list will be publicly archived and cannot be deleted
>
>
>
>
--
For unsubscribe instructions e-mail to: [hidden email]
Problems? http://www.libreoffice.org/get-help/mailing-lists/how-to-unsubscribe/
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/global/users/
All messages sent to this list will be publicly archived and cannot be deleted

Next » 12