formule ineficace

classic Classic list List threaded Threaded
6 messages Options
pascaudjipe_ovh pascaudjipe_ovh
Reply | Threaded
Open this post in threaded view
|

formule ineficace

bonjour,
depuis plusieurs année je me sert de classeur que je copie année après
année en changeant uniquement les dates des années.
dans certaine cellules j'ai ce genre de formule
=SOMME.SI(C21:C65;"apt";F21:F65)
seule diffère suivant les cellules l'intitulé "apt"
jusqu'à maintenant javais le résultat qui s'affichait correctement
je viens de m'apercevoir que depuis janvier 2019 le résultat ne
s'affiche plus, j'ai 0,00EUR à la place de la somme

LO Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded

je vois pas où chercher
j'ai mis un exemple bidon sur fiamadrop [1]
si quelqu'un a une idée ou une piste,
merci d'avance
librement
jipé

--
Linux 4.14.89-desktop-1.mga6 x86_64 GNU/Linux Mageia 6
https://jiperaw.art 

Links:
------
[1]
https://framadrop.org/r/cE9HN6CBND#JPC++npmUu8IWPhWVHW//w8WCVcS94SbBIn6KFZGTv0=
--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Tulum Tulum
Reply | Threaded
Open this post in threaded view
|

Re: formule ineficace

Le mardi 16 avril 2019, 09:11:43 CEST jipé a écrit :

> bonjour,
> depuis plusieurs année je me sert de classeur que je copie année après
> année en changeant uniquement les dates des années.
> dans certaine cellules j'ai ce genre de formule
> =SOMME.SI(C21:C65;"apt";F21:F65)
> seule diffère suivant les cellules l'intitulé "apt"
> jusqu'à maintenant javais le résultat qui s'affichait correctement
> je viens de m'apercevoir que depuis janvier 2019 le résultat ne
> s'affiche plus, j'ai 0,00EUR à la place de la somme
>
> LO Version: 6.1.5.2
> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
> Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
> Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
>
> je vois pas où chercher
> j'ai mis un exemple bidon sur fiamadrop [1]
> si quelqu'un a une idée ou une piste,
> merci d'avance
> librement
> jipé
Bonjour,

A priori, il recherche "apt" exactement dans les cellules et non pas contient
"apt".
Une solution de contournement serai de créer une colonne supplémentaire à ton
tableau du type : =SI((DROITE(C10;3)="apt");F10;0). Tu masques les cellules.
Dans ton récapitulatif tu fais l'addition de de cette colonne.
J'ai essayé d'intégrer la fonction droite dans ta formule somme.si mais je
n'ai pas réussi.

Cordialement



--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy

Patrick47 Patrick47
Reply | Threaded
Open this post in threaded view
|

Re: formule ineficace

In reply to this post by pascaudjipe_ovh
Bonjour,

Voici une solution.
Tout d'abord aller sur le menu Outils, sélectionner Options.
Cliquer sur "LibreOffice Calc" puis sur "calcul".
Parmi les options sous "Calculs généraux" valider le bouton radio en
face de " Autoriser les expressions régulières dans les formules".
Valider.
Modifier la formule comme suit : SOMME.SI(C7:C25;"*.**apt";F7:F25), et
tout fonctionne.
Dans l'aide de LibreOffice on trouve cela pour la fonction SOMME.SI.ENS,
mais pas pour SOMME.SI (??)
Cordialement,
Patrick

------------------------------------------------------------------
Lorsque tu arrives en haut de la montagne, continue de grimper. ;)

Le 16/04/2019 à 09:11, jipé a écrit :

> bonjour,
> depuis plusieurs année je me sert de classeur que je copie année après
> année en changeant uniquement les dates des années.
> dans certaine cellules j'ai ce genre de formule
> =SOMME.SI(C21:C65;"apt";F21:F65)
> seule diffère suivant les cellules l'intitulé "apt"
> jusqu'à maintenant javais le résultat qui s'affichait correctement
> je viens de m'apercevoir que depuis janvier 2019 le résultat ne
> s'affiche plus, j'ai 0,00EUR à la place de la somme
>
> LO Version: 6.1.5.2
> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
> Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
> Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
>
> je vois pas où chercher
> j'ai mis un exemple bidon sur fiamadrop [1]
> si quelqu'un a une idée ou une piste,
> merci d'avance
> librement
> jipé
>



---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Patrick47 Patrick47
Reply | Threaded
Open this post in threaded view
|

Re: formule ineficace

Erreur dans le codage du message qui apparait en réponse sur la liste.
Ce n'est pas "*.**apt", mais ".*apt". J'avais mis ".*" en gras et en
rouge pour bien attirer l'attention, mais cela a été modifié (comment,
pourquoi ??)

Patrick

------------------------------------------------------------------
Lorsque tu arrives en haut de la montagne, continue de grimper. ;)

Le 16/04/2019 à 14:20, Patrick Auclair a écrit :

> Bonjour,
>
> Voici une solution.
> Tout d'abord aller sur le menu Outils, sélectionner Options.
> Cliquer sur "LibreOffice Calc" puis sur "calcul".
> Parmi les options sous "Calculs généraux" valider le bouton radio en
> face de " Autoriser les expressions régulières dans les formules".
> Valider.
> Modifier la formule comme suit : SOMME.SI(C7:C25;"*.**apt";F7:F25), et
> tout fonctionne.
> Dans l'aide de LibreOffice on trouve cela pour la fonction
> SOMME.SI.ENS, mais pas pour SOMME.SI (??)
> Cordialement,
> Patrick
>
> ------------------------------------------------------------------
> Lorsque tu arrives en haut de la montagne, continue de grimper. ;)
>
> Le 16/04/2019 à 09:11, jipé a écrit :
>> bonjour,
>> depuis plusieurs année je me sert de classeur que je copie année après
>> année en changeant uniquement les dates des années.
>> dans certaine cellules j'ai ce genre de formule
>> =SOMME.SI(C21:C65;"apt";F21:F65)
>> seule diffère suivant les cellules l'intitulé "apt"
>> jusqu'à maintenant javais le résultat qui s'affichait correctement
>> je viens de m'apercevoir que depuis janvier 2019 le résultat ne
>> s'affiche plus, j'ai 0,00EUR à la place de la somme
>>
>> LO Version: 6.1.5.2
>> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
>> Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
>> Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
>>
>> je vois pas où chercher
>> j'ai mis un exemple bidon sur fiamadrop [1]
>> si quelqu'un a une idée ou une piste,
>> merci d'avance
>> librement
>> jipé
>>
>
>
>
> ---
> L'absence de virus dans ce courrier électronique a été vérifiée par le
> logiciel antivirus Avast.
> https://www.avast.com/antivirus
>


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy
Dipsode Dipsode
Reply | Threaded
Open this post in threaded view
|

Re: formule ineficace

In reply to this post by Tulum
Bonjour,

Si l'option "autoriser les caractères génériques dans les formules" est
activé  (Outils-Option-Libre office Calc-Calcul), on peut utiliser les
caractères génériques (* : une suite quelconque de caractères et ? : un
caractère et un seul) pour indiquer des recherches sur des chaînes de
caractères.

Une formule du genre
=SOMME.SI(C7:C25;"*apt";F7:F25)
fonctionne

Christian F
Le 16/04/2019 à 10:28, Tulum a écrit :

> Le mardi 16 avril 2019, 09:11:43 CEST jipé a écrit :
>> bonjour,
>> depuis plusieurs année je me sert de classeur que je copie année après
>> année en changeant uniquement les dates des années.
>> dans certaine cellules j'ai ce genre de formule
>> =SOMME.SI(C21:C65;"apt";F21:F65)
>> seule diffère suivant les cellules l'intitulé "apt"
>> jusqu'à maintenant javais le résultat qui s'affichait correctement
>> je viens de m'apercevoir que depuis janvier 2019 le résultat ne
>> s'affiche plus, j'ai 0,00EUR à la place de la somme
>>
>> LO Version: 6.1.5.2
>> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
>> Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
>> Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
>>
>> je vois pas où chercher
>> j'ai mis un exemple bidon sur fiamadrop [1]
>> si quelqu'un a une idée ou une piste,
>> merci d'avance
>> librement
>> jipé
> Bonjour,
>
> A priori, il recherche "apt" exactement dans les cellules et non pas contient
> "apt".
> Une solution de contournement serai de créer une colonne supplémentaire à ton
> tableau du type : =SI((DROITE(C10;3)="apt");F10;0). Tu masques les cellules.
> Dans ton récapitulatif tu fais l'addition de de cette colonne.
> J'ai essayé d'intégrer la fonction droite dans ta formule somme.si mais je
> n'ai pas réussi.
>
> Cordialement
>
>
>


--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy
sophie sophie
Reply | Threaded
Open this post in threaded view
|

Re: formule ineficace

In reply to this post by Patrick47
Bonjour Patrick,
Le 16/04/2019 à 14:26, Patrick Auclair a écrit :
> Erreur dans le codage du message qui apparait en réponse sur la liste.
> Ce n'est pas "*.**apt", mais ".*apt". J'avais mis ".*" en gras et en
> rouge pour bien attirer l'attention, mais cela a été modifié (comment,
> pourquoi ??)

Parce que les listes traitent le message en texte et non en html.

À bientôt
Sophie

--
Sophie Gautier [hidden email]
GSM: +33683901545
IRC: sophi
Release coordinator
The Document Foundation

--
Envoyez un mail à [hidden email] pour vous désinscrire
Les archives de la liste sont disponibles à https://listarchives.libreoffice.org/fr/users/
Privacy Policy: https://www.documentfoundation.org/privacy