[it-users] LO Still: Error while installing extension LanguageTool

classic Classic list List threaded Threaded
9 messages Options
Lucilla Less ab srl Lucilla Less ab srl
Reply | Threaded
Open this post in threaded view
|

[it-users] LO Still: Error while installing extension LanguageTool

Buonasera,
sono un utente molto junior, uso LibreOffice da pochissimo, mi scuso quindi anticipatamente se le mie domande risultano scontate e se in questa mia prima richiesta sono un po' "lunga".
Ho installato la versione "Still" di LibreOffice sul mio iMac (OS X 10.9.5) e successivamente, seguendo le istruzioni, installato anche il Language Service Pack.
Ho poi seguito le istruzioni per settare l'interfaccia in italiano, ma le opzioni di settaggio non includono l'italiano, prevedono solo l'inglese. Fin qui poco male, lo sto usando in inglese.
Da qualche giorno però LO mi segnala un aggiornamento da installare (icona sulla barra della Scrivania), cliccando parte il download, che non va a buon fine. Copio di seguito il messaggio che compare alla fine del "Download and Installation":
 
Error while installing extension LanguageTool. Open source language checker. The error message is: [jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0
java stack trace:
java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
        at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
        at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)

The extension will not be installed.


Ho verificato che la versione di Java su iMac sia quella corretta e mi sembra di sì (Java 8 aggiornamento 71). Ho provato a disinstallare e reinstallare sia LO sia il Language Pack, nessun risultato.
Grazie per ogni consiglio.

Lucilla
[hidden email]
--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili

Vito Sebastiano Giaquinta Vito Sebastiano Giaquinta
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

Ciao,
Io sul mio mini Mac ho istallato librereoffice la versione 5  va
benissimo ti consiglio e di mettere questa. Per il java  esiste uno a
posta per il mac se non erro si apriva una finestra di dialogo che ti
indirizzava alla versione per il mac ma ti serve solo se devi usare il
modulo base , spero di non aver detto una scemenza in caso correggetemi
pure :P.
Saluti.

Il 01/02/2016 18:10, Lucilla Less ha scritto:

> Buonasera,
> sono un utente molto junior, uso LibreOffice da pochissimo, mi scuso quindi anticipatamente se le mie domande risultano scontate e se in questa mia prima richiesta sono un po' "lunga".
> Ho installato la versione "Still" di LibreOffice sul mio iMac (OS X 10.9.5) e successivamente, seguendo le istruzioni, installato anche il Language Service Pack.
> Ho poi seguito le istruzioni per settare l'interfaccia in italiano, ma le opzioni di settaggio non includono l'italiano, prevedono solo l'inglese. Fin qui poco male, lo sto usando in inglese.
> Da qualche giorno però LO mi segnala un aggiornamento da installare (icona sulla barra della Scrivania), cliccando parte il download, che non va a buon fine. Copio di seguito il messaggio che compare alla fine del "Download and Installation":
>  
> Error while installing extension LanguageTool. Open source language checker. The error message is: [jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0
> java stack trace:
> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 52.0
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
> at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
> at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)
>
> The extension will not be installed.
>
>
> Ho verificato che la versione di Java su iMac sia quella corretta e mi sembra di sì (Java 8 aggiornamento 71). Ho provato a disinstallare e reinstallare sia LO sia il Language Pack, nessun risultato.
> Grazie per ogni consiglio.
>
> Lucilla
> [hidden email]

--
Vito Sebastiano Giaquinta
Via Marmolada, 26
31030  Breda di Piave TV
Tel: 3938557555
Fax: 04220247176
Email:[hidden email]
Pec: [hidden email]

 

Ai sensi del D.Lgs. 196/2003 si precisa che le informazioni contenute in questo messaggio sono riservate ed a uso esclusivo del destinatario.
Qualora il messaggio in parola Le fosse pervenuto per errore, La invitiamo ad eliminarlo senza copiarlo e a non inoltrarlo a terzi, dandocene gentilmente comunicazione. Grazie.

Pursuant to Legislative Decree No. 196/2003, you are hereby informed that this message contains confidential information intended only for the use of the addressee.
If you are not the addressee, and have received this message by mistake, please delete it and immediately notify us.
You may not copy or disseminate this message to anyone. Thank you.


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili

Marina Latini-2 Marina Latini-2
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

In reply to this post by Lucilla Less ab srl


----- Messaggio originale -----
> Da: "Lucilla Less" <[hidden email]>
> A: [hidden email]
> Inviato: Lunedì, 1 febbraio 2016 18:10:51
> Oggetto: [it-users] LO Still: Error while installing extension LanguageTool
>
> Buonasera,
> sono un utente molto junior, uso LibreOffice da pochissimo, mi scuso quindi
> anticipatamente se le mie domande risultano scontate e se in questa mia
> prima richiesta sono un po' "lunga".

Buongiorno Lucilla e benvenuta,

> Ho installato la versione "Still" di LibreOffice sul mio iMac (OS X 10.9.5) e
> successivamente, seguendo le istruzioni, installato anche il Language
> Service Pack.

Per comodità ti incollo i link per scaricare la versione corretta per Mac:

* Fresh - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/5.0.4/it/LibreOffice_5.0.4_MacOS_x86-64.dmg
* Fresh - interfaccia: http://download.documentfoundation.org/libreoffice/stable/5.0.4/mac/x86_64/LibreOffice_5.0.4_MacOS_x86-64_langpack_it.dmg

* Still - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/4.4.7/it/LibreOffice_4.4.7_MacOS_x86-64.dmg
* Still - interfaccia: http://download.documentfoundation.org/libreoffice/stable/4.4.7/mac/x86_64/LibreOffice_4.4.7_MacOS_x86-64_langpack_it.dmg

Di solito si preferisce utilizzare la versione "still" per questioni di maggiore stabilità ma se volessi provare la versione "fresh" non dovresti incappare in problematiche bloccanti.

> Ho poi seguito le istruzioni per settare l'interfaccia in italiano, ma le
> opzioni di settaggio non includono l'italiano, prevedono solo l'inglese. Fin
> qui poco male, lo sto usando in inglese.

Installati i due pacchetti dovresti andare nel menu LibreOffice -> preferenze -> LibreOffice -> Impostazioni della lingua -> Lingue
dovresti vedere un menu di selezione della lingua dell'interfaccia.

> Da qualche giorno però LO mi segnala un aggiornamento da installare (icona
> sulla barra della Scrivania), cliccando parte il download, che non va a buon
> fine. Copio di seguito il messaggio che compare alla fine del "Download and
> Installation":
>  
> Error while installing extension LanguageTool. Open source language checker.
> The error message is: [jni_uno bridge error] UNO calling Java method
> writeRegistryInfo: non-UNO exception occurred:
> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
> Unsupported major.minor version 52.0
> java stack trace:
> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
> Unsupported major.minor version 52.0
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
> at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> at
> com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
> at
> com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)
>
> The extension will not be installed.

L'errore non è legato direttamente all'aggiornamento di LibreOffice ma ad un'estensione, la "Language Tool" che ha qualche problema di compatibilità con la versione di Java installata nel tuo sistema.
La nuova versione dell'estensione poi scaricarla anche da qui:
https://www.languagetool.org/download/LanguageTool-3.2.oxt

Sempre dal menu LibreOffice -> preferenze -> LibreOffice -> Avanzate
controlla che versione di Java è stata rilevata da LibreOffice e, se dovessi vederne più di una, seleziona quella più recente.

Per quanto riguarda l'estensione che causa l'errore, quello che ti consiglio di fare è andare nel menu Strumenti -> Gestione estensioni
e controllare che versione di quella estensione è attualmente installata. Se dovessi trovare una versione di "Language tool" più vecchia della 3.2 disinstallala manualmente, chiudi completamente LibreOffice (cmd+q) e poi prova a reinstallare la versione 3.2 che ti ho indicato poco più in alto.

Durante uno degli ultimi aggiornamenti di quell'estensione avevo riscontrato dei problemi anche io ma credevo fossero legati ad altro, a questo punto mi viene da pensare di non essere la sola ;)

Facci sapere come va ;)

Buona giornata,
Marina



--
==================================================
Marina Latini
Divisione LibreOffice
[hidden email]

Studio Storti S.r.l.
Via dell'industria 8
36040 Torri di Quartesolo - VICENZA
Tel 0444-782140 int.38
Fax 0444-782141
www.studiostorti.com
==================================================

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Lucilla Less ab srl Lucilla Less ab srl
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

Grazie mille Marina!
Seguirò step by step le puntuali istruzioni e vi aggiorno sull'esito.

A presto e grazie,
Lucilla


Il giorno 09/feb/2016, alle ore 10:31, Marina Latini <[hidden email]> ha scritto:

>
>
> ----- Messaggio originale -----
>> Da: "Lucilla Less" <[hidden email]>
>> A: [hidden email]
>> Inviato: Lunedì, 1 febbraio 2016 18:10:51
>> Oggetto: [it-users] LO Still: Error while installing extension LanguageTool
>>
>> Buonasera,
>> sono un utente molto junior, uso LibreOffice da pochissimo, mi scuso quindi
>> anticipatamente se le mie domande risultano scontate e se in questa mia
>> prima richiesta sono un po' "lunga".
>
> Buongiorno Lucilla e benvenuta,
>
>> Ho installato la versione "Still" di LibreOffice sul mio iMac (OS X 10.9.5) e
>> successivamente, seguendo le istruzioni, installato anche il Language
>> Service Pack.
>
> Per comodità ti incollo i link per scaricare la versione corretta per Mac:
>
> * Fresh - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/5.0.4/it/LibreOffice_5.0.4_MacOS_x86-64.dmg
> * Fresh - interfaccia: http://download.documentfoundation.org/libreoffice/stable/5.0.4/mac/x86_64/LibreOffice_5.0.4_MacOS_x86-64_langpack_it.dmg
>
> * Still - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/4.4.7/it/LibreOffice_4.4.7_MacOS_x86-64.dmg
> * Still - interfaccia: http://download.documentfoundation.org/libreoffice/stable/4.4.7/mac/x86_64/LibreOffice_4.4.7_MacOS_x86-64_langpack_it.dmg
>
> Di solito si preferisce utilizzare la versione "still" per questioni di maggiore stabilità ma se volessi provare la versione "fresh" non dovresti incappare in problematiche bloccanti.
>
>> Ho poi seguito le istruzioni per settare l'interfaccia in italiano, ma le
>> opzioni di settaggio non includono l'italiano, prevedono solo l'inglese. Fin
>> qui poco male, lo sto usando in inglese.
>
> Installati i due pacchetti dovresti andare nel menu LibreOffice -> preferenze -> LibreOffice -> Impostazioni della lingua -> Lingue
> dovresti vedere un menu di selezione della lingua dell'interfaccia.
>
>> Da qualche giorno però LO mi segnala un aggiornamento da installare (icona
>> sulla barra della Scrivania), cliccando parte il download, che non va a buon
>> fine. Copio di seguito il messaggio che compare alla fine del "Download and
>> Installation":
>>
>> Error while installing extension LanguageTool. Open source language checker.
>> The error message is: [jni_uno bridge error] UNO calling Java method
>> writeRegistryInfo: non-UNO exception occurred:
>> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
>> Unsupported major.minor version 52.0
>> java stack trace:
>> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
>> Unsupported major.minor version 52.0
>> at java.lang.ClassLoader.defineClass1(Native Method)
>> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
>> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
>> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
>> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
>> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
>> at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>> at
>> com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
>> at
>> com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)
>>
>> The extension will not be installed.
>
> L'errore non è legato direttamente all'aggiornamento di LibreOffice ma ad un'estensione, la "Language Tool" che ha qualche problema di compatibilità con la versione di Java installata nel tuo sistema.
> La nuova versione dell'estensione poi scaricarla anche da qui:
> https://www.languagetool.org/download/LanguageTool-3.2.oxt
>
> Sempre dal menu LibreOffice -> preferenze -> LibreOffice -> Avanzate
> controlla che versione di Java è stata rilevata da LibreOffice e, se dovessi vederne più di una, seleziona quella più recente.
>
> Per quanto riguarda l'estensione che causa l'errore, quello che ti consiglio di fare è andare nel menu Strumenti -> Gestione estensioni
> e controllare che versione di quella estensione è attualmente installata. Se dovessi trovare una versione di "Language tool" più vecchia della 3.2 disinstallala manualmente, chiudi completamente LibreOffice (cmd+q) e poi prova a reinstallare la versione 3.2 che ti ho indicato poco più in alto.
>
> Durante uno degli ultimi aggiornamenti di quell'estensione avevo riscontrato dei problemi anche io ma credevo fossero legati ad altro, a questo punto mi viene da pensare di non essere la sola ;)
>
> Facci sapere come va ;)
>
> Buona giornata,
> Marina
>
>
>
> --
> ==================================================
> Marina Latini
> Divisione LibreOffice
> [hidden email]
>
> Studio Storti S.r.l.
> Via dell'industria 8
> 36040 Torri di Quartesolo - VICENZA
> Tel 0444-782140 int.38
> Fax 0444-782141
> www.studiostorti.com
> ==================================================
>
> --
> Come cancellarsi: E-mail [hidden email]
> Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
> Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
> Archivio della lista: http://listarchives.libreoffice.org/it/users/
> Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili

Lucilla Less ab srl Lucilla Less ab srl
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

In reply to this post by Marina Latini-2
Buonasera,
riprendo la mia mail inviata tempo fa per dare risocntro dei tentativi fatti per risolvere il problema del Language Pack su OS X, sperando che sia utile anche ad altri,
Ad integrazione della mia precedente segnalazione, specifico che ho avuto gli stessi problemi sul MacBookAir nuovo su cui è installato El Capitan (10.11.4). Sull’iMac ho, come detto, è installata la versione di OS X 10.09.5
Ho seguito le puntuali indicazioni di Marina (grazie ancora), ma il problema del tool di lingua non si risolve. Continuo ad usare l’interfaccia in inglese. Non mi arrivano più notifiche di aggiornamento, ma nemmeno riesco a trovare un modo per avere l’interfaccia in italiano.
Ho disinstallato e reinstallato tutto un paio di volte, incluso Java. La versione di Java installata in entrambi i sistemi è la 8 aggiornamento 91 (build 1.8.0_91-b14)
Segnalo inoltre che:
1) provando a scaricare il Language Tool dal link indicato (https://www.languagetool.org/download/LanguageTool-3.2.oxt <https://www.languagetool.org/download/LanguageTool-3.2.oxt>)  Libre Office si impalla completamente e per poter uscire devo forzare lo spegnimento del sistema (sia su MacBookAir che su iMac). Precisamente, rimane aperta la finestra dell’Extension manager ed è impossibile chiuderla, il che provoca il blocco dello spegnimento del sistema;
2) nelle preferenze di linguaggio l’italiano non compare tra le scelte di lingua per l’interfaccia né scaricando il LanguagePack da download del sito, né scaricando l’extension dal link indicato.

Dove sbaglio?

Grazie per ogni consiglio,
Lucilla

> Il giorno 09 feb 2016, alle ore 10:31, Marina Latini <[hidden email]> ha scritto:
>
>
>
> ----- Messaggio originale -----
>> Da: "Lucilla Less" <[hidden email] <mailto:[hidden email]>>
>> A: [hidden email] <mailto:[hidden email]>
>> Inviato: Lunedì, 1 febbraio 2016 18:10:51
>> Oggetto: [it-users] LO Still: Error while installing extension LanguageTool
>>
>> Buonasera,
>> sono un utente molto junior, uso LibreOffice da pochissimo, mi scuso quindi
>> anticipatamente se le mie domande risultano scontate e se in questa mia
>> prima richiesta sono un po' "lunga".
>
> Buongiorno Lucilla e benvenuta,
>
>> Ho installato la versione "Still" di LibreOffice sul mio iMac (OS X 10.9.5) e
>> successivamente, seguendo le istruzioni, installato anche il Language
>> Service Pack.
>
> Per comodità ti incollo i link per scaricare la versione corretta per Mac:
>
> * Fresh - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/5.0.4/it/LibreOffice_5.0.4_MacOS_x86-64.dmg <http://donate.libreoffice.org/home/dl/mac-x86_64/5.0.4/it/LibreOffice_5.0.4_MacOS_x86-64.dmg>
> * Fresh - interfaccia: http://download.documentfoundation.org/libreoffice/stable/5.0.4/mac/x86_64/LibreOffice_5.0.4_MacOS_x86-64_langpack_it.dmg <http://download.documentfoundation.org/libreoffice/stable/5.0.4/mac/x86_64/LibreOffice_5.0.4_MacOS_x86-64_langpack_it.dmg>
>
> * Still - installazione: http://donate.libreoffice.org/home/dl/mac-x86_64/4.4.7/it/LibreOffice_4.4.7_MacOS_x86-64.dmg <http://donate.libreoffice.org/home/dl/mac-x86_64/4.4.7/it/LibreOffice_4.4.7_MacOS_x86-64.dmg>
> * Still - interfaccia: http://download.documentfoundation.org/libreoffice/stable/4.4.7/mac/x86_64/LibreOffice_4.4.7_MacOS_x86-64_langpack_it.dmg <http://download.documentfoundation.org/libreoffice/stable/4.4.7/mac/x86_64/LibreOffice_4.4.7_MacOS_x86-64_langpack_it.dmg>
>
> Di solito si preferisce utilizzare la versione "still" per questioni di maggiore stabilità ma se volessi provare la versione "fresh" non dovresti incappare in problematiche bloccanti.
>
>> Ho poi seguito le istruzioni per settare l'interfaccia in italiano, ma le
>> opzioni di settaggio non includono l'italiano, prevedono solo l'inglese. Fin
>> qui poco male, lo sto usando in inglese.
>
> Installati i due pacchetti dovresti andare nel menu LibreOffice -> preferenze -> LibreOffice -> Impostazioni della lingua -> Lingue
> dovresti vedere un menu di selezione della lingua dell'interfaccia.
>
>> Da qualche giorno però LO mi segnala un aggiornamento da installare (icona
>> sulla barra della Scrivania), cliccando parte il download, che non va a buon
>> fine. Copio di seguito il messaggio che compare alla fine del "Download and
>> Installation":
>>
>> Error while installing extension LanguageTool. Open source language checker.
>> The error message is: [jni_uno bridge error] UNO calling Java method
>> writeRegistryInfo: non-UNO exception occurred:
>> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
>> Unsupported major.minor version 52.0
>> java stack trace:
>> java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main :
>> Unsupported major.minor version 52.0
>> at java.lang.ClassLoader.defineClass1(Native Method)
>> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
>> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
>> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
>> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
>> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
>> at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:627)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>> at
>> com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
>> at
>> com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:380)
>>
>> The extension will not be installed.
>
> L'errore non è legato direttamente all'aggiornamento di LibreOffice ma ad un'estensione, la "Language Tool" che ha qualche problema di compatibilità con la versione di Java installata nel tuo sistema.
> La nuova versione dell'estensione poi scaricarla anche da qui:
> https://www.languagetool.org/download/LanguageTool-3.2.oxt <https://www.languagetool.org/download/LanguageTool-3.2.oxt>
>
> Sempre dal menu LibreOffice -> preferenze -> LibreOffice -> Avanzate
> controlla che versione di Java è stata rilevata da LibreOffice e, se dovessi vederne più di una, seleziona quella più recente.
>
> Per quanto riguarda l'estensione che causa l'errore, quello che ti consiglio di fare è andare nel menu Strumenti -> Gestione estensioni
> e controllare che versione di quella estensione è attualmente installata. Se dovessi trovare una versione di "Language tool" più vecchia della 3.2 disinstallala manualmente, chiudi completamente LibreOffice (cmd+q) e poi prova a reinstallare la versione 3.2 che ti ho indicato poco più in alto.
>
> Durante uno degli ultimi aggiornamenti di quell'estensione avevo riscontrato dei problemi anche io ma credevo fossero legati ad altro, a questo punto mi viene da pensare di non essere la sola ;)
>
> Facci sapere come va ;)
>
> Buona giornata,
> Marina
>
>
>
> --
> ==================================================
> Marina Latini
> Divisione LibreOffice
> [hidden email] <mailto:[hidden email]>
>
> Studio Storti S.r.l.
> Via dell'industria 8
> 36040 Torri di Quartesolo - VICENZA
> Tel 0444-782140 int.38
> Fax 0444-782141
> www.studiostorti.com <http://www.studiostorti.com/>
> ==================================================


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Italo Vignoli-6 Italo Vignoli-6
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

Cerco di riassumere la procedura da seguire:

1. Scaricare LibreOffice per Mac,

2. Scaricare il Language Pack per la lingua italiana (l'estensione
Language Tools non ha nulla a che vedere con l'interfaccia in lingua
italiana).

Java serve solo per l'uso di Base, per cui è inutile per gli altri
moduli di LibreOffice. Nel caso in cui si voglia utilizzare Java, ci
vuole il Software Development Kit, perché è presente un bug Apple che
non permette il riconoscimento del JDK da parte delle applicazioni.

1. Aprile il Pannello di Controllo Sicurezza, e selezionare "Installa
qualsiasi tipo di software" (in questo momento sto usando Ubuntu, per
cui la dicitura potrebbe essere diversa, ma il concetto è quello).
Lasciare aperto il Pannello di Controllo.

2. Installare LibreOffice.

3. Installare il Language Pack in Italiano.

4. Lanciare LibreOffice, che sarà comunque in inglese, perché bisogna
attivare il Language Pack. Aprire le Preferenze, e nel Pannello della
Lingua selezionare l'interfaccia utente in Italiano. Salvare.

5. Chiudere LibreOffice.

6. Nel Pannello di Controllo Sicurezza, ripristinare il livello di
sicurezza originario (probabilmente, il più restrittivo). Chiudere il
Pannello di COntrollo.

7. Aprile LibreOffice, che dovrebbe essere in Italiano.

Ciao, Italo

On 03/05/2016 21:33, Lucilla Less ab srl wrote:

> Ho seguito le puntuali indicazioni di Marina (grazie ancora), ma il
> problema del tool di lingua non si risolve. Continuo ad usare
> l’interfaccia in inglese.

> Ho disinstallato e reinstallato tutto un paio di volte, incluso Java.
> La versione di Java installata in entrambi i sistemi è la 8
> aggiornamento 91 (build 1.8.0_91-b14).

--
Italo Vignoli - LibreOffice Marketing & PR
mobile +39.348.5653829 - email / jabber [hidden email]
hangout / jabber [hidden email] - skype italovignoli
GPG Key ID - 0xAAB8D5C0
DB75 1534 3FD0 EA5F 56B5 FDA6 DE82 934C AAB8 D5C0

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Lucilla Less ab srl Lucilla Less ab srl
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

Grazie Italo,
mi sembra di aver fatto tutto ciò, ma ora ci riprovo seguendo passo passo le tue indicazioni.
Domanda scema: a quale Pannello di controllo ti riferisci? sarebbero le Preferenze di sistema nel caso del Mac?
Grazie,
Lucilla

> Il giorno 03 mag 2016, alle ore 21:56, Italo Vignoli <[hidden email]> ha scritto:
>
> Cerco di riassumere la procedura da seguire:
>
> 1. Scaricare LibreOffice per Mac,
>
> 2. Scaricare il Language Pack per la lingua italiana (l'estensione
> Language Tools non ha nulla a che vedere con l'interfaccia in lingua
> italiana).
>
> Java serve solo per l'uso di Base, per cui è inutile per gli altri
> moduli di LibreOffice. Nel caso in cui si voglia utilizzare Java, ci
> vuole il Software Development Kit, perché è presente un bug Apple che
> non permette il riconoscimento del JDK da parte delle applicazioni.
>
> 1. Aprile il Pannello di Controllo Sicurezza, e selezionare "Installa
> qualsiasi tipo di software" (in questo momento sto usando Ubuntu, per
> cui la dicitura potrebbe essere diversa, ma il concetto è quello).
> Lasciare aperto il Pannello di Controllo.
>
> 2. Installare LibreOffice.
>
> 3. Installare il Language Pack in Italiano.
>
> 4. Lanciare LibreOffice, che sarà comunque in inglese, perché bisogna
> attivare il Language Pack. Aprire le Preferenze, e nel Pannello della
> Lingua selezionare l'interfaccia utente in Italiano. Salvare.
>
> 5. Chiudere LibreOffice.
>
> 6. Nel Pannello di Controllo Sicurezza, ripristinare il livello di
> sicurezza originario (probabilmente, il più restrittivo). Chiudere il
> Pannello di COntrollo.
>
> 7. Aprile LibreOffice, che dovrebbe essere in Italiano.
>
> Ciao, Italo
>
> On 03/05/2016 21:33, Lucilla Less ab srl wrote:
>
>> Ho seguito le puntuali indicazioni di Marina (grazie ancora), ma il
>> problema del tool di lingua non si risolve. Continuo ad usare
>> l’interfaccia in inglese.
>
>> Ho disinstallato e reinstallato tutto un paio di volte, incluso Java.
>> La versione di Java installata in entrambi i sistemi è la 8
>> aggiornamento 91 (build 1.8.0_91-b14).
>
> --
> Italo Vignoli - LibreOffice Marketing & PR
> mobile +39.348.5653829 - email / jabber [hidden email]
> hangout / jabber [hidden email] - skype italovignoli
> GPG Key ID - 0xAAB8D5C0
> DB75 1534 3FD0 EA5F 56B5 FDA6 DE82 934C AAB8 D5C0
>
> --
> Come cancellarsi: E-mail [hidden email]
> Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
> Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
> Archivio della lista: http://listarchives.libreoffice.org/it/users/
> Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Italo Vignoli-6 Italo Vignoli-6
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool

On 03/05/2016 22:04, Lucilla Less ab srl wrote:

> Domanda scema: a quale Pannello di controllo ti riferisci? sarebbero le Preferenze di sistema nel caso del Mac?

Si, Preferenze di Sistema.

--
Italo Vignoli - LibreOffice Marketing & PR
mobile +39.348.5653829 - email / jabber [hidden email]
hangout / jabber [hidden email] - skype italovignoli
GPG Key ID - 0xAAB8D5C0
DB75 1534 3FD0 EA5F 56B5 FDA6 DE82 934C AAB8 D5C0

--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili
Lucilla Less ab srl Lucilla Less ab srl
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] LO Still: Error while installing extension LanguageTool


Signori,
mi sento molto molto scema , ma ora funziona tutto….
Grazie ancora a Italo e scusate la molesta ingerenza!
Buon proseguimento,
Lucilla

> Il giorno 03 mag 2016, alle ore 22:25, Italo Vignoli <[hidden email]> ha scritto:
>
> On 03/05/2016 22:04, Lucilla Less ab srl wrote:
>
>> Domanda scema: a quale Pannello di controllo ti riferisci? sarebbero le Preferenze di sistema nel caso del Mac?
>
> Si, Preferenze di Sistema.
>
> --
> Italo Vignoli - LibreOffice Marketing & PR
> mobile +39.348.5653829 - email / jabber [hidden email]
> hangout / jabber [hidden email] - skype italovignoli
> GPG Key ID - 0xAAB8D5C0
> DB75 1534 3FD0 EA5F 56B5 FDA6 DE82 934C AAB8 D5C0
>
> --
> Come cancellarsi: E-mail [hidden email]
> Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
> Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
> Archivio della lista: http://listarchives.libreoffice.org/it/users/
> Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili


--
Come cancellarsi: E-mail [hidden email]
Problemi? http://it.libreoffice.org/supporto/mailing-lists/come-cancellarsi/
Linee guida per postare + altro: http://wiki.documentfoundation.org/Local_Mailing_Lists/it
Archivio della lista: http://listarchives.libreoffice.org/it/users/
Tutti i messaggi inviati a questa lista vengono archiviati pubblicamente e non sono eliminabili