[it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in

classic Classic list List threaded Threaded
44 messages Options
Next » 123 « Prev
alessandro-2 alessandro-2
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Un ringraziamento a Renato Ferrari e a Paolo Pedaletti sono riusciti a risolvermi il problema:
Renato Ferrari aprendo il file con Kspread

Paolo Pedaletti invece con questa procedura


> errore di lettura Errore di formato nel file nel sottodocumento
> content.xml in 2,425430 (riga, colonna)
>
> cosa ho fatto:
> creo una dir apposta "tmp"
> copio li' il file .ods
> decomprimo con unzip
>
> riformatto con xmlindent:
> # xmlindent -o content.2.xml content.xml
>
> ora content.2.xml contiene gli stessi dati di content.xml ma in formato
> piu' leggibile
>
> li ho aperti con firefox
> # firefox content.2.xml content.xml
>
> il parser di firefox mi dice dove c'e' l'errore (stesso punto nei due
> file, ma in posizioni diverse a causa della riformattazione)
>
> contemporaneamente apro content.2.xml con gvim/vim
> e modifico "opportunamente" il file nei punti incriminati (c'era una
> ripetizione sulla stessa riga)
>
> (salvo e ricarico per verificare che l'errore del parser di firefox
> scompare)
>
> verifica:
> # xmllint --format  content.2.xml
>
> ricomprimo (nella dir a monte):
>
> zip -r  ../CaricoSett.5.zip mimetype .
>
> soffice CaricoSett.5.zip
>
Grazie a tutti

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Felix-2 Felix-2
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by carlo.strata
Il 02/11/2011 16:29, Carlo Strata ha scritto:

>
> (...) Tieni conto che sulla qualità, anche su bug segnalati su
> indicazioni mie e tue si sono fatti passi in avanti (una trentina di
> fix tra RC1 ed RC2)
> http://download.documentfoundation.org/libreoffice/src/bugfixes-libreoffice-3-4-release-3.4.4.1.log 
>
> http://dev-builds.libreoffice.org/pre-releases/src/bugfixes-libreoffice-3-4-4-release-3.4.4.2.log 
>
>
> In questo modo la tua opinione dovrà essere rimodulata almeno sulla
> 3.4.4-RC2 ed avrai dato anche tu un sano e costruttivo contributo attivo.
>
> Facci sapere e buona giornata,
>
> Carlo

Bene, provato Libò 3.4.4-RC con Win-XP in Vbox ma il problema del
rendering non mi pare sia ancora stato risolto.
Non credo che sotto Linux la cosa possa cambiare ma proverò anche quella.
Per il resto: tempistica di avvio, funzionalità, etc... Libò conferma di
non avere nulla da invidiare al vecchio OpenOffice che, a mio
modestissimo parere, oramai comincia a mostrare i segni dell'età ;-)))
Saluti,
Felice

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

carlo.strata carlo.strata
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Il 03/11/2011 07:46, Felix ha scritto:

> Il 02/11/2011 16:29, Carlo Strata ha scritto:
>>
>> (...) Tieni conto che sulla qualità, anche su bug segnalati su
>> indicazioni mie e tue si sono fatti passi in avanti (una trentina di
>> fix tra RC1 ed RC2)
>> http://download.documentfoundation.org/libreoffice/src/bugfixes-libreoffice-3-4-release-3.4.4.1.log 
>>
>> http://dev-builds.libreoffice.org/pre-releases/src/bugfixes-libreoffice-3-4-4-release-3.4.4.2.log 
>>
>>
>> In questo modo la tua opinione dovrà essere rimodulata almeno sulla
>> 3.4.4-RC2 ed avrai dato anche tu un sano e costruttivo contributo
>> attivo.
>>
>> Facci sapere e buona giornata,
>>
>> Carlo
>
> Bene, provato Libò 3.4.4-RC con Win-XP in Vbox ma il problema del
> rendering non mi pare sia ancora stato risolto.
> Non credo che sotto Linux la cosa possa cambiare ma proverò anche quella.
> Per il resto: tempistica di avvio, funzionalità, etc... Libò conferma
> di non avere nulla da invidiare al vecchio OpenOffice che, a mio
> modestissimo parere, oramai comincia a mostrare i segni dell'età ;-)))
> Saluti,
> Felice
>

Grazie per i test, Felice: un mesetto fa avevo parlato con Italo
(Vignoli) circa il rendering e mi aveva confermato che erano consci di
questo a causa di una parziale riscrittura del motore di Calc e stavano
cercando una soluzione che compensasse i comportamenti di rendering
dovuti alla parziale riscrittura in Libò 3.4.x in modo da riottenere
rendering perfetti.

Questo problema dovrebbe scomparire per definizione sulla serie 3.5.
A questo punto e visto che hai la macchina virtuale (VirtualBox) perché
non lo provi e ce lo confermi? Direi su Windows dato che è più che altro
per te una piattaforma di test, così da non intaccare la tua
installazione di "produzione" (Ubuntu).

Basta che tu vada a scaricare una delle build di test
http://wiki.documentfoundation.org/Testing_Daily_Builds

che ti porterà qui (è l'unica cartella Windows non vuota e con una build
sulla serie 3.5)
http://dev-builds.libreoffice.org/daily/MinGW_cross-compilation/master/current/

è la 3.5.0m1, ma è solo per controllare che il rendering delle immagini
delle firme nel tuo grande file .ods sia corretto (o almeno migliori).
Attenzione che questa è anche quella che ha provato (non so esattamente
a quale punto si sia) il porting dello sviluppo da Microsoft Visual
Studio a MinGW, come si è ricordato ieri in un thread che ho aperto io
sulla piattaforma Win64...

Ovviamente quando hai un quarto d'ora per provarlo...

Buona serata,

Carlo

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

--
ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel./fax +39.041.822.0665
cell. +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
carlo.strata@tiscali.it
PEC: carlo.strata@ingpec.eu


carlo.strata carlo.strata
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by alessandro-2
Il 02/11/2011 22:22, Alessandro ha scritto:

> Un ringraziamento a Renato Ferrari e a Paolo Pedaletti sono riusciti a risolvermi il problema:
> Renato Ferrari aprendo il file con Kspread
>
> Paolo Pedaletti invece con questa procedura
>
>
>> errore di lettura Errore di formato nel file nel sottodocumento
>> content.xml in 2,425430 (riga, colonna)
>>
>> cosa ho fatto:
>> creo una dir apposta "tmp"
>> copio li' il file .ods
>> decomprimo con unzip
>>
>> riformatto con xmlindent:
>> # xmlindent -o content.2.xml content.xml
>>
>> ora content.2.xml contiene gli stessi dati di content.xml ma in formato
>> piu' leggibile
>>
>> li ho aperti con firefox
>> # firefox content.2.xml content.xml
>>
>> il parser di firefox mi dice dove c'e' l'errore (stesso punto nei due
>> file, ma in posizioni diverse a causa della riformattazione)
>>
>> contemporaneamente apro content.2.xml con gvim/vim
>> e modifico "opportunamente" il file nei punti incriminati (c'era una
>> ripetizione sulla stessa riga)
>>
>> (salvo e ricarico per verificare che l'errore del parser di firefox
>> scompare)
>>
>> verifica:
>> # xmllint --format  content.2.xml
>>
>> ricomprimo (nella dir a monte):
>>
>> zip -r  ../CaricoSett.5.zip mimetype .
>>
>> soffice CaricoSett.5.zip
>>
> Grazie a tutti
>

Molto interessante: a completamento dell'opera sarebbe bello sapere se
si apriva anche con Gnumeric e con quale versione.
Ovviamente oltre alla versione, non precisata, del citato KSpread...

Buona giornata,

Carlo

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

--
ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel./fax +39.041.822.0665
cell. +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
carlo.strata@tiscali.it
PEC: carlo.strata@ingpec.eu


Paolo Pedaletti Paolo Pedaletti
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

ciao Carlo,

> Molto interessante: a completamento dell'opera sarebbe bello sapere se
> si apriva anche con Gnumeric e con quale versione.

si, anche gnumeric 1.10.13 ubuntu 10.04

> Ovviamente oltre alla versione, non precisata, del citato KSpread...

a quanto pare e' molto piu' "robusto" nel correggere al volo alcuni
possibili errori presenti all'interno dei file

ciao

--
Paolo Pedaletti
www.openlabs.it
http://www.ecis.eu/documents/Finalversion_Consumerchoicepaper.pdf
http://linguistico.sourceforge.net/pages/traduzioni/ms_illegal.html


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

italovignoli italovignoli
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

On 11/4/11 10:59 AM, Paolo Pedaletti wrote:

> a quanto pare e' molto piu' "robusto" nel correggere al volo alcuni
> possibili errori presenti all'interno dei file

Oppure hanno un parser più "liberale" verso gli errori nel formato XML.

In realtà, l'uso del formato XML per i contenuti in tutti i formati ODF
può creare dei problemi quando nel testo - incollato senza precauzioni,
ovvero senza usare "incolla speciale > testo non formattato" - ci sono
caratteri "sporchi" o ripetizioni, che non dovrebbero esistere in un
file XML "pulito".

In questo senso, il parser di LibreOffice (che è lo stesso di OOo)
rappresenta la "reference implementation" ed è abbastanza severo, per
cui sei il file XML non rispetta gli standard W3C è molto probabile che
non venga letto.

In effetti, se un file non si apre con LibreOffice bisognerebbe sempre
provare con AbiWord/Gnumeric, oppure con KOffice/Calligra.

Ciao, Italo

--
Italo Vignoli
[hidden email]
mobile +39.348.5653829
VoIP +39.02.320621813
skype italovignoli

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Italo Vignoli
Director - The Document Foundation
carlo.strata carlo.strata
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by carlo.strata
Il 03/11/2011 20:28, Carlo Strata ha scritto:

> Il 03/11/2011 07:46, Felix ha scritto:
>> Il 02/11/2011 16:29, Carlo Strata ha scritto:
>>>
>>> (...) Tieni conto che sulla qualità, anche su bug segnalati su
>>> indicazioni mie e tue si sono fatti passi in avanti (una trentina di
>>> fix tra RC1 ed RC2)
>>> http://download.documentfoundation.org/libreoffice/src/bugfixes-libreoffice-3-4-release-3.4.4.1.log 
>>>
>>> http://dev-builds.libreoffice.org/pre-releases/src/bugfixes-libreoffice-3-4-4-release-3.4.4.2.log 
>>>
>>>
>>> In questo modo la tua opinione dovrà essere rimodulata almeno sulla
>>> 3.4.4-RC2 ed avrai dato anche tu un sano e costruttivo contributo
>>> attivo.
>>>
>>> Facci sapere e buona giornata,
>>>
>>> Carlo
>>
>> Bene, provato Libò 3.4.4-RC con Win-XP in Vbox ma il problema del
>> rendering non mi pare sia ancora stato risolto.
>> Non credo che sotto Linux la cosa possa cambiare ma proverò anche
>> quella.
>> Per il resto: tempistica di avvio, funzionalità, etc... Libò conferma
>> di non avere nulla da invidiare al vecchio OpenOffice che, a mio
>> modestissimo parere, oramai comincia a mostrare i segni dell'età ;-)))
>> Saluti,
>> Felice
>>
>
> Grazie per i test, Felice: un mesetto fa avevo parlato con Italo
> (Vignoli) circa il rendering e mi aveva confermato che erano consci di
> questo a causa di una parziale riscrittura del motore di Calc e
> stavano cercando una soluzione che compensasse i comportamenti di
> rendering dovuti alla parziale riscrittura in Libò 3.4.x in modo da
> riottenere rendering perfetti.
>
> Questo problema dovrebbe scomparire per definizione sulla serie 3.5.
> A questo punto e visto che hai la macchina virtuale (VirtualBox)
> perché non lo provi e ce lo confermi? Direi su Windows dato che è più
> che altro per te una piattaforma di test, così da non intaccare la tua
> installazione di "produzione" (Ubuntu).
>
> Basta che tu vada a scaricare una delle build di test
> http://wiki.documentfoundation.org/Testing_Daily_Builds
>
> che ti porterà qui (è l'unica cartella Windows non vuota e con una
> build sulla serie 3.5)
> http://dev-builds.libreoffice.org/daily/MinGW_cross-compilation/master/current/ 
>
>
> è la 3.5.0m1, ma è solo per controllare che il rendering delle
> immagini delle firme nel tuo grande file .ods sia corretto (o almeno
> migliori).
> Attenzione che questa è anche quella che ha provato (non so
> esattamente a quale punto si sia) il porting dello sviluppo da
> Microsoft Visual Studio a MinGW, come si è ricordato ieri in un thread
> che ho aperto io sulla piattaforma Win64...

Ciao Felice,

è proprio il caso di vivere, ed essere, il tuo nome:
https://bugs.freedesktop.org/show_bug.cgi?id=37083

Appena corretto nel master, la linea di sviluppo principale, ad occhio
dobbiamo ringraziare anche Italo (!) che l'avrà riportata all'attenzione
a causa dei nostri scambi di messaggi... ;-)

Vediamo se faranno anche per questo fix un "cherry picking" del bug per
la 3.4.4-RC3/final.

Carlo

>
> Ovviamente quando hai un quarto d'ora per provarlo...
>
> Buona serata,
>
> Carlo
>

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

--
ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel./fax +39.041.822.0665
cell. +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
carlo.strata@tiscali.it
PEC: carlo.strata@ingpec.eu


Ferrari Renato Maria Ferrari Renato Maria
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by carlo.strata
Il venerdì 4 novembre 2011, Carlo Strata ha scritto:
> > Grazie a tutti
>
> Molto interessante: a completamento dell'opera sarebbe bello sapere se
> si apriva anche con Gnumeric e con quale versione.
> Ovviamente oltre alla versione, non precisata, del citato KSpread...
>
> Buona giornata,
>
> Carlo

mi sembrava di averlo detto
comunque:
slackware 12.2
kde 3.5 fornito con slackware 12.2
in più, ho installato gnomeslacky, scaricata dal sito slacky.eu


--


Linux Registered User #219791
Linux Registered Machine #104061
[hidden email]

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

carlo.strata carlo.strata
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Il 04/11/2011 19:07, Renato Ferrari ha scritto:

> Il venerdì 4 novembre 2011, Carlo Strata ha scritto:
>>> Grazie a tutti
>> Molto interessante: a completamento dell'opera sarebbe bello sapere se
>> si apriva anche con Gnumeric e con quale versione.
>> Ovviamente oltre alla versione, non precisata, del citato KSpread...
>>
>> Buona giornata,
>>
>> Carlo
> mi sembrava di averlo detto
> comunque:
> slackware 12.2
> kde 3.5 fornito con slackware 12.2
> in più, ho installato gnomeslacky, scaricata dal sito slacky.eu
>

Ciao Renato,

era solo perché rimanesse come informazione utile. Se indichi la
versione di KSpread e non quella di KDE e della Slackware è più
importante perché dedurre la versione di KSpread è ora fattibile, ma tra
qualche mese magari meno...

Per dirti nel mio notebook che uso al 99,9% in Gnome (2.30.2) ho anche
*KDE 4.6.3* in cui è installato e via via aggiornato la seguente
versione di:
KSpread
*Versione 2.3.1*
Con piattaforma di sviluppo KDE 4.6.3 (4.6.3) "release 4"

Oggi con la possibilità di aggiornare online la versione di KDE e quella
di KOffice/Calligra non sono per forza di cose legate.

Tutto qui: è solo per aiutare i test e poter effettuare un confronto di
comportamenti e di sensibilità alla bontà dei vari xml parser...

Buona serata,

Carlo


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

--
ing. Carlo Strata
-
via Botticelli 1/4
30031 Dolo - VE
Italia - Italy
-
tel./fax +39.041.822.0665
cell. +39.347.85.69.824
Skype carlo.strata
Google carlo.strata.69
-
carlo.strata@tiscali.it
PEC: carlo.strata@ingpec.eu


alessandro-2 alessandro-2
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Il 04/11/2011 20:55, Carlo Strata ha scritto:

> Il 04/11/2011 19:07, Renato Ferrari ha scritto:
>> Il venerdì 4 novembre 2011, Carlo Strata ha scritto:
>>>> Grazie a tutti
>>> Molto interessante: a completamento dell'opera sarebbe bello sapere se
>>> si apriva anche con Gnumeric e con quale versione.
>>> Ovviamente oltre alla versione, non precisata, del citato KSpread...
>>>
>>> Buona giornata,
>>>
>>> Carlo
>> mi sembrava di averlo detto
>> comunque:
>> slackware 12.2
>> kde 3.5 fornito con slackware 12.2
>> in più, ho installato gnomeslacky, scaricata dal sito slacky.eu
>>
>
> Ciao Renato,
>
> era solo perché rimanesse come informazione utile. Se indichi la
> versione di KSpread e non quella di KDE e della Slackware è più
> importante perché dedurre la versione di KSpread è ora fattibile, ma
> tra qualche mese magari meno...
>
> Per dirti nel mio notebook che uso al 99,9% in Gnome (2.30.2) ho anche
> *KDE 4.6.3* in cui è installato e via via aggiornato la seguente
> versione di:
> KSpread
> *Versione 2.3.1*
> Con piattaforma di sviluppo KDE 4.6.3 (4.6.3) "release 4"
>
> Oggi con la possibilità di aggiornare online la versione di KDE e
> quella di KOffice/Calligra non sono per forza di cose legate.
>
> Tutto qui: è solo per aiutare i test e poter effettuare un confronto
> di comportamenti e di sensibilità alla bontà dei vari xml parser...
>
> Buona serata,
>
> Carlo
>
>

Ciao A tutti, mi è risuccesso, a questo punto penso che sia un bug ed ho
capito cosa provoca il problema almeno una possibilità.
Il file calc contiene dei link a dei pulsanti su pagine protette (sotto
password) su internet. quando il sito non è raggiungibile l'apertura del
file diventa impossibile da Calc sia su Liberoffice, sia su Openoffice,
stranamente il medesimo file viene tranquillamente aperto da  Gnumeric
vers. 1.10.17 usata su ubuntu 11.10.
All'apertura di Gnumeric compare una finestra che segnala la presenza di
link a queste immagini premendo fine li cancella ed apre il file.
Con Calc sia di Liberoffice che di Openoffice questa cosa non viene
evidenziata il file di 47K per es dopo 10 minuti di tentativi ad aprirsi
da uno schermo bianco...
Provate per credere...
Ciao e spero possa essere utile

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Ferrari Renato Maria Ferrari Renato Maria
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by carlo.strata
Il venerdì 4 novembre 2011, Carlo Strata ha scritto:

> Il 04/11/2011 19:07, Renato Ferrari ha scritto:
> > Il venerdì 4 novembre 2011, Carlo Strata ha scritto:
> >>> Grazie a tutti
> >>
> >> Molto interessante: a completamento dell'opera sarebbe bello sapere se
> >> si apriva anche con Gnumeric e con quale versione.
> >> Ovviamente oltre alla versione, non precisata, del citato KSpread...
> >>
> >> Buona giornata,
> >>
> >> Carlo
> >
> > mi sembrava di averlo detto
> > comunque:
> > slackware 12.2
> > kde 3.5 fornito con slackware 12.2
> > in più, ho installato gnomeslacky, scaricata dal sito slacky.eu
>
> Ciao Renato,
>
> era solo perché rimanesse come informazione utile. Se indichi la
> versione di KSpread e non quella di KDE e della Slackware è più
> importante perché dedurre la versione di KSpread è ora fattibile, ma tra
> qualche mese magari meno...

hai ragione, non ci avevo pensato: do' per scontato che tutti facciano come
me, e si tengano la distribuzione nativa!!!!
:)

il mio kspread è la versione 1.6.3 fornita con kde 3.5.10

--


Linux Registered User #219791
Linux Registered Machine #104061
[hidden email]

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Andrea Pescetti Andrea Pescetti
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by italovignoli
Il 04/11/2011Italo Vignoli ha scritto:
> l'uso del formato XML per i contenuti in tutti i formati ODF
> può creare dei problemi quando nel testo - incollato senza precauzioni,
> ovvero senza usare "incolla speciale>  testo non formattato" - ci sono
> caratteri "sporchi" o ripetizioni, che non dovrebbero esistere in un
> file XML "pulito".

Per fortuna questo dettaglio non e' vero, altrimenti sarebbe una grave
vulnerabilita' di sicurezza: sicuramente il problema non sta nel fatto
che salvando contenuto "sporco" sotto forma di file XML si confondono
contenuto e descrizione del documento.

Il resto che scrivi (parser rigido, reference implementation) e' vero ma
non ha nulla a che fare con questo. Mi sembra giusto sottolinearlo prima
che qualcuno deduca, sbagliando, che e' piu' sicuro salvare in formato
DOC o RTF...

Ciao,
   Andrea.

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

italovignoli italovignoli
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

On 11/5/11 2:18 PM, Andrea Pescetti wrote:

> Per fortuna questo dettaglio non e' vero, altrimenti sarebbe una grave
> vulnerabilita' di sicurezza: sicuramente il problema non sta nel fatto
> che salvando contenuto "sporco" sotto forma di file XML si confondono
> contenuto e descrizione del documento.

Infatti, non intendevo questo. E' che se tra due tag XML finiscono dei
contenuti a loro volta taggati, questo può creare qualche problema al
parser (di lettura, non di sicurezza).

--
Italo Vignoli
[hidden email]
mobile +39.348.5653829
VoIP +39.02.320621813
skype italovignoli

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Italo Vignoli
Director - The Document Foundation
Andrea Pescetti Andrea Pescetti
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Il 05/11/2011 Italo Vignoli ha scritto:
> On 11/5/11 2:18 PM, Andrea Pescetti wrote:
>> Per fortuna questo dettaglio non e' vero, altrimenti sarebbe una grave
>> vulnerabilita' di sicurezza: sicuramente il problema non sta nel fatto
>> che salvando contenuto "sporco" sotto forma di file XML si confondono
>> contenuto e descrizione del documento.
>
> Infatti, non intendevo questo. E' che se tra due tag XML finiscono dei
> contenuti a loro volta taggati, questo può creare qualche problema al
> parser (di lettura, non di sicurezza).

No! E' proprio questo il punto: OpenOffice.org e LibreOffice non sono
scritti cosi' male da far si' che questo possa succedere. Non puo'
succedere, e se succedesse avrebbe implicazioni di sicurezza perche'
sarebbe possibile ingannare il parser in modo da confondere contenuto e
struttura. Ma, dato che non succede, possiamo stare tranquilli.

Ciao,
   Andrea.

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Felix-2 Felix-2
Reply | Threaded
Open this post in threaded view
|

Rendering erranto in LibreOffice (era Re: [it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in)

In reply to this post by carlo.strata
Il 04/11/2011 14:17, Carlo Strata ha scritto:
>> Grazie per i test, Felice:

Di nulla... è un dovere oltre che un piacere ;-)

>> un mesetto fa avevo parlato con Italo (Vignoli) circa il rendering e
>> mi aveva confermato che erano consci di questo a causa di una
>> parziale riscrittura del motore di Calc e stavano cercando una
>> soluzione che compensasse i comportamenti di rendering dovuti alla
>> parziale riscrittura in Libò 3.4.x in modo da riottenere rendering
>> perfetti.
>>
>> Questo problema dovrebbe scomparire per definizione sulla serie 3.5.
>> A questo punto e visto che hai la macchina virtuale (VirtualBox)
>> perché non lo provi e ce lo confermi? Direi su Windows dato che è più
>> che altro per te una piattaforma di test, così da non intaccare la
>> tua installazione di "produzione" (Ubuntu).

Fatto... provata la versione Winzoz in Vbox e tentato di provare anche
la versione per Linux (amd64).

La Windows XP (unica che ha funzionato) non ha prodotto miglioramenti...
il rendering è sempre scorretto :-(((

In Ubuntu, nonostante non c'erano installazioni precedenti le cui tracce
provvedo sempre a cancellare anche "a manina" data l'abitudine che hanno
sia Libò sia OOo a persistere, Libò non si è mai avviato :-(((

Forse dovrei provare ad installare la versione a 32bit... ci provo
domani e Ti confermo che resto sempre a completa disposizione per
qualsiasi ulteriore test... anche in macchina principale in quanto ho
sempre disponibile backups recentissimi per cui non ci sono problemi a
"sporcare" la macchina :-)))

Saluti e mille grazie anche al buon Italo per la sua disponibilità,
Felice

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Valter Mura (Google Drive) Valter Mura (Google Drive)
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

In reply to this post by Andrea Pescetti
Il 05/11/2011 18:45, Andrea Pescetti ha scritto:

> Il 05/11/2011 Italo Vignoli ha scritto:
>> On 11/5/11 2:18 PM, Andrea Pescetti wrote:
>>> Per fortuna questo dettaglio non e' vero, altrimenti sarebbe una grave
>>> vulnerabilita' di sicurezza: sicuramente il problema non sta nel fatto
>>> che salvando contenuto "sporco" sotto forma di file XML si confondono
>>> contenuto e descrizione del documento.
>>
>> Infatti, non intendevo questo. E' che se tra due tag XML finiscono dei
>> contenuti a loro volta taggati, questo può creare qualche problema al
>> parser (di lettura, non di sicurezza).
>
> No! E' proprio questo il punto: OpenOffice.org e LibreOffice non sono
> scritti cosi' male da far si' che questo possa succedere. Non puo'
> succedere, e se succedesse avrebbe implicazioni di sicurezza perche'
> sarebbe possibile ingannare il parser in modo da confondere contenuto e
> struttura. Ma, dato che non succede, possiamo stare tranquilli.

Andrea, hai dei riferimenti per queste specifiche, anche se in inglese?

Anche se molto tecnici, potrebbe tornarci utile

Grazie, ciao,
--
Valter
*Open Source is better!*
KDE: www.kde.org
Kubuntu: www.kubuntu.org
LibreOffice: www.libreoffice.org

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Andrea Pescetti Andrea Pescetti
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] [RISOLTO]errore di lettura Errore di formato nel file nel sottodocumento content.xml in

Valter Mura ha scritto:
> Il 05/11/2011 18:45, Andrea Pescetti ha scritto:
>> sarebbe possibile ingannare il parser in modo da confondere contenuto e
>> struttura. Ma, dato che non succede, possiamo stare tranquilli.
>
> Andrea, hai dei riferimenti per queste specifiche, anche se in inglese?
> Anche se molto tecnici, potrebbe tornarci utile

Penso proprio che nessuno possa trovarlo utile, comunque parliamo del
capitolo 1 di
http://docs.oasis-open.org/office/v1.1/OS/OpenDocument-v1.1-html/OpenDocument-v1.1.html
(idem per ODF 1.2) e del capitolo 2 di
http://www.w3.org/TR/REC-xml/
entrambi di contenuto molto tecnico perche' sono pensati per essere
trascritti in un linguaggio di programmazione.

Ciao,
   Andrea.

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Felix-2 Felix-2
Reply | Threaded
Open this post in threaded view
|

Re: Rendering erranto in LibreOffice (era Re: [it-users] errore di lettura Errore di formato nel file nel sottodocumento content.xml in)

In reply to this post by Felix-2
EUREKAAAAAAAA!!! :-)))))))))

Installata in Debian Squeeze in Vbox (32bit) la seguente beta:
master~2011-11-05_01.05.12_LibO-Dev_OOO350m1_Linux_x86_install-deb_en-US.tar.gz

scaricata da questo link:
http://dev-builds.libreoffice.org/daily/Linux_x86_Release_Configuration/master/2011-11-05_01.05.12/

Il rendering è perfetto, semplicemente perfetto.

Un ringraziamento a te Carlo (a proposito, auguri posticipati), ad Italo
Vignoli ed allo staff di Libò.

Ora Libò è davvero qualche spanna sopra OOo :-))))))

Felice

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

italovignoli italovignoli
Reply | Threaded
Open this post in threaded view
|

[it-users] Re: Rendering errato in LibreOffice

On 11/06/2011 09:18 PM, Felix wrote:
> EUREKAAAAAAAA!!! :-)))))))))
> Il rendering è perfetto, semplicemente perfetto.

Sono molto contento che il problema sia stato risolto. Questo dimostra
che gli sviluppatori stanno andando nella giusta direzione.

> Un ringraziamento a te Carlo (a proposito, auguri posticipati), ad Italo
> Vignoli ed allo staff di Libò.

Mi sembra opportuno chiarire che io non ho alcun merito nella soluzione
dei problemi tecnici.

--
Italo Vignoli
[hidden email]
mobile +39.348.5653829
VoIP +39.02.320621813
skype italovignoli

--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Italo Vignoli
Director - The Document Foundation
Felix-2 Felix-2
Reply | Threaded
Open this post in threaded view
|

Re: [it-users] Re: Rendering errato in LibreOffice

Il 06/11/2011 21:23, Italo Vignoli ha scritto:
> On 11/06/2011 09:18 PM, Felix wrote:
>> EUREKAAAAAAAA!!! :-)))))))))
>> Il rendering è perfetto, semplicemente perfetto.
> Sono molto contento che il problema sia stato risolto. Questo dimostra
> che gli sviluppatori stanno andando nella giusta direzione.

La mia ultima prova era in Squeeze che ho in VBox... ieri però, in
Winzoz XP, il problema ha mostrato di persistere :-(((
Nun me ne potrebbe fregà de meno se non fosse per il fatto che, sotto
Ubuntu 11.04, la DEB a 64bit non si avviava mentre l'installazione della
32bit (con l'opzione --force-architecture) non si installava continuando
a dare errori.
Quindi il problema è risolto parzialmente e, al momento, solo con la
32bit installata su 32bit nativa.

>> Un ringraziamento a te Carlo (a proposito, auguri posticipati), ad Italo
>> Vignoli ed allo staff di Libò.
> Mi sembra opportuno chiarire che io non ho alcun merito nella soluzione
> dei problemi tecnici.

Comunque ti sei interessato ;-)))
Resto a disposizione per tutti i test che volete :-)))
Risaluti,
Felice


--
Unsubscribe instructions: E-mail to [hidden email]
Posting guidelines + more: http://wiki.documentfoundation.org/Netiquette
List archive: http://listarchives.libreoffice.org/it/users/
All messages sent to this list will be publicly archived and cannot be deleted

Next » 123 « Prev