min version of gtk3

classic Classic list List threaded Threaded
4 messages Options
Caolán McNamara Caolán McNamara
Reply | Threaded
Open this post in threaded view
|

min version of gtk3

There was a theming change in gtk3 3.20.0 and we support the old scheme
before that point and the new scheme after that point.

Things would be a lot simpler if the min version of gtk3 was 3.20.0, is
there any distributions or individual devs for whom that would cause a
problem ?
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Jan-Marek Glogowski Jan-Marek Glogowski
Reply | Threaded
Open this post in threaded view
|

Re: min version of gtk3

Am 01.12.2017 um 13:43 schrieb Caolán McNamara:
> There was a theming change in gtk3 3.20.0 and we support the old scheme
> before that point and the new scheme after that point.
>
> Things would be a lot simpler if the min version of gtk3 was 3.20.0, is
> there any distributions or individual devs for whom that would cause a
> problem ?

Ubuntu Xenial (16.04) has 3.18.9-1ubuntu3, which I backported for our
trusty master tinderbox.

I guess we won't deliver any 6+ version of LO for trusty and won't have
problems with our next OS release.

You want to drop Gtk+ < 3.20.0 support in or after 6.0?

Jan-Marek
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Caolán McNamara Caolán McNamara
Reply | Threaded
Open this post in threaded view
|

Re: min version of gtk3

On Fri, 2017-12-01 at 14:25 +0100, Jan-Marek Glogowski wrote:

> Am 01.12.2017 um 13:43 schrieb Caolán McNamara:
> > There was a theming change in gtk3 3.20.0 and we support the old
> > scheme before that point and the new scheme after that point.
> >
> > Things would be a lot simpler if the min version of gtk3 was
> > 3.20.0, is there any distributions or individual devs for whom that
> > would cause a problem ?
>
> Ubuntu Xenial (16.04) has 3.18.9-1ubuntu3, which I backported for our
> trusty master tinderbox.
>
> I guess we won't deliver any 6+ version of LO for trusty and won't
> have problems with our next OS release.
>
> You want to drop Gtk+ < 3.20.0 support in or after 6.0?

For me I was thinking for > 6.0, scarabeus (for suse) was wondering
additionally about 6.0
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice
Caolán McNamara Caolán McNamara
Reply | Threaded
Open this post in threaded view
|

Re: min version of gtk3

On Fri, 2017-12-01 at 13:31 +0000, Caolán McNamara wrote:
> On Fri, 2017-12-01 at 14:25 +0100, Jan-Marek Glogowski wrote:
> > You want to drop Gtk+ < 3.20.0 support in or after 6.0?
>
> For me I was thinking for > 6.0, scarabeus (for suse) was wondering
> additionally about 6.0

I've bumped the min requirement to build and run to gtk3 3.18 and
propose to raise that to 3.20 for master if there's no objection to
that https://gerrit.libreoffice.org/#/c/45735/
_______________________________________________
LibreOffice mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/libreoffice